Tag Info

Hot answers tagged

4

This problem can be tackled either in roundcube, dovecot or your username-backend. Roundcube has option to auto append domain parts if no domain provided (as proposed by Kondybas). But it won't too useful in your case. Of course you can patch roundcube (with PHP language) to adding your logic. Dovecot has option to strip domain (as proposed in Dovecot ...


3

You're probably missing the intermediate certificate. AFAIK Dovecot does not have a chain certificate option as you have in for instance Apache, you need to concatenate the intermediate certificate into a single file with your public certificate: The signed certificate for your domain Intermediate CA cert Root CA cert Get correct intermediate ...


3

Despite what I configure or do. I get always the same result with dig (like if the data comes from other place bit not my zone file): In your output I notice you have 2 dns servers. ;; AUTHORITY SECTION: mydomain.com. 63046 IN NS dns1.kontent.com. mydomain.com. 63046 IN NS dns2.kontent.com. Your domain server is ...


3

Ordering of firewall rules is significant. You need to move your rules to accept traffic on 993 and 995 above the log and reject rules.


3

There you go (from imap-commands.c)! Hope it helps yoi alot! static const struct command imap4rev1_commands[] = { { "CAPABILITY", cmd_capability, 0 }, { "LOGOUT", cmd_logout, COMMAND_FLAG_BREAKS_MAILBOX }, { "NOOP", cmd_noop, COMMAND_FLAG_BREAKS_SEQS }, { "APPEND", cmd_append, COMMAND_FLAG_BREAKS_SEQS }, ...


2

I now have my failregex filter working. I tried using the '^'at the start and placed '$' at the end and my filter started working. Although the on-line Regex Test web page shows that my filter matches the target without these, I guess that when the filter is actually applied to a test, the start and end of the target string has to be set with them.


2

Launch doveconf -a | grep _valid_ You have to set that variables to something like that: first_valid_uid = 26 last_valid_uid = 0 first_valid_gid = 6 last_valid_gid = 0


2

Change your config-file with SQL-query like that: . . . . . password_query= SELECT username as user, \ password \ FROM mailbox \ WHERE username = '%n@%d' \ AND active=1 user_query = SELECT maildir AS userdb_home, \ 150 AS userdb_uid, \ ...


2

RoundCube have an option called username_domain // Automatically add this domain to user names for login // Only for IMAP servers that require full e-mail addresses for login // Specify an array with 'host' => 'domain' values to support multiple hosts // Supported replacement variables: // %h - user's IMAP hostname // %n - hostname ...


2

If you already know all the FQDN's you are going to need, buy a SAN-certificate. If you need to be flexible with you certificates you can try and setup a nginx smtp proxy. I looked at the documentation and from the looks it should support SNI but it's not going to be an easy setup I think: http://nginx.org/en/docs/mail/ngx_mail_ssl_module.html Update: two ...


1

The permissions are set by the directory_mode and mode settings in the maildir_home transport. The group as well. You may want to look at using a shared namespace in Dovecot to allow sharing the folder.


1

A couple of possible solutions: Stand up Dovecot on server1, and configure it to use login referrals to send the clients over to server2. If your clients support login referrals, this could be the simplest solution. It would introduce a small delay with each new login, as the client connected to server1 and then got sent over to server2. Stand up Dovecot ...


1

Perhaps an easier solution is to have it all running on server1 and just tunnel pop/pops and imap/imaps to server2 (autossh is a simple solution, but there are probably some better ways). If you run autossh to maintain a ssh connection from server2 to server1: autossh -M 3319 -4 -R 993:localhost:993 -R 995:localhost:995 -NC server1 -f You could throw ...


1

Bot: convert self-answered-post-in-question-section to CW Canonical mapping fixed this problem for me. Putting this line joey.domain2@domain1.com joey@domain2.com in /etc/postfix/canonical allowed me to send mail from Domain 2. I set Webmin to read hash:/etc/postfix/canonical as all three canonical normal/send/receive mapping files.


1

Set auth_username_format to %Lu.%Ld It will result username.domain in lowercase. See this wiki for complete variables from dovecot


1

Note: smtp != smtpd smtp act as smtp client used to sending email smtpd act as smtp server used to receiving email Parameter smtp_sasl_type with dovecot was unsupported. Maybe you mean smtpd_sasl_type = dovecot instead.


1

Check this page for IMAP testing example https://workaround.org/ispmail/lenny/test-fetching-with-imap-and-pop3


1

As per @HBruijn's comment, Gmail only supports retrieving email through POP3, not IMAP. This has been confirmed on their product forums Both Gmail and Dovecot support POP3 over SSL, which you should be able to use by opening port 995 on your firewalls, and directing Gmail at it.


1

SF problem with SU solution :D Ensure thunderbird computer can't connect to IMAP server (turn off wifi/pull the LAN cable). You don't want to Thunderbird synchronize itself with outdated backup. Run Thunderbird. While offline, copy new email from IMAP account in Thunderbird to Thunderbird Local Folder. It will backup the email to your computer. Connect ...



Only top voted, non community-wiki answers of a minimum length are eligible