Tag Info

New answers tagged

1

Found this solution: add this on /etc/dovecot/conf.d/20-lmtp.conf: protocol lmtp { postmaster_address = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf # required mail_plugins = quota } probably this was: protocol lmtp { # Space separated list of plugins to load (default is global mail_plugins). #mail_plugins = $mail_plugins }


2

Mynetworks is not the best choice for allowing relaying, as it is quite easy to fake. In your case it is not a huge problem, but in general, unless you have complete control over who can obtain an IP in your mynetworks range, it is best to avoid including anything besides localhost. Myhostname is obviously the name of the mail server itself, basically how ...


1

Postfix has neat official documentation about postfix and its behavior. So it would be good idea to visit postfix DEBUG README page. In that page. the first step to look sign of trouble is look into /var/log/maillog file. When Postfix does not receive or deliver mail, please look for errors that prevent Postfix from working properly by issuing command egrep ...


-2

Check your 10_auth.conf. disable_plaintext_auth = yes ... auth_mechanisms = plain login The auth mechanisms you have allowed are both disabled by the disable_plaintext_auth directive, so there aren't any left.


6

To execute your filters on your existent mailbox you can manually run sieve-filter from the command line. To (dry) run the sieve-script example.sieve as user test on the mailbox INBOX use the following command: sieve-filter -v -C -u test /path/to/sieve/example.sieve 'INBOX' Once you like the actions sieve would perform you can execute the script with ...


0

It's easy :( sudo su user-which-owns-mails sieve-filter -e -W -u targetuset@domain.com /path/to/sieve/script.sieve INBOX


2

Ouch... you obscure too much... :( Well looks like your case was simple typo Well, looks like you want to define alias for admin@ratdotoyolo.cc to webmaster@ratdotoyolo.cc but you have typo in alias table here Jan 26 08:32:50 server348 postfix/smtp[15138]: C9ECB678CD21: to=<webmaster@ratdotyolo.cc>, orig_to=<admin@ratdotoyolo.cc>, relay=none, ...


0

The problem is you've defined a value in the lmtp setup under dovecot that doesn't make much sense. Under the protocol lmtp{ line, remove the hostname = mydomain.cc and restart dovecot, also remove the mydomain = mydomain.cc line from the main.cf and restart postfix. Then see what you get back when you send an email.


1

The error log means client aborted SASL authentication process after process connect to dovecot SASL service. FYI, here the sample of SASL LOGIN transaction from this page. S: 220 esmtp.example.com ESMTP C: ehlo client.example.com S: 250-esmtp.example.com S: 250-PIPELINING S: 250-8BITMIME S: 250-SIZE 255555555 S: 250 AUTH LOGIN PLAIN CRAM-MD5 C: auth login ...


0

I solved the problem with creating 'own' delivery script. In fact, dovecot's deliver script is still used and is inside my own one, but before delivering message to mailbox, my script does stuff which I want to achieve. Of course I had to change 'virtual_transport' in main.cf vonfiguration as well as create hook in master.cf file (as I described in the ...


1

Problem solved - wrong socket file used in amavis configuration, thus causing messages to be deffered. Thank you for your time.


1

Contrary with mailq answer, actually you can do it via Dovecot version 2.0 released at August 2010. The documentation can be found here: Postfix and Dovecot LMTP. To preventing link-rot answer, here the summary of that page In debian postfix run with chroot, so you need place LMTP socket in postfix queue directory (usually in /var/spool/postfix/ directory). ...


2

Your script must act like Simple content filter example from Postfix official documentation. After postfix send the email via pipe, you must resubmit it via sendmail command. Snippet from that page Postfix receives unfiltered mail from the network with the smtpd(8) server, and delivers unfiltered mail to a content filter with the Postfix pipe(8) delivery ...


0

Finally found the answer, turned out postfix was trying to connect to gmail using ipv6. To fix this, configure ipv6 on the server, or like I did, disable ipv6 in /etc/postfix/main.cf by adding the following line: inet_protocols = ipv4 and restarting postfix: service postfix restart


0

Normally, you'll want to re-inject your messages back into postfix from your script, instead of using a content filter, I think a before queue milter might be a better fit for your use case.


1

Installing the packages below: apt-get install dovecot-mysql apt-get install libclass-dbi-mysql-perl I also reinstalled apt-get install php-auth apt-get install php-pear apt-get install postfix-mysql You might find that these last three are already installed by libclass-dbi-mysql-perl but on my test server I had to manually install them. ...


1

If your smtp server (ISPConfig seems to use postfix) wasn't able to accept those mails (i.e., if it needs the mysql connection to store them), it will have answered the requests from the foreign mail servers with an error - you should check your mail server logs as already suggested. In this case the sending mail servers should retry after a while (depending ...


-2

I think perhaps this thread is old, but I will try and contribute, someone else might find it useful Google is very peculiar when it comes to connecting to mail servers, unless the mail-server uses a genuine ssl certificates issued by a recognised authority such as "Starssl " and so on, Google won't even talk to your server. I had similar problem few ...


0

After looking deeper through the change logs, it appears that override_fields and default_fields options were not added until Dovecot 2.1.0, so those options would not be available. There was also mention in another post (no longer have the link to it) that there was an issue with Dovecot 2.0.X clearing the variables prior to hitting the postlogin scripting ...


2

The reason to use virtual users is quite simple. It allows you to use databases and web front ends to do user authorization, and it is much easier to teach someone how to change a user's password, or create a new user, through a web page, instead of having to give them command line access. The virtual user model is pretty flexible, you can use it for email, ...


2

FTP-users also can be virtual and, as far as dovecot provide system-wide auth-service, you can use the same virtual accounts for both FTP and IMAP. Sure you have to use FTP-server that allow virtual users.


2

The solution was to set user_filter = (&(objectClass=posixAccount)(uid=%n) in /etc/dovecot/dovecot-ldap.conf.ext.


1

Dovecot package normally delivers a wrapper script /usr/share/doc/dovecot-<version>/mkcert.sh. Try it to generate your self-signed certificate.


1

Looks like a problem with /etc/ssl/certs/dovecot.pem Check that the file exists and Dovecot has permission to read it, or disable the SSL functionality. On my Ubuntu machine, dovecot.pem is in /etc/dovecot, with user root and group dovecot.


0

I dont know what I did wrong, but redoing the setup all over again fixed the problem. A guide for those who are interested. https://www.linode.com/docs/email/postfix/email-with-postfix-dovecot-and-mysql#postfix


3

First thing I would do would be to update the client. What is happening here is an attempted protocol downgrade. That is, the client is trying to downgrade from TLSv1 to SSLv3, or from any higher version of TLS to a lower version. (Exactly which is not clear from the logs, and would require more verbose OpenSSL debugging to be enabled, but that particular ...


0

First make sure you are using Maildir in your settings. Mbox collects everything in a single file. The you can follow the steps taken in http://ubuntuguide.org/wiki/Mail_Server_setup#Create_a_Dovecot-compatible_Maildir_directory_skeleton The skeldirectory will create new directory in every new user that is added. For users that are already created these ...


0

You have to add lda_mailbox_autocreate = yes lda_mailbox_autosubscribe = yes to the dovecot's config file. Sure you have to use dovecot's deliver for LDA.


0

It depends on how you provision your users, if they're traditional system users the template for the home directory including the Maildir and any other mail folders is /etc/skel


2

Your mydestination does not include your own domain, thus Postfix doesn't know it is meant to deliver the mail locally. This is why you see errors like "Relay access denied" and "Mail loops back to myself". It appears you had already set this up, but had commented it out. #mydestination = vapsterthekoala.com, makaveli, localhost.localdomain, localhost ...



Top 50 recent answers are included