New answers tagged

0

I see there is no /run/php/php7.0-fpm.pid file. This file is created when php7.0-fpm starts. So I solved this issue by adding to Dockerfile: RUN service php7.0-fpm start Of course after php-fpm installation :)


0

You have an error here: <FilesMatch "\.php*"> The "*" is not a wildcard in the sense that you used it, but means to "Repeat the previous match zero or more times." You should review the Apache documentation for Regular Expressions, and change the FilesMatch to: <FilesMatch "\.php"> ALSO: It looks like: ScriptAlias / /usr/lib/cgi-bin ...


0

If I'm understanding the situation correctly you should change the ownership of the files to the www-data user. Since you have sudo permissions you can add your user (sam) to the www-data group and still be able to do what you need to do. To add your user to the www-data group: usermod -a -G www-data sam To change ownership of all the files to www-data ...


0

I have solved the problem by reading the Configuring Virtual Hosts document and creating 3 XML-files: $JETTY_BASE/webapps/site1.xml $JETTY_BASE/webapps/site2.xml $JETTY_BASE/webapps/site3.xml With the following content at the top of each file: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE Configure PUBLIC "-//Mort Bay Consulting//DTD ...


0

I was coding from memory of past programs and had forgotten some of the requirements, such as Status:. Here is the changed line from my original question that finally worked. FCGX_FPrintF(request.out, "Status: 404\r\n Content-type: text/html\r\n <html><body>Not Found</body></html>\n\n"); That works until you have to do a ...


0

Nginx has this ability, though it's behavior changed in v1.7.5. Prior to v1.7.5, you could only add headers to return codes less than 400. After v1.7.5, you can assign headers to any return code with the always argument. The syntax is as follows: add_header name value [always]; add_header X-Test headervalue always; - will attach the header to all ...


0

mod_proxy_fcgi, which is newly available in Apache 2.4, is just for this type of use case. The Apache wiki entry for PHP-FPM has some good guidance to get started. The mod_proxy_fcgi documentation also includes specific examples for setting up PHP-FPM and the PHP documentation also has helpful information. Note also (notwithstanding some erroneous ...


0

The limit of 1024 characters is hard-coded in php-fpm not nginx. If you want to go over 2048 characters you need to re-compiled both nginx and php-fpm, else only php-fpm. There is a full solution with patches here for 8192 characters: https://forums.freebsd.org/threads/56543/


0

I have resovled this issue. I installed xsp via yast & zypper several times without improvment. Finally, I tried installing directly from https://software.opensuse.org/package/xsp This has made the crital difference for me - fastcgi-mono-server4 no longer complains about unhandled exceptions. However, xsp still does. But given that I don't really want ...



Top 50 recent answers are included