Tag Info

New answers tagged

0

As man db_load says: DESCRIPTION The db5.3_load utility reads from the standard input and loads it into the database file. The database file is created if it does not already exist. Also the option -n (Do not overwrite existing keys) might be useful.


0

I don't think that is possible, there is a single IIS FTP process and it listens on all addresses on all assigned ports. This way it can then process the requests for various FTP sites on multiple addresses or ports.


18

The SSH/SFTP protocol does not have any mechanism to provide the host to the server. There was a discussion about adding this functionality to OpenSSH, see "Virtual hosts" for ssh. The FTP protocol does have HOST command, which is an equivalent to HTTP Host header. It is specified by a relatively new RFC 7151. The RFC was published in March 2014 (though ...


0

Aside from iptables solution, some FTP servers also allow the IP address filtering. For example with ProFTPD server, you can use Allow directive.


19

No, the SSH clients do not pass the DNS name you connected to on to the server. As you said correctly, the name is resolved locally to the IP address. It looks like I was wrong about FTP. See the other answer for details.


0

Yes, you can do that but with a VPS, use iptables to drop connections from stranger IP. For the IP based system, you can make your own FTP server using Node.js.


0

I was having some problems with the auto upload script provided by Strix and had to modify it slightly to work with Sublime Text 3 (unsure of Sublime Text 2 will work the same way). If you were having problems with his script not working or uploading blanks (and thereby EVERYTHING) then replace the middle function of autoupload.awk with this modified ...


1

Or find the numbers as explained in this article To find a user's UID or GID in Unix, use the id command. To find a specific user's UID, at the Unix prompt, enter: id -u username Replace username with the appropriate user's username. To find a user's GID, at the Unix prompt, enter: id -g username If you wish to find out all the groups a user belongs ...


0

Alright, after trial and error, it seems here's the answer. adduser someone vi /etc/ssh/sshd_config I am using Froggiz's configuration, so my code looks like this: PasswordAuthentication yes Subsystem sftp internal-sftp -u 0007 -f AUTH -l VERBOSE Match Group someone ChrootDirectory /var/www ForceCommand internal-sftp -u 0007 ...


0

this is how i set my sftp for specific user 1] create a user adduser {USER} 2] edit /etc/ssh/sshd_config PasswordAuthentication yes Subsystem sftp internal-sftp -u 0007 -f AUTH -l VERBOSE Match Group {USER} ChrootDirectory {FOLDER} ForceCommand internal-sftp -u 0007 AllowTcpForwarding no GatewayPorts no X11Forwarding no ...


0

You have to make sure your Security Group for that Instance to reflect your pasv_min_port & pasv_max_port and pasv_address is correct as well. part of my /etc/vsftpd/vsftpd.conf: $ sudo grep ^pasv_ /etc/vsftpd/vsftpd.conf pasv_max_port=2121 pasv_min_port=2020 pasv_address=54.X.X.X $ also, make sure you're client is using PASSIVE connection instead ...


0

You could try using pam_script - it's a pam module that allows executing arbitrary shell scripts after a user session is opened (among others). You can find pam_script here: https://github.com/jeroennijhof/pam_script. It should also be installable via package managers, at least I've been able to install it through apt-get. Be careful, as vsftpd seems to ...


1

Mirror command is to copy directories. As you want to copy just the files, you should use mget command. E.g. mget -c bla1/data/*.* -O /n/data/bla/all_the_data/


1

In the passive FTP mode, the server sends back to the client an IP address and a port the client needs to connect to for opening data transfer connection (for file transfers and directory listings). If that is a different IP address than the one you actually need use to connect to the server (due to NATing for example), the connection fails. Were the ...


-2

Opening Port 22 in Windows Firewall can be a solution. I tried and it worked but the only drawback is that you will have access to the whole system.


0

I normally test my answers, but this time I did not, forgive me. I am suspecting that you cannot exit twice. It is likely when the ID matches "asdf", you are halting vsftpd without realizing it. Specifically, try this instead: #!/bin/bash echo "$PAM_USER" >> /home/me/pam_script.log if [ "$PAM_USER" == "asdf" ]; then exit 0 else exit 1 fi


-1

Stumbled upon this myself. Many pages have the same question, but often not the (full) answer. It's the PASV ports that need to be reachable in PASV mode. This may need the firewall/IPtables to be adjusted: How to configure vsftpd to work with passive mode


0

I ended up figuring this out. It wasn't directly a firewall issue. I have two NICs, one for the LAN and another for the DMZ, to which the WAN IP is NAT'ed. The default route was over the LAN. When receiving packets from the internet, the server tried to respond via the default route on the LAN. Disconnecting from the LAN enabled the services to communicate ...


0

Looking at your iptables rules, I am assuming that it is your intention to forward your FTP traffic to host 65.118.148.196 - I am also assuming that 65.118.148.196 is not the host where your iptables are running. For iptables to successfully forward PASV FTP traffic in this way, the iptables conntrack module must be loaded. To do so, modify your ...


0

Note the + at the end of the . entry. This means that there is an alternate file access method in effect. Most likely this is an ACl. You can read the ACL using getfacl /home/back The output will likely point you in the correct direction to fix the problem.


1

You can change DefaultRoot directive per: "virtual host", i.e. per server-side IP address - contain the directive in VirtualHost user group (using "group expression") So, you cannot change it per source IP address. See documentation for DefaultRoot directive.


0

There is another failure which is not this one but it may be similar. If you are connecting in PASSIVE mode and you can connect to the server but the directory list fails. This may be caused because the port range specified in vsftpd.conf is not open in EC2 instance. You need to go to AWS EC2 console management panel to open the ports. For more details, see ...



Top 50 recent answers are included