Tag Info

Hot answers tagged

5

Typically in most modern packages this is done by installing the php-gd package with your package manager. for RHEL 5.3 try: yum install php5-gd


3

[root@a-sys1 ~]# yum search "php" | grep -i gd php-gd.i386 : A module for PHP applications for using the gd graphics library [root@a-sys1 ~]# yum install php-gd Loading "dellsysidplugin2" plugin etc etc


2

It looks like libjpeg62 isn't installed on your server. Install libjpeg62and restart Apache2. sudo apt-get install libjpeg62


1

It seems you have installed PHP via launchpad PPA: https://launchpad.net/~ondrej/+archive/php5 Check your apt sources.list if the ppa is still active. On 14.04, you should have these repos active: deb http://ppa.launchpad.net/ondrej/php5/ubuntu trusty main deb-src http://ppa.launchpad.net/ondrej/php5/ubuntu trusty main Explanation: It seems you had ...


1

First of all you need check PHP version you have installed # php -v After this you need to find php-gd package for your version of PHP, cause yo are trying php-gd for PHP 5.5., but you (probably) have PHP 5.3.. So you can try: I assume you have REMI or CentALT repo installed, so just try installing pgp-gd from those repos. # yum install php-gd ...


1

The gd-php adds the php module for gd. It is not compiled into php, which is why you see the --without-gd in the info. It sounds like you never restarted lighttpd or php-fpm (if that is how you set it up). I have seen instances where a simple restart of lighttpd won't kill the php-fcgi threads, which cause it to use the old php configuration even after ...


1

You can try it by installing the lamp development package instead of php-gd Use the link to check out for downloading the lamp development package.


1

Why you are trying to install xampp/lampp if you already have everything on your Ubuntu repository ? Anyway to answer to your problem, you are trying to load a header file as a module. :) It will not work. For your lampp probably you should copy /usr/lib/php5/20090626/gd.so to /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/, but I don't know if ...


1

Perl looks for modules in the directories of the @INC array, just like Bash does with $PATH for commands. The GD installed by apt is probably being overridden by something else in the @INC. Look for files named GD.pm in your system, it should show only the Debian one in /usr/lib/perl5/GD.pm. You can check your @INC using perl -e 'print join "\n", @INC', ...


1

You need to find and install the package(s) with appropriate version to meet the dependencies. Otherwise, you will have no other choice but to build and install the needed packages from source.


1

I set --with-jpeg-dir=/usr/local/ and it worked! It appears to add the lib itself.


1

you need libjpeg-devel too if you are COMPILING your own php and extensions yum install libjpeg-devel you need all the -devel equivalents for libraries that you are going to link and use (curl-devel, zlib-devel, gmp-devel, etc)


1

Try with yum install php5-gd. Then just restart Apache with service httpd restart and you should be all set.


1

I also found I wasn't able to find any php-gd libs in yum install packages.. Only gd.. Did you check carefully? It located in base repo: # repoquery -i php-gd Name : php-gd Version : 5.1.6 Release : 27.el5_5.3 Architecture: x86_64 Size : 341034 Packager : None Group : Development/Languages URL : ...


1

This is the command that failed: yum --exclude=kernel* -y install gettext automake19 libpng-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libstdc++-dev libltdl3-devel libltdl libopenssl0.9.7-static-devel libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev ...


1

First, check if the package wasn't excluded. Open up the yum config with vi /etc/yum.conf and look for a line starting with exclude=if php-gdor php*is mentioned, remove it. Sometimes VPS-hosters won't allow you to use some packages because they hog memory. So you might want to check you aliases by running aliasand check if there is no alias for yumwith an ...


1

Ideas.. php.ini was replaced, changed, or isn't being read. Compare backup to current one on system. New package is compiled with different options. Compare new and old by running php -i I know it seems unrelated, but verifying fundamentals such as permissions and resource availability (memory) could potentially help isolate the issue as well. Are ...


1

First cd to the directory of the PHP source. Then make clean Then compile with JPEG support (add this to all the other compile options you already had used): --with-jpeg-dir=<put path to jpeg library here> For example, if your jpeg library is located at: /usr/lib/libjpeg.so Use: --with-jpeg-dir=/usr/lib


1

Try turning on error_reporting(E_ALL); and point your browser to the image URL. Comment the type header to see any error messages that may be hidden if your browser only displays a broken pict message. And fix that missing semi-colon Ben mentioned. Edit: And sanitize $_GET['src'] you may be opening a big security hole there.


1

The command line shown under Configure Command reflects the options that the binary was built with, not what modules are currently available. Look below the main Configuration header to see if the gd module is loaded. If not then install the php-gd package and restart/reload httpd.


1

How are you running PHP? If you're running it in FCGI mode with an external spawner, restarting nginx will have no effect on the PHP server, so you'll need to restart that separately.


1

This is very older bug in freebsd. In extensions.ini the string extension=gd.so needs to be the first line.


1

If you are using portmaster, this will work: portmaster -dbrR png-1.2.40


1

Before updating always read /usr/ports/UPDATING Sometimes you'll need to do recursive portupgrade i.e. portupgrade -fr png-1.2.37



Only top voted, non community-wiki answers of a minimum length are eligible