Tag Info

Hot answers tagged

4

Check /etc/nsswitch.conf, specifically the groups line. Also check the output of $ getent groups git To find out why you get the error about the group already existing. Reference: man nsswitch.conf(5) and man getent(1)


3

Ensure that your SCRIPT_FILENAME is correct. I've found that I have to specify the full absolute location to get it work: fastcgi_param SCRIPT_FILENAME /usr/share/gitweb/gitweb.cgi; If you continue to have errors, you may need to specify the full path to your Gitweb configuration file as well: fastcgi_param GITWEB_CONFIG /etc/conf.d/gitweb.conf;


2

gitweb is available in the EPEL repo http://fedoraproject.org/wiki/EPEL. To add Epel repository to your system open a terminal and as root run: For RedHat/centos 6 rpm -ivh http://mirror.datacenter.by/pub/fedoraproject.org/epel/6/i386/epel-release-6-8.noarch.rpm For RedHat/centos 5 rpm -ivh ...


2

I fixed this by using cygwin's version of Perl instead of msysgit. That will really speed up your response time. To do this, you will need to modify the gitweb.cgi script in 3 places The first line should say this: #!C:/cygwin/bin/perl I choose to use cygwin's version of git instead of msysgit's as well, so you need to make sure the projectroot is in ...


2

You need to add a gitweb.conf.pl file (like this one) which: will be called by gitweb (if that file exists and defines a export_auth_hook sub, gitweb.cgi calls it) will specify where the git repos are will call gitolite That would include: $ENV{GL_REPO_BASE_ABS} = "$ENV{HOME}/repositories"; $export_auth_hook = sub { my $repo = shift; my $user = ...


2

I've found and fixed the problem. Actually it's a bug in nginx. Normally, under nginx.conf, there's a user directive which sets the nginx's setuid()/setgid() behavior & the syntax of the directive is user <username> <groupname>. Doucmentation[1] states that, if you omit <groupname>, <username> will be used as group. However, ...


1

I guess this makes a good community wiki. Please extend this robots.txt if you think it can be improved: User-agent: * Disallow: /*a=search* Disallow: /*a=blobdiff* Disallow: /*a=commitdiff* Disallow: /*a=snapshot* Disallow: /*a=blame*


1

From the gitolite config page: You can also use the special values %GL_REPO and %GL_CREATOR in the string. The former is available to all repos, while the latter is only available to wild repos. So this could work (not tested): config gitweb.url = git@git.exmaple.com/%GL_CREATOR/%GL_REPO config receive.denyNonFastforwards = true (I suppose the ...


1

Fixed it! I am running on RHEL and it turns out it was a problem with SELinux. When I disabled it, everything worked correctly. Since I didn't want to disable it for good, I found the solution on a blog for writing a module that sets the correct policies and installs it. What I did was: # mkdir gitolite-selinux; cd gitolite-selinux # touch local.te ...


1

I suspect that this is because your repositories are NOT bare repositories; that is, gitweb doesn't work correctly with non-bare repositories. A good way to check is--the directory that gitweb is publishing; does it contain a bunch of directories with a .git directory? The solution would be to use bare repositories (git clone --bare) instead.


1

Gitosis uses gitweb for http publishing of repositories. You need to have gitweb running. Please ensure that gitweb is installed. Your gitweb.conf should look like: # Location of the git binary $GIT = "/usr/bin/git"; # Project root for gitweb $projectroot = "/srv/git/repositories"; $stylesheet = "/gitweb.css"; $logo = "/git-logo.png"; $favicon = ...


1

Here is my "gitweb-gitolite" configuration, hoping that may help you find what is missing in your configuration: I have included my gitweb.conf.pl at then end of gitweb_config.perl (as mentioned in the gitolite doc) like so: use lib ("."); require "gitweb.conf.pl"; Here is my gitweb.conf.pl, adapted from gitolite/contrib/gitweb/gitweb.conf: (note that ...



Only top voted, non community-wiki answers of a minimum length are eligible