Tag Info

New answers tagged

0

You need to download, build and install protobuf. In the end the executable 'protoc' should be should be in your PATH.


0

I am not sure it's going to answer your question but Hadoop version 1 All command line utilities were in 'hadoop install dir'/bin directory. All hadoop commands are invoked by the bin/hadoop script Hadoop version 2 Commands live in two directories. bin : Most used commands like hadoop, mapred ..etc sbin: Administrative commands like start-all.sh ...


0

Thanks for pointing this out.I tried in my system [root@prashant bin]# hadoop version Hadoop 1.2.1 and you are absolutely correct 20:39:57.038706 open("/usr/local/hadoop/libexec/../conf/hadoop-env.sh", O_RDONLY) = 3 <0.000253> When I moved this file then its referring to file inside /bin 20:42:51.024234 ...


0

You can configre RAID0 per available phisical disk. Let's say if you've got 8 disks, then you end up having something like that (CentOS 6): # hpacucli ctrl all show config | grep RAID logicaldrive 1 (558.9 GB, RAID 0, OK) logicaldrive 2 (558.9 GB, RAID 0, OK) logicaldrive 3 (558.9 GB, RAID 0, OK) logicaldrive 4 (558.9 GB, RAID 0, ...


1

You don't call this via hadoop. You can either run: hdfs dfs -ls / Or: hadoop fs -ls /


0

You are asking for an if block so why not just use an if block? if File.exists?("/etc/yum.repos.d/ambari.repo") %w{package1 package2}.each do |pkg| package pkg end ... do some other stuff here if you want... end The default action for package is install so you don't need the full block in this case.


3

It is required during the installation and upgrade procedure when using the wizard in the Cloudera Manager. During normal cluster operation it is not needed. All communication is done via the locally running agents then. In fact Cloudera Manager does not store the credentials, after the installation / upgrade it will delete it. When you upgrade your ...


0

Just installing the ZKFC and starting it is not sufficient. HDFS' NameNode (NN) needs to be installed, High Availability (HA) needs to be enabled for this NN to avoid HA is not enabled for this namenode. error and to avoid Missing required configuration 'ha.zookeeper.quorum' for ZooKeeper quorum issue ha.zookeeper.quorum needs to be configured in HDFS' ...


0

After applying the configuration (see Configuration details paragraph) defined in this documentation the issue HA is not enabled for this namenode was solved. <property> <name>dfs.namenode.rpc-address.mycluster.nn1</name> <value>machine1.example.com:8020</value> </property> <property> ...


1

If you have netcat installed. You could do echo stat | nc localhost 2181 | grep Mode echo srvr | nc localhost 2181 | grep Mode #(From 3.3.0 onwards) If the zookeper server is a leader, Returns Mode: leader Else returns Mode: follower



Top 50 recent answers are included