New answers tagged

0

remove the SSL config from nginx and enable it in 'magento' https://www.siteground.com/tutorials/magento/magento_ssl.htm


0

Your link leads to a 404, so no html files there. Anyway, all files should normally get served the same way. Maybe from inside your html files css and js files are called by absolute URL? If so you should change that to requests for relative URLs. And why are you using the alias directive and not root?


4

If the number of formula's in the Wikipedia article scares you off: what's the meaning of 99th percentile? The cut-off point which fits 99% of the observed values. For instance when the 99th percentile is 3000 milliseconds => 99% of all observed latencies are 3000 milliseconds or less. Or in other words: only 1% of observed latencies is larger than 3 ...


0

You must set proxy_http_version 1.1; for PUT to work.


0

Also, the problem does not come from proxytunnel as the request is correctly forwarded to apache and is present in the server logs This was wrong, proxytunnel does not support SNI in the version I use (latest commit from their repository as of the date of this post, so something a little ahead of 1.9.1 if I trust their release tags). The consequence is ...


0

For historic reasons simply look at the older HTTP 1.0 specification from RFC 1945 (emphasis mine): 403 Forbidden The server understood the request, but is refusing to fulfill it. Authorization will not help and the request should not be repeated. If the request method was not HEAD and the server wishes to make public why the request ...


0

It can be a MTU-related problem. To test, try lowering your MTU on both servers issuing the command ifconfig <ifname> mtu 580 This should be only viewed as a workaround, though. If that solves the problem, restore the original MTU (issuing ifconfig <ifname> mtu 1500 and check with your firewall admin / ISP why larger packet are dropped.


0

Remember that nginx logs a 499 when, from its perspective, the client it was talking to closed the connection. Remember also that CloudFlare is not the only thing talking to your web server. It is possible for clients to visit it directly, and many do. If you are using CloudFlare, much of this traffic is Internet background noise and the rest is malicious. ...


0

You need to block any access to port 7000, then allow access to port 7000 to only the servers in your network. That way you effectively block the Web UI from being accessed unless you're accessing it from a server inside your network. HTTP is a protocol (P in HTTP) and runs on port 80. UFW can't block it based on it being a web page or not since it only ...


0

You can block this via .htaacess file. In .htaccess fle you need to allow application only via your public IP address and deny all other IP address. Below i have shared the content which needs to be entered in .htaccess file. Order deny,allow allow from 1.2.3.4 #Your Public IP, only this IP is accessible to application. deny from all This will sort ...


1

If i understood your question correctly, you have multiple ways to block access to your application from outside the server. You can set your application to work only with a 127.0.0.1/8 IP address. You can block it via iptables. My best practice is the first option.



Top 50 recent answers are included