Hot answers tagged

2

I notice you are using this cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA However that cipher is black listed for HTTP/2: https://tools.ietf.org/html/rfc7540 And by default mod_http2 will not allow you to negotiate with blacklisted ciphers: https://httpd.apache.org/docs/2.4/mod/mod_http2.html#h2moderntlsonly So I wonder if that is the only problem and ...


2

2.X.Y.Z is NOT bind to eth1 interface, yet 172.20.54.10 is, either comment out Listen 2.X.Y.Z:80 line or replace 2.X.Y.Z with 172.20.54.10 and then try to start your httpd. Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 that ...


1

On your instance, run host ec2-123-123-123-123.eu-central-1.compute.amazonaws.com (your instance's public DNS hostname). See that it does not, in fact, resolve to 123.123.123.123, but rather to an RFC 1918 address (probably 10.x.x.x)? Amazon uses split-view DNS, so the hostname resolves to the public IP outside the region/VPC, but resolves to the private ...


1

This issue can arise on CentOS (and likely other distributions) because of the way the SSL configuration is setup "out of the box". The configuration setting that creates issues here is the NameVirtualHost *:443 instruction. For non-ssl, the instruction NameVirtualHost *:80 is stored in /etc/httpd/httpd.conf and is loaded first. When the other ...


1

You don't want to have multiple VirtualHost blocks with the same ServerName value. Instead you want to have a single VirtualHost block per ServerName and use either ProxyPass of RewriteRule to route the traffic to the appropriate backends. Here's an example using ProxyPass: <VirtualHost *:80> ServerName web.url.in ProxyPreserveHost On ...



Only top voted, non community-wiki answers of a minimum length are eligible