New answers tagged

1

On your instance, run host ec2-123-123-123-123.eu-central-1.compute.amazonaws.com (your instance's public DNS hostname). See that it does not, in fact, resolve to 123.123.123.123, but rather to an RFC 1918 address (probably 10.x.x.x)? Amazon uses split-view DNS, so the hostname resolves to the public IP outside the region/VPC, but resolves to the private ...


1

You don't want to have multiple VirtualHost blocks with the same ServerName value. Instead you want to have a single VirtualHost block per ServerName and use either ProxyPass of RewriteRule to route the traffic to the appropriate backends. Here's an example using ProxyPass: <VirtualHost *:80> ServerName web.url.in ProxyPreserveHost On ...


2

2.X.Y.Z is NOT bind to eth1 interface, yet 172.20.54.10 is, either comment out Listen 2.X.Y.Z:80 line or replace 2.X.Y.Z with 172.20.54.10 and then try to start your httpd. Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 that ...


0

As suggested by @HBruijn I've added ProxyPass "/core/" "http://cloud.algerian-radio.dz/core/" ProxyPassReverse "/core/" "http://cloud.algerian-radio.dz/core/" But then the server received requests for /index.php/apps/files/, so I added that as well ProxyPass "/index.php/apps/files/" "http://cloud.algerian-radio.dz/apps/file\ s/" ...


0

Just adding your own sollution as an answer for readability: The problem was that I was using a different server name when creating a certificate and now it did not want to accept the certificate. So, when I correct the line: AuthLDAPUrl "ldap://ldap.domen.lan/dc=domen,dc=lan" TLS with server name in certificate, it worked!


1

This issue can arise on CentOS (and likely other distributions) because of the way the SSL configuration is setup "out of the box". The configuration setting that creates issues here is the NameVirtualHost *:443 instruction. For non-ssl, the instruction NameVirtualHost *:80 is stored in /etc/httpd/httpd.conf and is loaded first. When the other ...


0

Most common modules should all be installed by default and located in /etc/apache2/mods-available/ You then need to enable or disable the one's you need. For example sudo a2enmod auth_basic sudo a2enmod mod_deflate sudo a2enmod mod_cache Then to disable any you don't need you disable them with sudo a2dismod auth_basic Make sure to check what modules ...


0

You need to determine which conf files are being loaded (likely conf/*.conf , vhost/*.conf .. trace it from the httpd.conf). Apache is reading multiple conf files, one of them already has a :443 that is listening on port 443. You only need the SSL configuration in the 2nd block/conf file for the :443 listener (this is why you are getting a default page, ...


0

That's the config file for Apache listening on port 80. However, HTTPS is delivered via port 443. It's likely that you have a rogue site remapping port 443 to the default directory (Possibly even Apache's own /etc/apache2/sites-available/default-ssl.conf).


0

Have you tried changing your Apache log format by adding %T/%D ? For a start this will add the seconds & microseconds that a request took. LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" **%T/%D**" combined As far as logging each php script and how long it took, have a look through the code provided on this solution at ...


0

I eventually found the error in the error_log, it seemed that it did not have permission to access the log file of the virtual host due to SELinux even though I didn't see anything in the audit log initially.


2

I notice you are using this cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA However that cipher is black listed for HTTP/2: https://tools.ietf.org/html/rfc7540 And by default mod_http2 will not allow you to negotiate with blacklisted ciphers: https://httpd.apache.org/docs/2.4/mod/mod_http2.html#h2moderntlsonly So I wonder if that is the only problem and ...


0

I had precisely the same problem as ide and spent far longer trying to solve this than I had hoped. Since this is the only post or article I was able to find that helped me to adequately solve the issue, I wanted to add my solution to the mix. My configuration: Ubuntu 14.04 Apache 2.4.20 PHP-FPM 5.5.9-1ubuntu4.17 (fpm-fcgi) (built: May 19 2016 19:08:26) ...



Top 50 recent answers are included