Tag Info

New answers tagged

2

HTTP is NOT a secure protocol, it never has been, and is not meant to be. HTTPS IS the same protocol over a secure channel, though only if you use TLS 1.0 or newer (TLS 1.2 is highly recommended as 1.0 and 1.1 have known issues).


2

Ensure that you have a binding for port 990, as that is the implicit FTPS port. Without that binding your site in IIS will not support implicit FTPS.


2

The SSLShopper answer did not work for me because it left the binding without the host header, and you couldn't remove that binding without breaking the connection to the certificate. Here is the method I used to get it to work: Please note that this answer assumes that your certificate has already been generated, added to the certificate store, and added ...


0

This is expected behavior. The most specific combination of bindings is what "takes". If you specify a host header name in the binding then requests must contain the host name (via the HTTP "Host:" header). If you intend to access a website by IP address then you will need a binding on that site with no host header name specified and the appropriate ...


0

In IIS you should bind by IP only, the hostname is something you can change from DNS, so you would point the A record "local" for you domain "somewebsite.com" to your IP of choice. Should work.


0

There is a very simple way to this, at least in IIS8, don't know if this existed in IIS6. Anyway I think it's helpful. You go to IIS Select your server on the left click Icon Worker Processes see CPU / Memory per application


-1

I use following code and works for me iis 7.5 protected void Application_PreSendRequestHeaders() { Response.Headers.Remove("Server"); Response.Headers.Remove("X-AspNet-Version"); Response.Headers.Remove("X-AspNetMvc-Version"); }


0

I have handled this in the past by creating a www2.whatever.com sub domain, which the new server will listen on in addition to www. The key is that it cannot be a redirect to www (otherwise you're back at square one). After changing DNS to point www at the new server you change the old server to 302 redirect www to www2. The result is that clients who get ...


0

As stated by others, SSL certs are only valid for the exact FQDN used. When you created the self-signed certificate in IIS, it provided you with an "issued to" name. If you use this instead of "localhost", the cert should work. For instance, if the machine's name is foo.bar.com, then you can use https://foo.bar.com in the URL instead of https://localhost. ...


0

Firefox has a different certificate repository. It is not the same that IE uses from the system. Look under settings in Firefox or Google for instructions to add CA certs into firefox repository. Edit: since a self signed certificate is used the browser should be able to verify tge certificate based on the ca certificate list in its repository. IE uses the ...


0

If you disabled SSL_3 by removing ciphers, you have likely also disabled TLS1 and TSL1_1. This leaves TLS1_2 which is not yet supported by all applications. As I documented in my post on Disabling SSLv3 to block Poodle, you can block SSL3 in Apache with the configuration line. SSLProtocol all -SSLv3 As suggested by StackzOfStuff, test connectivity with ...


0

Check if your SQL server actually accepts any encryption above SSL3: Run the connection client Find out what serverport it is connecting to. Check with openssl's "s_client" if TLS is supported: openssl s_client -connect Mysqlserver:myserverport -ssl3 openssl s_client -connect Mysqlserver:myserverport -tls1 openssl s_client -connect ...


0

You can do this with a Citrix NetScaler. But only with the HARDWARE version. The VM version does not support TLS1.1 and upwards. The way to do this is this: You disallow all TLS1.0/SSL-suites. Then all you are left with are the suites introduced with TLS1.1 and upwards. Then you use the feature called "CipherRedirect". This will allow a connection with an ...


0

I think the problem is WinCache extension, existed some problems reported with the use of this extension https://bugs.php.net/bug.php?id=58985, https://bugs.php.net/bug.php?id=59352 and others. You can try to disable from your code: ini_set('wincache.fcenabled','0'); Also check if exists some plugin that is using this extension. I hope this help


0

Try changing /section:applicationPools to /section:system.applicationHost/applicationPools and adding /commit:apphost to the end appcmd set config /section:system.applicationHost/applicationPools /[name='AppPoolName'].processModel.identityType:SpecificUser /[name='AppPoolName'].processModel.password:P4ssW0rd /commit:apphost


0

Install ARR - Application Request Routing - in IIS and then configure it. Finished. IIS has this functionality for ages.


1

This is just another manifestation of the IIS bug that I wrote about in this answer. You will find that a reboot fixes it. A hotfix is available. The different behavior of your two sites can only be due to the two different application pool identities that they are running under. You didn't clearly mention the identities of the working and non-working ...


0

First thing, make sure you're metrics are being gathered correctly. In a virtual environment you can't necessarily rely on traditional performance counters. The host can (and will) regulate hardware allocations to your VM based its load and the demands of other VM's it's managing. There is not much to go on from your question in the way of details, but ...


0

You can use the following regex pattern to match only requests where the path part of the URI is empty: ^$ Put it into the "Match URL" field Use a Condition to make sure it only applies to requests for the sub.foo.com domain by matching on the {HTTP_HOST} server variable. Pattern should be something like ^sub\.foo\.com$


0

http://community.zimbra.com/ Zimbra can be traced back to Telligent Systems, who produced the ASP.NET-based Community Server suite (circa 2005) which itself had its roots from ASP.NET Forums v1.


2

Baris is right! The SSL certificate configured on an IP:PORT binding (example: 100.74.156.187:443) always takes precedence in http.sys! So the solution is as follows: Do not configure an IP:443 binding for your wildcard-fallback-certificate but configure a *:443 binding (* means "All Unassigned") for it. If you have configured your wildcard certificate on ...


1

I used IIS Crypto to do this, seems to work just fine. Note that a full reboot is required after disabling/enabling encryption methods.


1

Your SSL cert is only valid for the exact FQDN by which the addressee access the website. The subject of the SSL certificate, and the server FQDN in the URL address bar must match. E.g., it is valid only for foo.domain.com, not foo, not localhost, not 127.0.0.1. This is by design. This is how SSL certificates work. No self-respecting Certificate Authority ...


2

On newer versions of Windows (Win2003 and later), you can use: netstat -b -o On older versions of Windows (XP and earlier), I'd recommend using fport: http://www.mcafee.com/us/downloads/free-tools/fport.aspx Either one will show you the process ID and filename. The process ID should be enough to kill the process; the filename should help you track down ...


3

Make sure that your catch-all binding is not of type IP:Port. When an IP:Port binding exists for an HTTPS binding while SNI is not required, that binding will always take precedence. For your catch-all case, use a *:Port binding (* being the all unassigned).


1

It's not a security restriction. Perl tries to find some driver's dll's in system registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip but path to dll is based on environment variable %SystemRoot%, and IIS do not pass environment through FastCGI Add following text to your programm: BEGIN { $ENV {SYSTEMROOT} = "C:\\Windows"; ...


0

Ok, I finally get it working by removing IsapiFilterModule and IsapiModule from the site.


1

There is a free utility from Nartac that you can use to disable the protocols. https://www.nartac.com/Products/IISCrypto/Default.aspx


1

From your RUN, go to services.msc Then, find and DISABLE the IIS Admin service. If you just stop it for now and the next time you reboot your machine/server, the service might be started again. So, make sure you stop and disable that service for good.


1

You can stop iis service. net stop iisadmin /y


0

I had exactly the same issue. It worked for me after I checked the "Disable Certificate revocation Lists (CRL)" in the properties of the self signed certificate in the Local computer trusted root CA store.


1

this happens because wfastcgi has a pretty specific section of code handling a watcher over the application directory for files changes. Unfortunately it trips up if a new file is added during the execution of a request. By default it restarts the process (in quite an abruptively way) for any *.py or *.config changes. It can be set, though, to watch only ...


1

If you turn on the "Command Line" view in Task Manager, that'll quickly identify the W3WPs you've got in play. Most simple explanation is likely that you've got more than one App Pool active on the box. NETSH HTTP SHOW SERVICESTATE would let you easily tie worker processes to a given queue (and count them, by the number of PIDs present for each pool). ...


0

You may check your IIS settings. Open the IIS managment console and goto application pools. Got to SMS Distribution points pool, right click and select advanced settings. make Enable 32-bit applications setting to be false.


0

I faced the same problem that u are having and it's working but u had to do some modifications : IIS changes the URL format so use the following instead of the normal url and port : http.createServer(function (req, res) { res.writeHead(200, { 'Content-Type': 'text/plain' }); res.end('Hello, world! [helloworld sample]'); ...



Top 50 recent answers are included