Tag Info

Hot answers tagged

2

If you turn on Require SSL then HTTP requests will fail immediately. One trick we used (using ASP.NET) before doing the same was to check for the protocol on the default page, then issue a friendly warning, e.g. If Not Request.IsSecureConnection Then loginform.visible = False ltl_warning.Text = "Non-secure connections will be disabled in one ...


1

No, according to the documentation, isapiFilters can only be defined on the server or site level. You may put the 32bit Application into its own site and then URL-rewrite every request for it from the main site. But that may result into more problems/work depending on your application.


1

In your example you specify a sub sub domain (www.dev.mydomain.com) which may be the cause. Per the specs wildcard certs only work with one level subdomains (ie mysite.mydomain.com and not test1.mysite.mydomain.com).


1

I'm using the following PowerShell script to look at all certs on the box and for each try to find it in the IIS SSL bindings. import-module WebAdministration ls cert:\LocalMachine\my | select * | foreach { $found = $false $tp = $_.Thumbprint ls IIS:\SslBindings | Foreach { if ($_.Thumbprint -eq $tp) { Write-Host "Used in ...


1

I had this issue with a Windows Server 2008 R2 Datacenter IIS. The solution to my problem was to: Open up your server remotely Start your IIS manager Under the left Connections panel look for the domain that is giving you the problem with the SSL After locating and selecting it click on SSL Settings Under Client certificates choose Ignore Click Apply Under ...


1

I was having this issue as well and it was related to the data ports being selected by IIS. I set it up to use a specific port range but when my client tried to use passive mode it showed that it was using the wrong port. This article describes the method for calculating which port it is using. e.g. 227 Entering Passive Mode (x1,x2,x3,x4,y1,y2) The IP ...



Only top voted, non community-wiki answers of a minimum length are eligible