Tag Info

New answers tagged

1

I had the same problem with 32 bit version of MySQL on a windows server 2008 VM 64 bit with 4G Ram. I tried increasing system ram to 6G and still could not allocate over 1G for innoDB. Since I was already on 64 bit OS, I tried the 64 bit installer for MySQL and had no issues at all allocating 2G on my 4G system.


0

Your problem is the storage backend. From you graph, it is clear that your SAN it is not capable of high random IOPS values (see both aver. iops and aver. queue depth). To ameliorate the situation, try with the following: increase the innodb buffer pool size, by editing the my.cnf file and adding (or changing) the line innodb_buffer_pool_size = ...


0

When you have disable innodb, dont' forget to remove all innodb-related tables from Dbs. For example "mysql" database has 5 of them: root@ustimen.co$ mysql mysql -e 'show table status' | grep Unknown | awk '{print $1}' innodb_index_stats innodb_table_stats slave_master_info slave_relay_log_info slave_worker_info


0

This MySQL forum post looks like a success story, although a bit old. I remember a similar story of mine, on Linux. Windows platform doesn't matter here, MySQL data files structure is similar. No command line work is really needed. I assume your Ibdata file is not damaged in any way. AFAIK you don't need ib_logfile? files at all, the forum post confirms ...


1

Assuming that mysql versions are the same (or similar enough): Shut down mysql Remove contents of /var/lib/mysql and replace with the new data Correct permissions on the files (hint: use chown and chmod) Start mysql



Top 50 recent answers are included