Hot answers tagged

3

A bit of reading on LDAP and DNs might be in order here. A distinguished name (usually just shortened to DN) both uniquely identifies an entry and describes its position in the DIT. A DN is much like an absolute path on a filesystem, except whereas filesystem paths usually start with the root of the filesystem and descend the tree from left to right, ...


3

The OP gave additional information of the location of the Administrator user so he has to use cn=Administrator,ou=Users,dc=ldap,dc=pathontheback,dc=org EDIT: Made a typo, it has to be: cn=Administrator,cn=Users,dc=ldap,dc=pathontheback,dc=org Users is a container, not OU.


2

You should use SSSD and configure it to use LDAP instead of working with PAM directly. Then you can use the following in the SSSD domain configuration: access_provider = simple simple_allow_groups = groupname which is a very basic way to limit users, but you could also use access_provider=ldap and then use much more advanced LDAP queries to control ...


2

Looks like this is a bug with Microsoft AD and Guest Account, fix is disabling the guest account. Guest Accounts on AD Server


1

Your OpenLDAP server doesn't appear to have TLS configured. Your /etc/ldap/slapd.d/cn=config.ldif should have something like the following: olcTLSCertificateKeyFile: /etc/ldap/ssl/ldap.key olcTLSCACertificateFile: /etc/ldap/ssl/ldap_ca.cert olcTLSCertificateFile: /etc/ldap/ssl/ldap.cert olcTLSCipherSuite: HIGH:!aNull:!MD5:@STRENGTH olcTLSProtocolMin: 3.1 ...


1

Finally it turned out that nfs was responsible. Client was v.4, while server v.3 and therefore, mount option sec=sys was necessary at the client part. Thanks to all who bothered.


1

Is your ldap base really "uid=john.martin,ou=Users,dc=company,dc=com"? It could be, but I think that is your binddn, am I right? When using ldapsearch with simple authentication I use this: ldapsearch -h host -LLL -s sub -x -W -b dc=your,dc=base -Z -D "cn=youruser,ou=org,dc=your,dc=base" ldapfilter attributes Use the manpage of ldapsearch to understand ...


1

I ran into this issue trying to get PHP extensions involved in a Docker container. Here is what I had to do: apt-get install libldb-dev libldap2-dev ln -s /usr/lib/x86_64-linux-gnu/libldap.so /usr/lib/libldap.so \ && ln -s /usr/lib/x86_64-linux-gnu/liblber.so /usr/lib/liblber.so


1

PHP Version 5.6.20 debian and based: su aptitude install libldb-dev ln -s /usr/lib/x86_64-linux-gnu/libldap.so /usr/lib/libldap.so then, try to compile it


1

I was having a similar issue. You have the fields mixed up LDAP filter: should be empty because there is some kind of issue between the Zimbra LDAP filter and Redmine's. Account: uid=zimbra,cn=admins,cn=zimbra Password: The password you entered for LDAP during installation Base DN: ou=people,dc=domain,dc=com (replace domain for your domain and com for ...



Only top voted, non community-wiki answers of a minimum length are eligible