Tag Info

Hot answers tagged

8

You want eth1 and eth2 on the same subnet so they should be on the same ethernet link: you should configure your linux box as a bridge between eth1 and eth2. This will create a new network interface (named br0 below): the kernel will work as a switch bridging your eth1 and eth2 (at layer 2). The IP configuration will be done on br0 instead of eth1 and eth2 ...


8

If you really need a quick way to transfer files, and both systems are Linux-based, you can try UDR. This is really a form of rsync-over-UDP (using the open-source UDT framework) and is particularly handy for moving large numbers of files or transferring over high-bandwidth or high-latency links. In addition, encryption is disabled by default, so the ...


7

The problem is that you can't refer multiple IP ranges in a single iptables rule, but using multiple rules indirectly leads to a disjunction (logical OR): connections will be logged if they match your first, OR your second rule. What you want, is a conjunctive behavior (logical AND): new connections coming out of 10.51.0.0/16, AND also out of ...


6

Incoming connections are always going to match one of those rules aren't they? A connection from 10.51.0.1 for example won't get logged by the first rule but will hit the second one. Don't you need the equivalent of !10.51.0.0/16 && !192.168.0.0/16 (probably not valid syntax but correct logically).


4

Just to explain why you need a bridge... A Bridge creates a link between two Layer 2 networks (eth1 and eth2 in your case) to act as a single Layer 2 network. This is Switching. A Router creates a link between two Layer 3 networks (eth0 and br0 in your case once you create the bridge). This is routing. With both clients in the same subnet, there is no ...


3

Bond them for reliability and speed and use aliases to the bonded interface.


3

This looks to actually be an issue that's occurring on your second Debian box when it attempts to send the packets in question, rather than it being anything to do with the box you're scanning. Try disabling iptables/netfilter on the second box and see if that helps.


3

The immediate cause of error is the leading whitespace in your db.10 file. Correct: ; ; BIND reverse data file for local loopback interface ; $TTL 604800 @ IN SOA necacdnsone.necone.com. root.necone.com. ( 1 ; Serial 604800 ; Refresh 86400 ...


2

If used in daemon mode without encryption, rsync can efficiently transfer large amount of small files. Give it another try using it in daemon mode.


2

Thee was a very similar q on UL: http://unix.stackexchange.com/questions/86056/why-does-linux-require-moving-ip-from-eth-interface-to-bridge-interface The analiogy is that ETH resembles an uplink L1 cable.


2

Well the problem is, as one commenter suggests, physics. For example one of the submarine cables from USA to Australia is about 12500km long. The data has to travel that path twice which is 25000km. And that is just the cable. You will have to add more for the fibers in USA and Australia. Typical single mode fiber has a refraction index of about 1.444 ...


2

To allow from only certain IP or range use the -s flag and an ip and netmask for example sudo iptables -I INPUT -p tcp -s 10.0.0.0/25 --dport 5000:5020 -j ACCEPT -m comment --comment "Allow Ports 5000s" Will allow only from systems with an IP of 10.0.0.1 thru 10.0.0.126 There is more information here IP Tables How TO To help you find a subnet to use to ...


1

I was running into the same issue. Apparently even though NetworkManager had been updated, the version that was still loaded in memory and running was older. Try restarting the service: sudo service NetworkManager restart to verify it works test the following command: sudo nmcli -p g You should see the NetworkManager status, instead of the pesky ...


1

So here's the answer after taking Matt's suggestion and going the trial and error route. The command I used had the following pattern ip route add via dev The final command actually was # ip route add 10.0.1.31 via 10.0.1.1 dev eth1 # ip route add 10.0.2.31 via 10.0.2.1 dev eth2 After adding these I had no issues pinging between the IP's on the ...


1

The problem can be at two different layers: at the forwarding level: ipforwarding can be disabled, or iptables rules be misconfigured at the routing level: your corporate network must be informed that the various 10.2.80.x networks can be reached via IP 10.2.82.195. If this is not possible, you had to "masquerade" (NAT) yours 10.2.80.x network using the ...


1

I worked this out after reading dsmsk80 answer and looking in the ifup-eth script. The key line is this: /sbin/arping -c 2 -w 3 -D -I <INTERFACE> <VLAN> So for the OP example: /sbin/arping -c 2 -w 3 -D -I eth0:1 192.168.0.2 Something I used this on recently returned this: > /sbin/arping -c 2 -w 3 -D -I eth0.1508 192.168.8.1 ...


1

You have several options Proxy - If you are interested in a limited number of protocols (e.g. HTTP) you can set up a server as a proxy server (e.g. using Squid). There are ways to set up transparent proxies but the simplest is probably to explicitly configure client applications to use the proxy and enforce this in your router's firewall (e.g. only allow ...


1

Simply have the FileZilla FTP server announce the correct external ip-address used by HA-proxy, which is something you can configure in Options --> Passive Mode Settings Normally the Linux kernel uses helper modules that scan the clear text FTP command channel for the PASV response to dynamically change that to the correct NAT response and/or to ...


1

You would normally do this using aliases (at least for IPv4) You would have three interfaces presented, each with a different IP address. eth0 eth0:1 eth0:2 Doing it with seperate devices is .... painful in the extreme, particularly when you end up with asymmetric routing/firewalling issues (throw in some external NAT device -- eg. some load balancers) ...



Only top voted, non community-wiki answers of a minimum length are eligible