Tag Info

Hot answers tagged

3

First off, it is worth noting that you will have to be running HAProxy 1.5 or later in order to use the tcp-check feature (as of writing this answer 1.5.3 is the current stable release). Unfortunately Ubuntu 14.04 (for example) ships with version 1.4 so you will need to install from another source. Personally I used the packages from here so that I could ...


2

You can't do this with mod_rewrite, as that is only for requests. Further, operating on Location is not a 100% solution (that it would be pretty high), as it won't capture things like HTTP meta-refresh (not very common these days...), or instances where the URL is generated using client-side solutions (eg. Javascript, embedded content). Thus, the desire ...


2

In the comments, you have verified that nginx process was running and telnet localhost 443 was working. But it doesn't mean that the outside party can reach your nginx. One layer you should check was firewall. It will inspect and drop the packet flowing to nginx if you don't allow rule to port 443. Sidenote: Nginx error 400 Bad request, usually means that ...


2

A couple of things you can try Update to the latest version of nginx from the official repos http://nginx.org/en/linux_packages.html#stable Try reducing the proxy_connect_timeout setting set it to something really low for testing say 1 second. http://nginx.org/en/docs/http/ngx_http_proxy_module.html#proxy_connect_timeout


1

Check if 443 port is open to the world or not. Trying using telnet telnet <host> 443 See if that work ? If not. Check the security settings of the load balancer instance.


1

Use this : location / { proxy_pass http://backend/; } The trailing slash will tell nginx to rewrite redirects from your backend to the normalized root URI, removing backend host and port and using configuration's primary server name.


1

I've hit this sort of problem previously(on a HAproxy based solution), in my case it was Exchange 2010 and ISA 2006 Server with the RPC filter enabled. We disabled the RPC filter and happy days again... I did a little searching around myself and I found this : http://geek.martinwahlberg.com/problem-using-forced-tunneling-mode-in-directaccess Which suggest ...


1

I just ran across this too. For me it was a wrong ip. In your route commands, the gateway should be the interface on the other end of the connection - that is, don't use 10.0.2.250 as the gateway, use the ip at the other end (10.0.2.1?). My guess for what is happening is that the address mapping goes into a loop, which is why it can't allocate more memory. ...


1

If your payment processor requires a static IP then you can not use an ELB on that instance. You will need to assign an Elastic IP to the instance that connects to the payment processor. The way we got around this with our application that we run in AWS was to set up a second small instance with an Elastic IP and then installed TinyProxy on it. We have a ...


1

An alternative to the 'proxy' answer is to use VPC with a NAT box for outgoing connections. We currently use a proxy for outgoing connections to our payment processor, but we're in the process of migrating to VPC. We can use a load balanced scaling group for incoming connections to our website, but the servers make outgoing requests to the payment processor ...


1

It sounds like you want to add a load balancer to your architecture. Any load balancer will likely suit your needs but they are all different. In open source world, here are some places to start looking: LVS HAProxy Nginx Apache mod_proxy_balancer You don't say what your application is but the first two are general purpose while the last two are more ...



Only top voted, non community-wiki answers of a minimum length are eligible