Tag Info

Hot answers tagged

5

Have you tried converting the gif to a postscript file? If you have imagemagick you can use: convert 1ZY437560399620027.gif 1ZY437560399620027.ps and print that? You can also use print to file in gimp or others. I'm assuming the issue is that lpr is going through a helper application that is creating the margins you have a problem with.


3

Note that running: ssh <host> echo $PRINTER ...tells you nothing about the remote environment, because $PRINTER will be expanded by your local shell. On the other hand: ssh <host> 'echo $PRINTER' ...will tell you something useful (note the single quotes). I suspect that what's happening is that you're setting the PRINTER environment ...


3

Per comment below: Install cups-bsd instead of lpr. Cups-bsd contains its own lpr binaries. This package provides the BSD commands for interacting with CUPS: /usr/bin/lpqa /usr/bin/lpr /usr/bin/lprm /usr/sbin/lpc


2

You can set the number of characters per inch with -o cpi and the margins in points (72 per inch) with -o page-left and -o page-right. For example: lp -d main -o cpi=10 -o lpi=8 -o page-left=72 -o page-right=72 filename would print 75 characters per line (assuming a fixed width font and an 8.5 inch wide page). From man lp on a CUPS-based system ...


2

try checking your printers.conf file and comment out the line: AuthInfoRequired negotiate it's a default setting in ubuntu


1

Well, it looks like the lpr is available through several different packages. I had to remove lpr from the server and then install cups-bsd which contains lpr command I needed.


1

Your printer's name, according to lptstat output is literally "printername". Running lp -d printername test.pdf or lpr -P printername test.pdf will work. For example, here's the output from a running system: [root@Smack ~]# lpstat -t scheduler is running no system default destination device for label: socket://label:9100 device for upstairs: ...


1

You need to install the LPDSVC in Windows to receive print jobs over lpr/lpd. Keep an eye on the event log for any error messages. You will probably need to enable passthrough on the printer to avoid mangling the print file. You will need some extra software to send the print to a file. We have a solution at http://www.frogmorecs.com/printdistributor.


1

Better late than never: you can get a little closer to lpr-based printing by adding gtk-print-backends = "file,lpr" to your ~/gtkrc-2.0 file. This will not get you a printer listing but should at least offer the possibility to enter the lpr command line used for printing. That's the closest to lpr printing you can get nowadays.


1

Apparently not: http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/lpr.mspx?mfr=true Well at least not according to the official Microsoft documentation.



Only top voted, non community-wiki answers of a minimum length are eligible