Tag Info

New answers tagged

1

Make sure your containers use distinct UTS namespaces then set a unique hostname in each one. For instance, things like docker set the hostname value to the container hash ID as a default in the UTS namespace associated with the main container process. Thus with a PS1 pattern using the hostname variable you will know in which container you are when running ...


0

I'm not familiar with LXC or how devices are shared between host and container, however using iptables you can forward traffic from one interface to another like so; iptables -A FORWARD -i eth0 -o eth1 -j ACCEPT Don't know if that helps you any.


0

For other readers who come here while using boot2docker, here is how I fixed. In fact, the answer above pointed me to the right direction. Basically, for some reason containers inside boot2docker couldn't resolve hostnames. So I just restarted boot2docker and started the containers. Now hostnames can resolve properly again. I suppose the problem was ...


0

This is what I finally did : The disk mounts in : /mnt/disk I want /mnt/disk/myfolder to be accessible in LXC container as /home/user/ext/myfolder So I create a folder /mnt/lxc-ext/myfolder and made lxc-ext accessible to lxc via the container fstab (provided the lxc.aa_profile = lxc-container-default-with-mounting option on ubuntu): /mnt/lxc-ext ...


6

But do I need a CPU that supports virtualization to run containerization such as Docker, or since it runs an app using the OS's libraries in a container, can I just run it on a CPU without virtualization? No, Docker (and other container solutions like LXC) do not require any special hardware support. They are effectively an enhanced version of chroot ...


1

This is definitely a feasible approach. We use Ubuntu 14.04 for our host machines and run several Oracle 11g instances within Docker containers for development purposes as well. Currently (Docker 1.5) for both 11g and 12c the main issue is Docker's hard-coded shared memory limit Issue #2606. There are currently two workarounds for this: Use docker run ...


0

OK, found another way to do it which works: Stop all containers Edit /etc/default/lxc-net uncomment "LXC_DHCP_CONFILE=/etc/lxc/dnsmasq.conf" create the file /etc/lxc/dnsmasq.conf edit dnsmasq.conf: dhcp-host=container_name,10.0.2.10 service lxc-net restart Now restart the containers and bask in the glory of your own IPs. -- EDIT -- Spoke too soon - ...



Top 50 recent answers are included