Tag Info

Hot answers tagged

10

I prefer postfix, it's easier to configure and by default, most things are turned off: Install postfix. In /etc/postfix/main.cf set these two options mydomain = example.com mydestination = example.com Replace "example.com" with your actual domain. This is very important Optionally in main.cf, set myhostname to something appropriate (could also be ...


7

You'll need a mail server installed on your node, yes. Postfix, exim, and sendmail are my preferences (in that order.) Note that some mail servers are a bit picky about who they accept mail from. If it's your local mail server, the restrictions are often done by network so you might not have a problem. If it's gmail, for example, you'll have to make sure ...


6

If root is receiving email, then you probably already have a server installed. $ sudo dpkg-reconfigure postfix If this gets an error, $ sudo apt-get install postfix (Re)configure to either deliver directly or use a smarthost. Now add "root: user@example.com" (with the correct address, of course) to /etc/aliases and run newaliases. (I think the Ubuntu ...


6

I see two solutions here. (i did configuration like this many years ago) google use many ip's as MX. You can define in transport map, that first mail is routed via gmail-smtp-in.l.google.com., and second via alt1.gmail-smtp-in.l.google.com. Then - using iptables and nat/POSTROUTING - nat connections to first google MX via first ip, and to second google MX ...


5

Remove the example.com from mydestination as mail to domains in that list is delivered via the $local_transport mail delivery transport. This is so common mistake it is separately warned in Postfix main.cf file format documentation of parameter mydestination: Warnings: Do not specify the names of virtual domains - those domains are specified ...


4

Instead putting me@example.com in transport_maps, you can skip that step and use virtual_alias_maps directly. # transport maps example.com :[mail.provider.com] .example.com :[mail.provider.com] # virtual alias maps me@example.com me@me.com Virtual alias maps is special mapping in postfix that overrides email aliasing regardless their domain ...


4

The receiving mail system cannot tell the difference between forwarded spam and real spam. If you forward email, you always have the huge risk of blacklist unless you control the receiving mail system as well. This happens often with web hosting accounts forwarding the email for a domain to Gmail, Yahoo, Hotmail, Aol, etc. You can either constantly fight ...


4

Perhaps they want you to use the Groups feature whereas support@example.com would be a group address with employee@example.com (and whomever else) as a member of that group. http://www.google.com/support/a/bin/answer.py?hl=en&answer=33329


4

The forwarding server needs to setup SRS in order not to break your SPF http://www.openspf.org/SRS


3

When it says sh: mail: not found, it's telling you that it's trying to send mail using a command called mail, and you don't have it installed. Generally, this is a link to another program called mailx. On CentOS/Fedora/RHEL: yum -y install mailx On Debian/Ubuntu: aptitude install bsd-mailx


3

What are you expecting it to do? You seem to expect the virtual_address_pipe transport to be called, but the aliasfile example you give doesn't have any pipe aliases in them... omigosh... I just reread your question for the 20th time. I got distracted by the fact that what you are describing doesn't quite gel with your example, since a redirect to ...


3

Exim is delivering locally because the destination domain matches one that you've configured Exim to consider local. Smarthosting doesn't come into it, because that only kicks in once Exim's decided to route the e-mail somewhere else, and that's not what's happening. The easiest way to handle this just to grep through your Exim config for your domain, and ...


3

You need to create mail contact. Step by step instructions. For the sake of full answer here's a cut-and-paste from the liink: Create a MailContact using the EMC: Expand Recipeint Configuration | Mail Contact In the Action pane, click New Mail Contact To create a new Contact object, leave the default (New Contact) selected | click Next ...


3

If mysender.com is only sending mail and not receiving it, it should not have any mx records on your domain. (Delete the 20 & 30 MX records). Additionally, mydomain.com referenced in your mx record MUST HAVE AN A Record, a cname record will cause problems with mail delivery. Finally, if the other users in your domain do not receive mail from ...


3

I figured this out. Basically I need to modify the mysql table that saves the aliases so that it supports multiple aliases per address, making it possible to have delivery setup for both the local domain and a remote email. This works so far, though I've heard that some people attempting this have gotten duplicate emails to the forwarded email account. So ...


3

Just do what you start in alias file - without renaming:-) buz: baz@otherdomain.com, buz If alias is expand to self then it is not expanded in loop again but skipped, so mail be forwarded outside and delivered locally. (See Exim documentation ).


3

If I understood your problem correctly I think you can do it configuring luser_relay on linux.example.com. Set in main.cf luser_relay = = $user@windows.example.com http://www.postfix.org/postconf.5.html#luser_relay If you don't have an MX record for domain windows.example.com and you don't want to create one you can use transport on linux.example.com ...


3

Do you already have a functioning incoming mail server? Have you setup MX records for you domain yet? Set up mx records in DNS Install sendmail Set up /etc/mail/virtusertable with the following forwarding line: emailaddress@mydomain.com otheremail@gmail.com


3

Top tip: just don't do this. It won't take long, then you'll have this situation: Spammer sends spam to user1@mydomain.com You forward it to user1@gmail.com GMail sees spam from you and adds you to their list of people who send spam You don't get to send any mail to GMail any more until you change what you're doing I've been there and done that. In ...


3

You set your virtual_alias_maps to a file: postconf -e virtual_alias_maps=hash:/etc/postfix/virtual Then you put in the file: user@mydomain.com myCheapGmailAccount@gmail.com you need to active the change now: postmap hash:/etc/postfix/virtual That is all.


3

with the wizard in MS Outlook creating rules is trivial. One rule for all messages with an attachment: A second rule for all messages, except those with attachments:


3

It turns out that this is actually an issue (feature?) on Google's end. If you send email from an address that automatically forwards back to you (eg. user@mydomain.com -> user@gmail.com) it will NOT appear in your inbox and only appear in your Sent Mail folder. This is apparently to prevent multiples of the same message appearing in your inbox (ie. if you ...


3

Assuming you are working with Exchange mailboxes (it's not terribly clear in your question) Set-Mailbox is your best friend. You're going to need a for-each loop to retrieve the user's attributes and properly set the destination SMTP address. If you have a whole OU of users to apply changes to, use something like: Get-Mailbox -OrganizationalUnit ...


2

Looks like you use this parameter recipient_canonical_maps = hash:/etc/postfix/recipient_canonical to provide mail forwarding. By default Canonical address mapping will rewrite both header and envelope address. So, disable header rewriting, you have two options here Configure recipient_canonical_classes so recipient_canonical_maps affects envelope ...


2

This is more than likely the case. Most providers have in effect a spam and virus filter, so before the original email is delivered it will be caught and discarded / not forwarded. Is this an IP address dedicated to you? If not, others using the IP address (example case, shared hosting) may be contributing towards the negative reputation.


2

Looks like you have send email email with sender and 'final' recipient was same, i.e. your sender is myname@gmail.com and the recipient (after aliasing) is myname@gmail.com too. Based on this fact, perhaps your problem was related to this KB: Why do I not receive mail I send to myself via a forward or mailing list? Gmail (and the gmail-based IU Umail ...


2

You can do this centrally by creating Contacts for the external recipients in AD and then configuring the forwarding to these Contacts on the relevant user objects in AD.


2

Exim needs to be told which domains it will accept email for, typically in a domain list setting early in the config file. There are two general ways that it's done: 1. a static list of domain names 2. a lookup in a local file or from a database As an example, in some previous systems that I managed it performed a sql lookup based on the domain of the ...


2

Looks like your initial goal with header_checks is preserving original sender and replace it with allowed sender of Amazon SES. The problem of your approach above is the From: header become non-standard because of multiple quotes in there. From: " "User" <user@gmail.com>" <root@example.com> Daniel R. Tobias mentioned this issue in his ...



Only top voted, non community-wiki answers of a minimum length are eligible