Tag Info

Hot answers tagged

27

Yes. Stuart Cheshire, who was the creator and is a primary maintainer of Rendezvous/Bonjour at Apple, who also co-chaired the IETF ZeroConf working group, and wrote the O'Reilly book on Zero Configuration Networking, has described Bonjour as a "three-legged stool" where the legs are (1) IPv4 (and IPv6) link-local addressing, (2) Multicast Name Resolution ...


8

Trent Lloyd here, one of the authors of the Avahi project. This is in theory possible, but it is not easy to do. Unfortunately the default mechanism for publishing a hostname in Avahi, also published a reverse-DNS record which is listed as exclusive. Thus if you try and publish 2 hostnames pointing at the same IP, you get a conflict on the reverse DNS ...


8

Since you already know the IP addresses you can look up the reverse entry for each IP address to get the associated forward address: $ dig -x 10.0.0.200 @224.0.0.251 -p 5353 ; <<>> DiG 9.6.0-APPLE-P2 <<>> -x 10.0.0.200 @224.0.0.251 -p 5353 ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: ...


4

Does your system have Vmware, Parallels or something like that? I believe that they setup a virtual network adapter and assign additional private addresses. A quick google search returned this page which suggests a fix may work. If you run 'ifconfig' in a Terminal on your OSX box do you see a 192.168.132.? address?


4

Although you can do “wide-area Bonjour” (that is, Bonjour over an ordinary DNS domain with dynamic registration enabled, rather than Bonjour over multicast DNS), most built-in Mac OS X stuff isn’t designed for using it — principally because wide-area Bonjour is designed for advertising services over something more diverse than just a couple of subnets. ...


4

First, what exactly Bonjour does (pleas read my guesses written bellow)? Here I found out that Bonjour enables automatic discovery of computers, devices, and services on IP networks. But I thought that it not only "discovers devices on IP network" it also creates an IP network by assigning IP addresses to devices where Bonjour is ...


2

Bonjour does not assign IP addresses - it is a discovery protocol - you still need DHCP/Static/Link-Local(APIPA) IP addresses for it to work. It uses multicast DNS (mDNS) to discover what hosts are on the same broadcast domain as itself and essentially it becomes its own DNS server. See Bonjour & Zeroconf for the lowdown. Unless your application is ...


2

Just for additional reference - don't know if it comes in handy with your setup: We're also running a .local network. On Ubuntu machines I've discovered that the mdns interferes with the setup unless you change /etc/nsswitch.conf: By default this file contains the line hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4 You need to place the "dns" ...


2

DNS Service Discovery is just a convention for finding services by first looking for a PTR record, eg: $ dig +short ptr _http._tcp.dns-sd.org ;; Truncated, retrying in TCP mode. \032*\032Zeroconf._http._tcp.dns-sd.org. \032*\032Multicast\032DNS._http._tcp.dns-sd.org. \032*\032DNS\032Service\032Discovery._http._tcp.dns-sd.org. << snipped >> ...


2

Thanks to @chris-s, I solved my own question by using Avahi instead of trying to route the multicast traffic. This worked for me: Compile and install net/avahi and dns/nss_mdns from the ports tree. Add avahi_daemon_enable="YES"and dbus_enable="YES" to /etc/rc.conf Use the avahi configuration file (/usr/local/etc/avahi/avahi-daemon.conf) and added my two ...


2

If you insert "search local" within the file /etc/resolv.conf, the queries will be send with the given domain for example host my-pc result in a first query for my-pc and a second for my-pc.local.


2

I seem to be answering my questions a lot on here these days, but after a day of trying things out I finally managed to get it to work by installing mod_dnssd and figuring the rest out myself (although I found the documentation to be really, really bad). Here's what I did:- 1. Install mod_dnssd sudo apt-get install libapache2-mod-dnssd 2. Import the ...


2

I am not sure I understood your problem very well but I know bridge interfaces and UDP multicasst/boradcast can trigger some eratics behaviours. To work it around you may want to disable multicast snooping on the bridge interface: echo 0 > /sys/devices/virtual/net/$IFACE/bridge/multicast_snooping Though I don't know virtualbox well enough to to be sure ...


2

This stackoverflow question sounds like what you're looking for. Sounds like a kluge to me. I would either setup DNS internally, or if you have a router/switch, make use of it's ability to perform DNS for your internal lan. Good DNS Server howto to start with.


1

Try using the samba package. You may need to install libnss-windbind as well. This should enable using WINS as a name service. You will need to add wins to the hosts entry in /etc/nsswitch.conf. I have the bonjour package installed on a Window system, but its address is not available. Media services are announce, but only have the machine name. ...


1

Generally if you are using OS X server you will be better off using normal DNS for name resolution rather than mDNS. Bonjour is really only suitable for service auto-discovery, if you have a server you will probably want to advertise or configure your services. That said Wide Area Bonjour (or more properly DNS-SD) does exist in various shapes and forms ...


1

You have to manually add a static A record in DNS for cactus. The Linux server with Likewise installed doesn't have the same "automatically register with DNS" function that Windows clients do.


1

Just realized I'm about to respond to a really old question, but maybe someone will find this useful. Have a look at your network equipment, specifically any managed switches. I've run into issues with IGMP snooping, where multicast requests might suddenly stop being received by clients after a few minutes because the switch was filtering it out. Food for ...


1

Your DNS server shouldn't be forwarding queries for company.com if company.com is your internal DNS zone. It's authoritative for company.com and the buck stops there. As for forwarding the PTR queries, set up a rDNS zone for 10.0.0.0, 172.16.0.0 and 192.168.0.0, which will stop your server from forwarding those queries for the same reason as in #1. As for ...


1

I don't frequent SF so frequently, but I can see that this question has attracted a fair bit of attention, so let me just summarise my findings here, and hopefully provide something of a solution to those experiencing the same issue:- It seems that this is a bug with the version of Avahi that ships with Ubuntu Jaunty (http://avahi.org/ticket/284) to do with ...


1

This is from installed software (which is a little concerning on a domain controller). Check through Add/Remove Programs, and get rid of anything that shouldn't be there. More info on multicast DNS here.


1

you need to allow traffic from/to 224.0.0.251/32 on your bridge interface. I don't know pf well, but you seem to specify only traffic from/to 10.0.10.0/24 in there. Assuming you trust both ends of the bridge you could just open it to traffic from all IP's or block traffic from oddball IP's from exiting other interfaces.


1

This appears to work: dig -x 192.0.2.42 -p 5353 @224.0.0.251 From Fun with multicast DNS


1

On Linux, you can use the getent command from the libc: getent hosts 192.168.0.52 Or install avahi-utils, and run avahi-resolve-address 192.168.0.52


1

In short, no. As per RFC2365 and IANA's multicast assignments, 224.0.0.0/24 is reserved for link-local multicast. This means that a multicast packet address to anything in the range 224.0.0.0 - 224.0.0.255 should never cross between IP subnets. I've not looked in to wide area Bonjour, which is mentioned in another answer, however if this is to work, it must ...


1

I've tried to have this work as expected for a long time. All I found is that these multicast packets will not cross subnets. However, the only real solution I have found is to use an mDNS Reflector daemon such as avahi-daemon on a system which spans across subnets. It also sounds like you could benefit from Wide Area Bonjour which is designed for ...


1

Have you checked your routing table to see which interface is preferred for publishing to the Zeroconf multicast group? netstat -rn | grep 224 Will return all the routing information for reserved multicast groups. Look for an entry for 224.0.0.251; this is the group used for MDNS. If there isn't a specific entry for this group, then check the entry for ...


1

In Windows, have you tried using Run > "msconfig" to disable the "mDNSResponder" service (I believe that gets installed via iTunes)? If it's running, then I'm guessing the Bonjour traffic is being generated from Windows itself. Otherwise, I would try the steps in this guide. In VMWare, open the settings for the virtual machine you're using. You need to ...


1

Actually, .local was never reserved for use for local domains, and its more recent (mis)appropriation for mDNS is somewhat controversial, although mDNS is (AIUI) likely to be approved by the IETF soon. Some of our staff use Psi and we don't have an mDNS server. Have you checked that Psi won't accept SRV records from unicast DNS instead: $ORIGIN ...



Only top voted, non community-wiki answers of a minimum length are eligible