New answers tagged

2

wanted to comment on some answers, but couldn't (not enough reputation) so replying the question: YES, downgrade is needed so that nc can listen. and as for the other comments: a) -p is not supposed to be used when in listening mode. from nc manpage: -l Used to specify that nc should listen for an incoming connection rather than initiate ...


0

I found a link that may help you: netcat: Strange behaviour with UDP – only receives first packet sent. "At this stage I wasn’t sure what to do but Nathan pointed out that if I made use of timeouts on the client and server then it would be possible to send multiple UDP packets. I restarted the netcat server but this time with a 1 second timeout: $ nc ...


1

SSH uses TCP, not UDP. You use nc -u so you send UDP packets. Just try nc -vz <ip> <port> If you want to test your iptables rules that way, you should set the policy for the INPUT chain to DROP or REJECT. Take care that you allow tcp packets to port 22 from your source before. You can allow it from the IP of the specific machine, the whole ...


0

There are 2 parts to your problem: Part 1 - Networking Configuration The first thing is that you are using 3 subnets. I am presuming you are using them all as /24's: 10.160.10.0/24, 172.10.0.0/24, and 192.168.10.0/24 VM-A is configured for 10.160.10.0/24 and 172.10.0.0/24. VM-B is configured for 192.168.10.0/24 VM-C is configured for 172.10.0.0/24. ...


1

I wouldn't recommend this as a long-term solution, but it could be good for debugging whether logstash or your shipper is working as expected. On the logstash side: input { tcp { port => 9000 } } On your client's side: cat logfile.log | nc logstash-server 9000


0

Here is a little script inspired by this blog which I called cors-http-proxy.sh: #!/bin/sh -e if [ $# != 3 ] then echo "usage: $0 <src-port> <dst-host> <dst-port>" exit 0 fi while true; do TMP=`mktemp -d` BACK=$TMP/pipe.back SENT=$TMP/pipe.sent RCVD=$TMP/pipe.rcvd trap 'rm -rf "$TMP"' EXIT mkfifo -m 0600 ...


0

The problem came from my iptables that were misconfigured. I fixed the problem by setting the input policy to ACCEPT: iptables -P INPUT ACCEPT



Top 50 recent answers are included