Tag Info

Hot answers tagged

4

I just ran pacman -Syu again and there was another update for it. Apparently the package had accidentally been compiled without proxy support and I didn't notice.


3

What you're looking for is the nginx reverse proxy feature. Read the docs.


3

"Server not found" from a browser often indicates a failure to resolve the host-name into an IP address. I notice that ubnt.aqtsolutions.com does not resolve, but the other two names do. It may be that your nginx configuration is fine and you just have a missing DNS entry.


3

The access_log directive is valid inside if, so you can simply add one there. However, its presence overrides any ones that appear above it in the hierarchy, so if you simply add one entry the request will not be logged to whatever access log you normally log for that server. To get around that, you can use two access_log directives inside the if, one ...


2

Normally if you have scripts that need more time there are a few solution. You can increase the fastcgi_read_timeout and reqest_terminate_timeout. But the problem is you shouldn't set the value too high. If you have a lot of processes that blocks each other they are open for a long time and its possible that your server can't deliver your content anymore. ...


2

May be because you don`t have A DNS record for ubnt.aqtsolutions.com nslookup ubnt.aqtsolutions.com 8.8.8.8 Server: 8.8.8.8 Address: 8.8.8.8#53 ** server can't find ubnt.aqtsolutions.com: NXDOMAIN


2

I think you can use the nginx you have for GitLab and, as @moebius_eye suggests, configure it as a reverse proxy for Etherpad and GemInABox. Also, to incorporate the functionality you wanted to approach via DNS, you could use what in nginx is called Server Blocks (a concept similar to Virtual Hosts on apache). You would have to modify your nginx configuring ...


2

The issue with Lukas's solution is HttpRewriteModule , which automatically turns everything with http(s) at the front into a 302. If you instead do the rewrite in two stages - the second one 'break' - it should work. e.g. rewrite ^(.*)$ "://registry.npmjs.org$1" break; rewrite ^(.*)$ "http$1" break; proxy_pass http://proxy.abc.lan:1234; I suspect there's ...


2

You need the break flag added to the rewrite rule, so that processing stops, and as this is inside a location block processing will continue inside that block: rewrite ^/petproject/?(.*)$ /$1 break; Note I also added /? to the matching pattern so that you don't end up with double slashes at the beginning of the url.


2

The configuration has the usual problem that generally happens with nginx. That is, using root directive inside location block. Try using this configuration instead of your current location blocks: root /home/me/Documents/site1; index index.html; location /petproject { alias /home/me/pet-Project/website; } This means that the default directory for ...


2

To get started, check out What permissions should my website files/folders have on a Linux webserver? - I'm not certain what specific tweaks to that you might need to do when using nginx instead of Apache, but I think that post and the answer(s) will give you a good foundational understanding.


2

update-rc.d -f nginx remove This command removes all /etc/rc*/nginx symbolic links. At next boot, the service is not started.


2

You can modify nginx proxy server configuration like this: server { server_name example.com; listen 80; location / { proxy_pass http://127.0.0.1:3001; } location /foo { proxy_pass http://127.0.0.1:3002; } } server { server_name example.org; listen 80; location / { proxy_pass ...


2

All of your location blocks need to be in the https server block since that's what is handling your requests. The only logic that needs to be in the http server section is what's required to perform the redirect. Edit: Now that we have the hostname in question, I can see that port 443 on your server is closed: $ nmap www.boilerplaza.co.uk -p 443 Starting ...


1

track_uploads syntax: track_uploads < zone_name> < timeout> default: n/a context: location This directive enables tracking uploads for the current location. Each POST landing in this location will register the request in the zone_name upload progress tracker. Since Nginx doesn't support yet RFC 1867 upload, the location must be ...


1

There are two directives involved here, one at nginx fastcgi_read_timeout as described here, the other is at php-fpm.conf reqest_terminate_timeout, you can set this to 0 to disable timeout. At nginx set fastcgi_read_timeout to any arbitrary large value as answered in my first link, you can set this inside any specific location.


1

As long as the specific server app/protocol doesn't support it (in the form of SRV records, wiki link), DNS can't be used for this purpose.


1

There are no proxied requests Of this block: location /ads { proxy_set_header 'Access-Control-Max-Age' 1728000; proxy_set_header 'Access-Control-Allow-Origin' '*'; proxy_set_header 'Access-Control-Allow-Credentials' 'true'; proxy_set_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS'; proxy_set_header ...


1

Just putting access_log inside if, does not work However access_log only inside if inside location and from this thread we can see the workaround: Separate Nginx access log file for certain requests only if ($http_referer ~* (bad-domain.com)){ set $bad_domain 'yes'; } location / { if ($bad_domain = 'yes') { access_log logs/bad_domain.log; ...



Only top voted, non community-wiki answers of a minimum length are eligible