Tag Info

Hot answers tagged

3

You can use the unique overlay to achieve this. See chapter 12.16 of the OpenLDAP manual and man slapo-unique (unfortunately, both still only refer the old-style configuration in slapd.conf, not the cn=config online configuration).


3

It looks like you're supplying a binddn, but bad credentials for it. Are the contents of /etc/ldap.secret and what you put in a the -W prompt exactly the same? rootbinddn is the binddn used by root on the client machine. It should generally not be the rootdn of the suffix as that would mean that compromise of the machine would also compromise the ...


2

I have struggle one this one as well for some time. Firstly check the version of openssh is >6.2 then the syntax of the sshpublickey from gosa. I had it on Debian 7.7 then dist upgrade to Debian 8 to get the latest openSSH features. Do ldapsearch -x '(&(objectClass=posixAccount)(uid='<Your user>'))' sshPublickey If you have added it with ...


1

somewhere in the slapd_start function of your /etc/init.d/slapd script, there is a line similar to: rm /var/lib/ldap/alock now, for whatever reasons, this file is non-existant, and the script stops because it fails to remove the non-existant file (which is obviously hard to remove, as it is not there anymore). you can simply fix this by telling rm to ...


1

I think this means that the consumer doesn't have a valid TGT. How do I configure the consumer to get a valid TGT? I've read some older sources that recommend using k5start or a cron job. Is this still the way to do it? Yes, that's exactly what it means. Yes, it still is, though the latest Krb5 has another option called client keytab. The ...


1

Is it possible, that the SSH server will 'understand' that the user has already authenticated? No. Just implement key auth for SSH as well. Then your users can ssh into your servers without typing a password at all (save for the initial private key load into your ssh key agent). You really should be using key authentication anyway. Doing this is a ...


1

The problem was: I was logged in as the wrong user. I'm tempted to delete the question



Only top voted, non community-wiki answers of a minimum length are eligible