Tag Info

Hot answers tagged

4

The Teredo tunneling protocol will likely do what you want, but you have to work with the protocol in picking addresses; the same is true of 6to4. You have picked your IPv6 addresses out of the air. The old IPv4 concept, of some private (RFC1918) address ranges which were globally unroutable but anyone could use (including over multiple sites, as long as ...


2

It seems like you are running a routed openVPN installation. In this configuration Netbios broadcasts are not forwarded via the VPN connection and you cannot connect using the Netbios name. See http://openvpn.net/index.php/download/60-open-source/faq.html for details on what is forwarded in which configuration. You may also install a DNS Server on your ...


1

maybe you are running into issues with MTU on the connection. take a look at the following two links, they may contains some usefull info. Configure the MTU with Fragment and MSS Optimizing performance on gigabit networks


1

I have solved it. Or rather, I know how to make it faster, but do not know why it is slow. It seems that AES cipher interferes somehow with TCP on this particular server and results in the low performance. If I change the cipher to, say, 3des (which is slower as reported by "openssl speed"), I get 150mbps. After some trials, I now use this: cipher ...


1

You need to put a match on the destination IP using -d IP. iptables -t nat -A PREROUTING -p tcp -m tcp -d 9.8.7.X --dport PORT -j DNAT --to-destination 10.8.1.X:PORT Considering that 9.8.7.X is your external IP getting the traffic and 10.8.1.X is your internal IP that needs redirecting to.


1

I doubt return traffic with data is coming balanced between links, so would recommend to test an uplink speed on bonded interface first.


1

I had the same issue, but this finally worked for me: First, enable forwarding: echo 1 > /proc/sys/net/ipv4/ip_forward And then authorize your tun0 interface with firewalld: firewall-cmd --zone=trusted --add-interface=tun0 Add --permanent to the last command to make it persistant. I had nothing more to do except the usual OpenVPN configuration.


1

Actually the problem seems to be an openvpn bug of sorts. It seems that using topology net30 (the default, though that topology is now considered deprecated) somehow breaks openvpn's routing. First step is to add topology subnet to your server config file. The other thing you need to do is to add the vpn server's IP as the route's gateway, as there's ANOTHER ...


1

SOLUTION I consider that what you can manually it is also automated. So you can do that. STEPS Download "SRVSTART.EXE" application from http://rozanski.org.uk/software Unpack and place it to path without spaces eg "c:\srvstart\" Move "SecOpenVPN" from default path "Program Files" to own eg "c:\SecurepointSSLVPN\" Run this program as an administrator ...


1

Apologies for answering my own question. The more I look at this the more it's clear that running two separate instances of OpenVPN on the same box is the right answer. For the LAN to LAN I plan to deal with the routing using RIP2. For the clients this isn't appropriate. So the options will be different on a number of points: RIP is clearly something ...


1

firewalld has some services already pre-configured which can be seen with: firewall-cmd --get-services (Configuration file /usr/lib/firewalld/services/openvpn.xml) If you see openvpn as already available service you can enable it with: firewall-cmd --add-service openvpn



Only top voted, non community-wiki answers of a minimum length are eligible