Tag Info

Hot answers tagged

4

The fact that you are using zabbix_sender implies that these items are of type "Zabbix trapper". With trapper items, the graphing behavior you described above is expected. Regular items of types like "Zabbix agent" and "Zabbix agent (active)" have update interval configured, so the frontend knows that data is expected to come, say, every 30 seconds. If ...


4

My guess is that your FTP server is behind a NAT firewall, and that you've got the ip_conntrack_ftp helper module (or equivalent) running on the firewall device. Basically, this module scans the data stream looking for instances of the internal IP address, and rewrites them to the external IP address. It can't do this for TLS-secured FTP connections, ...


3

In the command prompt of the server, enter these two commands to open the firewall: First command: netsh advfirewall firewall add rule name="FTP (non-SSL)" action=allow protocol=TCP dir=in localport=21 Second command: netsh advfirewall set global StatefulFtp enable In Amazon EC2, you also have to set up a security group to open the passive ports, such ...


2

The problem is related to the fact that Passive FTP uses ports other than 21. Read about it here: http://slacksite.com/other/ftp.html Usually if I setup an FTP server I'll either whitelist hosts like voretaq said or you can usually set the passive port range to use in the FTP config and just open those ports.


2

To cover the obvious - you are running the ftp-proxy daemon, and your securelevel is <= 1, right? (see also the ftp-proxy(8) manpage which is probably more helpful than I will be - FTP and I don't get along) In my experience FTP is horribly broken behind any halfway decent firewall -- typically I give up and allow all outbound traffic (& stateful ...


2

There is (or, perhaps, was?) a very nice daemon called SuSE Proxy Suite. It was intercepting FTP traffic and allowed one to redirect ftp-client to some specific backend-server and if my memory serves me, it allowed active<->passive conversions, too. I used the program in pretty heavy environment for years without troubles. Unfortunately my old bookmark ...


2

I had a similar issue, and resolved it by choosing "default" in the "External Server IP Address for passive mode transfers" option in Filezila server settings. In other words, don't enter your public IP address here even if you are on a private address. The reason is that your Firewall may have "FTP inspection" enabled, and it will do the translation of your ...


2

I realize that it might be a change, but the new FTP server in 2008 is very robust and I wound up replacing FileZilla myself with it. You might want to look into it as well.


2

I suggest you try to locally on the server using Windows' FTP or another installed client. This way you will see if it's network/firewall issue or an issue with the configuration of the FTP server. Also check Filezilla server's log files if the commands. If it depends on the firewall, here is a TechNet article that could help: How to Configure Windows ...


2

IIS supports both Active and Passive FTP connections by default. You don't have to do anything special to enable either one. You also can't disable either one as far as I know. You can however, configure the port range that IIS will use for Passive FTP sessions, but that won't help you here. The problem is most likely that your firewall doesn't support or ...


2

Did you open ports 60000 to 60200 in your EC2 security group ?


2

Based on the IP also being different between the server and client logs, I would suspect that the firewall is intercepting the connection and attempting to NAT it or something (although it should still work if the firewall is doing this correctly). Can you try connecting with SSL/TLS so that the firewall doesn't mess with the control connection?


2

The absolute best possible advice I can give you about FTP and NAT in practice is Just don't do it. Use a modern alternative like SFTP which adds security to the connection (sending your password in plaintext is generally considered a Bad Thing these days), and also doesn't do the deranged port-dance that FTP does. That way you don't have to worry about ...


2

In fact, it is possible. But this can change in a future version, because I think it's a bug in Zabbix: If you change the item type to 'Zabbix agent (active)' (instead of 'Zabbix trapper'), you can set the 'Update interval (in sec)' and this will work as expected, even when using zabbix_sender instead of the agent. The reason for this: Zabbix agent and ...


1

The notch indicates that it's an active cable that requires power from the device it's attached to. Not all devices support active cables, though all equipment I've used does support them (I'm particularly hesitant of that off-brand disk shelf). In any case, if the device doesn't support active cables then the cable should not latch all the way into the ...


1

I know that you mention the local firewall is fine, but if you do not have the nf_conntrack_ftp module loaded, PASV mode won't work right.


1

Either: Set up port forwarding through the NAT (on as many NAT boxen as you have) or SSH out from the machine to another box and use -R (*R*emote port forwarding) to pass the connection through. See man ssh for additional information. The first is more correct. The second can be implemented without access to the NAT rulesets, and is probably a bit ...


1

Passive FTP ports are being blocked by a firewall on the server side. There is a metabase property called PassivePortRange that allows you to specify the range of ports used for passive FTP, to match what is allowed through your firewall. See these references: ...


1

I had the same issue using filezilla ftp server. Active connections worked but passive didn't... I solved it by adding FileZilla server.exe ( in the program files folder ) to the "exceptions list" of windows firewall. Then everything worked. Just goes to show you ... RTFM.


1

HA! I got it! The key is to use -P, but you've got to use the "obvious" choice, since you can't open another port and have it connect in. To quote the documentation: - make curl pick the same IP address that is already used for the control connection So the curl command curl -u username:password -P - -o output.file ftp://whatever/source.file ...


1

This link explains Active vs Passive very well.


1

You have to specify masquerade IP on the passive command.. right now your passive command returns 192,168,15,2 (which is a private IP and will not work over public internet connections) '-P ': Force the specified IP address in reply to a PASV/EPSV/SPSV command. If the server is behind a masquerading (NAT) box that doesn't properly handle stateful FTP ...



Only top voted, non community-wiki answers of a minimum length are eligible