Tag Info

Hot answers tagged

9

I had the same problem. You must reconfigure it to find the PEAR packages. Replace the php version of Mac OS X by that of MAMP $ cd /usr/bin $ cp php php.bak (Backup the old version) $ ln -s /Application/MAMP/bin/php5.3/bin/php (link to the version of MAMP php) $ sudo chmod 0554 /Application/MAMP/bin/php5.3/bin/* (makes all the scripts executable) $ php ...


9

I came across this error after updating my PHP installation to 5.5.14, on RedHat EL v6. I had installed PHP via the Yum package manager, and then needed to re-install some of the PHP extensions I was using. In searching for tips on how to solve this issue, I came across this question, and now that I have discovered a working solution I wanted to share my ...


6

I had this problem when generating PHPDoc, during the "Transform analyzed project into artifacts"-phase. I solved this problem by executing the following command sudo apt-get install graphviz


5

Set a different temporary directory on a filesystem on which you can execute binaries. For instance: mkdir /root/tmp pecl config-set temp_dir /root/tmp or: pear config-set temp_dir /root/tmp


3

Had this error on Mac with MAMP. For me deleting .../MAMP/bin/php/php5.3.6/conf/pear.conf helped.


3

I'd rather not take any risks – if you are on blacklists, getting back out of them will be a pain. There are lots of services like TinyMail/Mailchimp that Just Work™ and offload all the problems. (If you don't like outsourcing it, I'd at least move it to a different server – no more performance penalties, and if you do happen to be blacklisted, you still ...


3

In this case, you should be able to use either From or Reply-to. It may be best put the client's address in Reply-to and use a no-reply address for your domain in the From header. If your web-server is not trusted by your email server, this may be required. If you were allowing the client to send a message, as some sites do, put the client's address in ...


2

Depending on the OS you have elected to install, you will need to install php-pear onto your system. On Red Hat/CentOS, this is yum install php-pear This will install the pear binary for you. If you then need specific pear modules, you will need to install them using: pear install "module" Where module is the name of the module. Don't forget to add ...


2

PHP 5.3 can't compile with this package.


2

Right now the Text_Highlighter package has a dependency on PEAR, which means it will pull in a bunch of other packages. To install the package into a self-contained repository you can use: mkdir Text_Highlighter cd Text_Highlighter php pyrus.phar `pwd` set bin_dir `pwd`/bin php pyrus.phar `pwd` install pear/Text_Highlighter-0.7.2 Which will install ...


2

Have you tried to uninstall them both at the same time? sh-3.2# ./pear uninstall saucelabs/PHPUnit saucelabs/PHPUnit_Selenium


2

go to the pecl xdiff directory, open xdiff.c remove the word 'static' from line 39. it's already defined in the macro in the following line. save, phpize, configure, make, make install, be happy :)


2

You need to make sure all your chef recipes are idempotent and nondestructive for your environment. Chef will always run default.rb when you require or include the recipe. Two ways to fix this: Make your PHP recipe check for installed PHP binaries, and do nothing if they are found Move the installation steps to a new recipe file outside of default.rb ...


2

You can specify that your cookbook depends on the opscode php cookbook by adding depends 'php' to your cookbook's metadata.rb. By using depends, you don't have to actually run the php cookbook. See http://wiki.opscode.com/display/chef/Metadata#Metadata-depends Then, assuming the php cookbook is available from your chef server, a chef-client run will pull ...


2

Deleting .pearrc on the home directories shall fix this problems. --Thanks God.


2

I've had the same issue with Ubuntu 10.04. All I had to do was to upgrade PEAR with -Z option. sudo pear upgrade -Z PEAR worked like a charm for me. And if you want to install PHPUnit afterwards use the same -Z option. sudo pear install -Z phpunit/PHPUnit


2

I solved the problem by reinstalling PEAR, I think Archive_Tar should be installed with PEAR


2

Use Pyrus, the next-gen pear installer and follow the instructions in Using Pyrus To Manage PEAR Installable Vendor Libs.


2

Christian is right. Pyrus is the best way to manage a local registry of PEAR-installable vendor dependencies for your application. I think the issues you're running into are caused by poorly implemented packages/channels, not issues specific to pyrus, or the method. Pyrus does not allow the user to customize the path to the data_dir for example, therefore ...


2

This is what worked for me. Tested on a Debian Squeeze amd64 installation: $ php -d suhosin.executor.include.whitelist="phar" go-pear.phar


2

You can use pear upgrade to upgrade PEAR itself: pear upgrade PEAR or: pear upgrade-all


2

Not to be rude, but 2 seconds on Google would have answered this for you. It's the first hit. It's package management for PHP.


2

That QMail instance just doesn't support the STARTTLS extension. It's a little weird that the extension is advertised in the welcome message, but since QMail needs to be patched in order to support STARTTLS, I guess the patching wasn't done properly. Bottom line: Nothing your PEAR client can do about it besides not using STARTTLS. Maybe SMTPS on 465/TCP ...


2

The following steps work for me. 1 step: yum erase php-pear 2 step: # rpm -Uvh http://ftp.iij.ad.jp/pub/linux/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm # rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm 3 step: yum install --enablerepo=remi --enablerepo=remi-php56 php-pear


1

Have you tried recreating the IIS FastCGIModule for PHP? Check the first part of this article. Also, check for the Old PHP instance on Registry Editor, I had a similar problem some years ago with Symantec Endpoint Protection Manager and solved it deleting all relevant registries (previously backed up)


1

To downgrade, you can try this: pecl install mongo-1.3.7 Then pecl list will show you that it worked.


1

I was able to achieve my goal by automating the interactive PEAR installer using the expect port for Windows. Here is the install_pear.tcl script I created: package require Expect spawn php "go-pear.phar" expect "system\|local" { exp_send "system\r\n" } expect "Enter to continue" { exp_send "\r\n" } expect "Would you like to alter php.ini" { ...


1

It's definitely in the base repo (see below from a Cent 6.5 machine). I would try a yum clean all first to eliminate the possibility of a caching issue. [gbeech@ny-man02 ~]$ yum info php-pear Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile * epel: yum.ds.stackexchange.com stack-local-prod ...


1

Check your yum configuration to learn if the packages have been excluded. Yum cannot install excluded packages, and will not even acknowledge their existence. The most obvious files to inspect are: /etc/yum.conf Each file in /etc/yum.repos.d directory


1

After days finally I could find the answer. Jsut type: sudo nano /etc/yum.conf And then remove php* then type: yum install --enablerepo remi php-pear php-devel good louk!



Only top voted, non community-wiki answers of a minimum length are eligible