Tag Info

Hot answers tagged

7

My guess would be either: pecl install mongo is actually installing a pre-built binary (which would be really dumb, but wouldn't be nearly as surprising); or You've still got the old php5-dev package from your 5.3 installation sitting around, and pecl is finding and using that instead of the 5.4 version. Take a look at your PHP-related packages list (dpkg ...


6

sudo yum install libicu sudo yum install libicu-devel.x86_64 sudo /usr/bin/pecl install intl sudo echo 'extension=intl.so' >> /etc/php.ini And you are good to go. And better enter the extension=intl.so manually to php.ini or even more elegant create a new .ini file in the /etc/php.d/ directory.


5

If you have the (patched) extension source code locally you can bypass PECL entirely: # cd extension_dir # phpize # ./configure # make # make install (phpize is a binary that comes with PHP - It prepares the extension to be compiled, the rest is pretty straightforward).


5

You are correct, you can't install the PECL package because as of PHP 5.3 Intl is part of PHP. If you installed PHP using YUM, you can just pull down the intl package: > yum list php*intl > yum install <file_from_above>


5

APD doesn't compile with PHP 5.3. See bug. Try apply patch. Edit apd-1.0.1/php_apd.c, change this line: CG(extended_info) = 1; to CG(compiler_options) |= ZEND_COMPILE_EXTENDED_INFO;


4

For anyone else who may have arrived here looking for an answer but the accepted one didn't fit your case - I may have your solution! I didn't have a setup problem - at least not to my knowledge. I am running nginx + php5-fpm. My php.ini file was correctly configured and all my other extensions were working properly - test it with phpinfo() or php --ini. ...


3

Just install autoconf manually: As per http://developer.casgrain.com/?p=125, Download the latest release http://ftp.gnu.org/gnu/autoconf/autoconf-latest.tar.gz Extract the files do a normal ./configure; make; sudo make install;


3

This issue is fixed in 3.1.0RC1 and 3.1.0RC2, but those are still beta (at the present time), so if you're getting this error, it's probably trying to install imagick 3.0.1 which has this problem. So instead of using "pecl install imagick", get the beta version instead: pecl install imagick-beta


3

I was finally able to solve this myself. I ended up doing: apt-get remove graphicsmagick-libmagick-dev-compat imagemagick imagemagick-common apt-get autoremove Then: apt-get install libmagickwand-dev And finally was able to get imagick installed via pecl without error: pecl install imagick-beta


3

Your error reads: PHP Fatal error: PHP Startup: To prevent data corruption, you are not allowed to turn on the mongo.native_long setting on 32-bit platforms in Unknown on line 0 The key here is the mongo.native_long setting. Seems like your OS is 32-bit, but this specific setting requires a 64-bit OS. The best long-term solution for you if this is ...


2

Your actual issue is that pecl can't find autoconf: Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF environment variable. Then, rerun this script. Try searching on that basis and you should find what you need - it seems that at least once person has just compiled and installed autoconf: wget ...


2

You're missing the package php5-dev: http://packages.ubuntu.com/quantal/php5-dev By activating php-fpm during configuration of PHP 5.4 you enable php-fpm: http://php-fpm.org/


2

I'd suggest either installing from the aur php-imagick package or taking a look at it, arch's php is patched a bit. I just installed the aur package without a problem. If the aur package fails for you, let the author know. The issue is almost absolutely caused by not having a version of the imagick extension that is in line with your php version -- the ...


2

Its windows I guess (from c:\xampp\php). So pecl would not work as it compiles the extension and for it needs, a c compiler, php headers and other stuff. The easiest way is to download a prebuilt dll and add it to your extensions dir. I have also installed xampp on my win dev machine and done the same thing. Grab the appropriate dll from ...


2

No need to use pecl. Install memcached extension module for PHP5: $ sudo apt-get install php5-memcached test.php: <?php $m = new Memcached(); $m->addServer('127.0.0.1', 11211); var_dump($m->getStats()); ?> $ php test.php array(1) { ["127.0.0.1:11211"]=> array(24) { ["pid"]=> int(2462) ...


2

I know this is an old post but thought I would answer it as I have just come across the same error and had to fix it. Not sure if you found this patch on your travels but it worked for me. The link bellow will lead you to patch that should fix this build error http://pecl.php.net/bugs/bug.php?id=16727&edit=1


2

Let you try the blow commands. % pecl download apd-or-whatever % tar zxvf *** % cd the-directory % /Applications/MAMP/bin/php5/bin/phpize % ./configure CFLAGS="-arch i386" --with-php-config="/Applications/MAMP/bin/php5/bin/php-config" % make % make install I'm using MAMP1.8.4 with manually compiled PHP5.3.2. In MAMP1.9.x, the paths of phpize and ...


2

to install libssh2 on centos follow the next steps: download libssh2 from the official website (look for in google - i don't have reputation and can't post but 1 link) extract it somewhere, then open a terminal and go in the folder where you extracted it and type these commands ./configure make make install ALSO you can install the rpmforge repos ...


1

Hey, '/usr/include/php/ext/pcre/php_pcre.h:29:18: error: pcre.h: No such file or directory' You're missing 'perl-compatible-regular-expression' header file. Why don't you install development package for pcre first and then try to recompile? I'm not sure what that package is called on macports, on debian, for example, it is called 'libpcre3-dev'. -F


1

PHP 5.2.10 isn't available in the default CentOS repositories, so your output above suggests it was updated using a non-standard repository (I think Remy offer 5.2.10). The issue is that the repository seems to have only been temporarily enabled so you've installed memcache (possibly as a side effect of iRedMail) using a different repository and so for a ...


1

Your best option is to install the PECL package as you were doing, the problem you have there is that you're missing the php headers, they're necessary for any compilation involving php code. Try downloading the headers (available in the source code package) and copying them were PECL is complaining until you get your PECL module compiled. Best of lucks! ...


1

/usr/bin/pecl install intl Search log checking for icu-config... /usr/bin/icu-config*. You'll need a path of the directory which has /bin/icu-config later. Download php: wget http://us2.php.net/get/php-5.3.6.tar.gz/from/jp.php.net/mirror tar xvzf php-5.3.6.tar.gz cd php-5.3.6/ext/intl/ compile and install intl module. phpize ./configure --enable-intl ...


1

This can occur if your are using wrong parameters or installation is file is corrupted. ...


1

configure script can have a hard time determining the V8 version if you don't have V8 installed in the usual location (directly in /usr or /usr/local). I used: export CXXFLAGS="-I/usr/local/mydir/include -Wl,--rpath,/usr/local/mydir/lib" before running the configure script ( --with-v8js=/usr/local/mydir ) so that it could find the v8 version. Really it's ...


1

config.m4 is located in the trunk Maybe download and install without pecl? http://pecl.php.net/package/sca_sdo Follow the readme in the packaged version: http://pecl.php.net/get/SCA_SDO


1

To correctly install stomp extension (with pecl) on systems where openssl is not on the expected /usr but is nevertheless reacheable system wide, instead of specifying a folder for finding the libraries, just type "yes". ref: https://bugs.php.net/bug.php?id=63935 This will force the system to find the system default. If you use manual compilation, just ...


1

I looked in my apache log and found the following error OAuth: Unable to initialize module Module compiled with module API=20090626 PHP compiled with module API=20100525 These options need to match in Unknown on line 0 So it was indeed getting compiled with the wrong target version. All I had to do was sudo apt-get install php5-dev Then rerun the ...


1

From the release announcement: ext/sqlite3 and ext/pdo_sqlite are not affected Hence you should be converting your code to use sqlite3. There's a crude shim for the procedural API in the comments here.


1

Out of the long terminal session you posted, the only important piece is: Cannot find libpq-fe.h So use whatever tools your distro provides (you didn't say which distro you're using) to find the package that has that file. Then install that package and try again. It's probably named libpq-devel or similar. For example in Debian-based distros, you can ...


1

I will suggest to remove all packages installed from source and install necessary packages via yum from http://dl.iuscommunity.org/pub/ius/testing/CentOS/6/x86_64/ # rpm --import http://dl.iuscommunity.org/pub/ius/IUS-COMMUNITY-GPG-KEY # rpm -ivh http://dl.iuscommunity.org/pub/ius/stable/CentOS/6/x86_64/ius-release-1.0-11.ius.centos6.noarch.rpm # yum search ...



Only top voted, non community-wiki answers of a minimum length are eligible