New answers tagged

1

If your VLAN and routing settings are correct, that shouldn't be a problem. We use pfSense as DHCP/ gateway for all our physical and VM servers (the pfSens is a VM).


0

The default configuration file on pfSense 2.3 has em0 assigned as WAN, and em1 assigned as LAN. If the target hardware has em0 and em1, then the assignment prompt is skipped and the install will proceed as usual.


6

In BSD, network interfaces are named after which driver they use. So in your case, emX = Intel, and bgeX = Broadcom. Any of your interfaces can be used for any purpose within pfSense. It's just up to you to examine the performance characteristics of each and decide accordingly.


0

Have you tried the pfsense console in the virtualbox manager? Go to shell, and use tools like netstat -r, arp, ping, ifconfig to see what's going on from the pfsense end. Default for web configurator may be set to https:// (port 443)


0

The AutoConfigBackup module may suit your use case. It stores the complete configuration of pfSense in a single XML file. You could grab, modify and push this file to as many pfSense instances as you want. <?xml version="1.0"?> <pfsense> <version>11.9</version> <lastchange/> <theme>pfsense_ng</theme> ...


2

You need the read the manual for your modem You can often connect to a modem that is in bridge mode following the user manual's instructions to verify it's settings. Try connecting it to a PC/laptop and if you get the address 192.168.1.100 try connecting to http://192.168.1.1 (my last modem was like that). There might be an admin interface there. Once you ...


1

You can't just assign your WAN IP. The modem or whatever upstream device you have has to either be in bridge mode, so the firewall behind it gets your public IP, or otherwise configured to pass through the public IP. Without knowing what you're plugged into upstream, can't offer any specific suggestions. Look into how to pass through your public IP with your ...


1

Guessing maybe you still have block private networks enabled on WAN? If you're connecting in from 192.168.1.x at least, and WAN is really a LAN in your case. On an unrelated note, it's always preferable to use UDP for VPNs unless TCP is required for some reason (can't pass UDP between client and server).


0

What you're doing there is only changing the config. That much of it's correct, but then you need to apply those changes. For the case of VIPs, check what firewall_virtual_ip.php does when you apply changes. https://github.com/pfsense/pfsense/blob/master/src/usr/local/www/firewall_virtual_ip.php#L48 Do that in your code after doing the write_config.


0

The pfSense php shell might help you out. Docs at https://doc.pfsense.org/index.php/Using_the_PHP_pfSense_Shell It appears to allow you to edit and view the config from the ssh shell.


3

TCP/IP basics: throughput <= TCP buffer size / RTT My question is: would scrapping the Netgear FVS336Gv3 router for a dedicated x64 box running pfSense increase throughput over the VPN tunnel? I doubt it, because ... Is the lack of throughput over the VPN tunnel the result of hosting file shares using Samba? Definitely no, your ...


0

Most of the heavy lifting in that circumstance is done by the OpenVPN server system, which sounds like resides on a system separate from the Netgear. From your description, it's unlikely the Netgear is the cause of the slow down, at least not because you're exceeding its capacity. Verify you don't have any traffic shaping or QoS configuration on it that ...


0

You don't want it allowing external DNS lookups. The built-in DNS Forwarder and Resolver are strictly for providing name resolution for your internal machines. If you want a public name server, use something that's designed to be a public name server. The BIND package if you must run it on the firewall, best to use a service provider or something on a ...


0

Ensure that Network Interfaces is set to All in Services > DNS Resolver Then add a rule like the below in Firewall > Rules > Wan:


0

It's not that Squid is changing it from HTTP to HTTPS, it's that NAT reflection doesn't apply to traffic initiated by the host itself (which is the case for Squid). Traffic from the LAN hosts would hit the reflection. So what you're hitting is actually the web GUI of the firewall, not your internal server. That's where the HTTP to HTTPS redirect comes from. ...



Top 50 recent answers are included