Tag Info

New answers tagged

1

I had the same issue. What I did to solve this was to check the user running nginx, php-fpm and check their permissions for accessing the folder where the root is. It is be default 'www-data'. but you can find out by using the ps aux | grep php-fpm and ps aux | grep nginx commands. You have to make sure the folder is accessible to the user running these ...


0

Figured it out ... I passed php_fastcgi to a port while my www.conf was waiting for a socket. So I've changed the default.conf file to: fastcgi_pass unix:/tmp/php-fpm.sock; Another thing that did the job was changing the listen.mode to 0660 on the www.conf file.


2

I will answer here since i cannot comment (yet). Since you tagged your post plesk, I assume you host your code using plesk which only uses your original root filesystem /. If you want to give an user access to /data you need to create a symlink in their home directory (somewhere here: /var/www/vhost/yourdomain.com/httpdocs). Try something like this: cd ...


0

Hello you just got to do this open the phpinfo() page in the browser from your web server directory. Then take note of the location directive that says the source of the php.ini file being loaded and then open it as a superuser and find the max_filesize directive and set it accordingly. The file section is as follows and tells you which file to find and ...


-1

Your configuration is unlikely. I have correct them and simplified it. server { listen 80; server_name ponix.com *.ponix.com; access_log /var/www/ffdb/access_log combined; error_log /var/www/ffdb/error_log; charset utf-8; root /home/ponix/public_html; index index.php index.html index.htm; location / { allow ...


2

As i understand you need to enable fastcgi_intercept_errors in your location: fastcgi_intercept_errors on http://nginx.org/en/docs/http/ngx_http_fastcgi_module.html#fastcgi_intercept_errors: Determines whether FastCGI server responses with codes greater than or equal to 300 should be passed to a client or be redirected to nginx for processing with the ...


-3

To update the PHP Extension in Linux: Step 1: Login as a root step2: type--> Yum install php-xml step3:service httpd restart // restart the service


0

This is a wild shot in the dark, so if it's wrong, I apologize for leading you in the wrong direction. Maybe your ldap service is running out of available file descriptors (each network connection consumes one FD). On my ldap servers, I upped the default limits: OVZ-CentOS65[root@ldap1 ~]# more /etc/security/limits.d/ldap.conf @ldap soft ...


1

I found that moving my php matching block above my root location block worked just fine. location ~ \.php$ { include fastcgi.conf; fastcgi_intercept_errors on; fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; include fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; } location / { root ...


0

You're missing the MySQL client libary, not the MySQL library itself. The error is complaining about: libmysqlclient.so.16 Try installing the mysql-libs package. If you've already installed it, try reinstalling. libmysqlclient.so.16 appears to be part of it. Where did you get the MySQL packages from that failed to install? You might have to clean out some ...


0

Squid starting from version 3 can act as an ICAP client. If you manage to build your own ICAP server or a plugin to already existing C-ICAP server (for example) then you will be able to filter contents of HTTP(s) requests and responses and not only URLs as in case of url rewriter. See the description at http://wiki.squid-cache.org/Features/ICAP and list of ...


0

I had the same problem, when I looked for a solution I found out that this is a security option for Exim. The only thing you need to do is to add 2 lines to Exim configuration file so it lets the untrusted users to write the envelope for their emails: http://www.gossamer-threads.com/lists/exim/users/21084


0

If anyone is having the same issue, I updated the jDownloads component to the latest version (1.8.2) for Joomla 1.5 and it fine. Just need to start the upgrade process from 1.5 to 3.x for Joomla.


0

DotDeb provides packages for PHP 5.5 and 5.6 on Debian Wheezy.


1

RedHat doesn't keep up with latest changes and only backports security fixes. So you will be stuck at 5.3.3 as long as you are on RHEL/CentOS 6. This is to ensure stability of enterprise systems. Like you said, you don't want 5.6 or something. Install the IUS Repo to get newer versions of PHP. They've deprecated 5.3 to their Archive repo, but you can still ...


0

From your vague question I guess you want to do something for the HTTP headers or request URIs. For that you can use url_rewrite_* parameters in Squid. For example, configuring Squid to use some PHP script for determining the correct URL you could put url_rewrite_program /path/to/your/script/squid_url_rewrite.php in Squid config and make sure your PHP ...


0

If I am understanding your question correctly you are looking for the url_rewrite_program directive. There is even an example using php and ofcourse there a lot more fun examples in April Fools Pranks with a Squid Proxy Server even though all of them are in perl.


0

Try The Below Code and change the extension whatever you want to hide: 1.For html file RewriteCond %{THE_REQUEST} ^[A-Z]{3,}\s([^.]+)\.html [NC] RewriteRule ^ %1 [R,L,NC] RewriteCond %{REQUEST_FILENAME}.html -f RewriteRule ^ %{REQUEST_URI}.html [L] 2.For php file RewriteCond %{THE_REQUEST} ^[A-Z]{3,}\s([^.]+)\.php [NC] RewriteRule ^ %1 [R,L,NC] ...


0

<Directory /home/myserver/www/mywebsite/forum> suPHP_UserGroup myuser myuser </Directory> solved it.


0

You must check the certificate validity, maybe the problem be related with this bug: TLS_REQCERT=never ignored when the issuer certificate is expired Summary: Description of problem: Setting TLS_REQCERT=never is ignored, when the server certificate is before/after validity period. In that moment, connection fails. Version-Release number of ...


0

A simple sudo yum update php will update php and it's dependencies to the latest version that hase been released by CentOS.


1

I have run into the same issue and I suspect the answer lies in the package description: APCu is userland caching: APC stripped of opcode caching That is, APCu is not functionally equivalent to APC, and will not be used if your application isn't explicitly calling it to store its own data. What would usually fill the APC cache automatically would be ...


0

Why use SFTP? Give WordPress to write permission then it will be solved. u said you're using Nginx then set chown -r nginx:nginx /var/www/html replace /var/www/html with your site dir path so WordPress will able to update automatically.


1

As Christopher Perrin said "If you need a version that is not in your distribution's repos you are getting into dangerous waters." - this confirmed my suspicion that unless you seriously know what your doing, it should be left well alone. Also that a minor release shouldn't be a issue. This made me search for information about updating minor versions when ...


1

You can use ACLs (access control lists) to set additional group permissions, which can be set with the setfacl command. For example: setfacl -dm g:apache:r /home/someuser/some_dir/subdir1/subdir2 When you do an ls on that directory it will show a + sign next to the permissions to indicate an ACL is set: $ ls -ld /home/someuser/some_dir/subdir1/subdir2 ...


1

i'm not certain about this, but first make sure you are reading the memory descriptions correctly. linux will clump similar processes together, but often times this is misread as "linux has ate my memory". see this page for more info: http://www.linuxatemyram.com/ once you are sure this is your bottle neck, you might consider a few things. how is PHP being ...


0

Check all your code for local paths like C:\ G:\ etc, and fix it. When you migrated your code it is trying to access files which are not on the server, because the paths are wrong. These paths (starting with C:\xampp\htdocs) are in your WordPress database or in the configuration files. Check it and fix them to match the new ones. edit: You'll need to ...


0

After trying the exec command with two pass and mp4 box removed things worked fine. I then tried two pass by itself wondering if it was an issue with the pass log file and that also worked. So obviously it was MP4Box that caused the problem. After some reading I found out that MP4Box will not save from one partition to another. WARNING: MP4Box may create ...


0

It sounds like you're describing something that can be used to send unsolicited email (the "receipt email to the user"). That's spam and, irrespective of the CAPTCHA it will be abused. I'd tell your client that the "receipt" email violates acceptable use policy with your host (because it probably does) and turn it off.


1

You can't. MySQL is unable to differentiate between a CLI session and a connection from a library, or at least has no permission model to act upon that difference. Generally, you have to make the permissions as specific as possible. A connection that should be allowed from a specific webserver should be restricted to that server alone. This reduces the ...


1

You generally deal with that in 1 of two ways or both if you want. You set the grant location to only allow the user connect from an ip, ip range, or hostname from where you want the user to connect to So for example GRANT SELECT, INSERT ON mydb.* TO 'someuser'@'127.0.0.0.1'; To grant select and insert from localhost only. Or say your web servers are on ...


0

I was able to achieve my goal by automating the interactive PEAR installer using the expect port for Windows. Here is the install_pear.tcl script I created: package require Expect spawn php "go-pear.phar" expect "system\|local" { exp_send "system\r\n" } expect "Enter to continue" { exp_send "\r\n" } expect "Would you like to alter php.ini" { ...


1

If you have PHP on your server and know a bit of programming, you can use a PHP library called "phplibsec". This library allows you to connect to a computer via SSH and execute specific shell commands. You can get store command results in PHP variables, so you can develop you own solution. I'm using it to develop a simple file browser through SSH on my ...


1

You have no location block forwarding requests for php files to a processing backend. Add a location block for php files and use nginx fastcgi_module into it, then convert rewrites to php files from break to last. You can find alot of examples on server fault : search. Update : root location block fix as asked in comments. Your regex already matches / so ...


0

It might not be the most pretty - but this was our solution: yum install libyaml yum --disablerepo=epel install php-pecl-yaml We needed epel to get libyaml but we did not want epel with php-pecl-yaml This allowed us to continue to use php-extension instead of php55-php-extension


0

This worked for me perfectly. Install LDAP libraries: apt-get install libldb-dev Create SO linker files: updatedb --prunepaths=/mnt cd /usr/lib if [ ! -L liblber-2.4.so.2 ]; then ln -s "$(locate liblber-2.4.so.2)" fi if [ ! -L liblber-2.4.so.2.8.3 ]; then ln -s "$(locate liblber-2.4.so.2.8.3)" fi if [ ! -L liblber.so ]; then ln -s ...


0

Nginx has an event driven model so it doesn't block on request processing. But if you are running only one worker process then you should set multi_accept on; in events block so the worker process accept multiple connections at a time.


0

Seems all I had to go was open up the cacert.pem file and add the contents of the server.crt file to it. For those reading, server.crt was the file that got created when I created the cert and which I copied over to: C:\xampp\apache\conf\ssl.crt\server.crt


0

My guess is you are using a 32 bit operating system. If that is the case you won't be able to go beyond 2GB with apache and PHP. See this article for more information: http://doc.owncloud.org/server/6.0/admin_manual/configuration/configuring_big_file_upload.html


0

You may be updating the wrong file. Verify with the php -i command. For example: $ php -i 2> /dev/null | grep php.ini Configuration File (php.ini) Path => /usr/local/lib Loaded Configuration File => /usr/local/lib/php.ini


0

(Assuming you're on Ubuntu) Please try configure --with-ldap-libs=/usr/lib/i386-linux-gnu/. If doesn't help, please extend your answer with details on which Linux distro do you use and which project you're building.


2

This is due to a limitation of RPM/YUM on Amazon Linux, and the way that the multiple versions of php are packaged. One of the features of Amazon Linux is that there are multiple versions of several languages and other opensource software packages. In many cases these packages have to conflict with one another, as the software is not designed to be installed ...


0

For the service not working on port 25, it might be either that the service was configured but not actually started, or that something (an anti-virus or local firewall?) was preventing it from being reached on port 25 (here we have McAfee VirusScan and one of its features is actually blocking unlisted applications to connect to anything on port 25...). Do ...


0

In your VirtualHost directive: <Directory /home/dir/public_html/www.site.com> AllowOverride All Options FollowSymLinks Require all granted RewriteEngine On RewriteCond %{REQUEST_FILENAME} ^/((.*\.php)(/.*)?)$ RewriteCond %2 -f RewriteRule . fcgi://127.0.0.1:9001/%1 [L,P] RewriteOptions Inherit </Directory> Site ...


2

I have had the same experience. To disable FastCGI on my wordpress installations, I have done the following: In the IIS manager, I created an App Pool for wordpress. Then, under "Web Sites", browse to the folder containing your WordPress installation. Right click on that folder, and select "Properties." On the "Directory" tab, create an application. ...


0

AFAIK which libraries to use are compile time options and not something that can be changed at run-time.


1

# yum install --enablerepo=ius-archive php53u-mysql # yum install --enablerepo=ius-archive phpMyAdmin3 Works now on RHEL 5.5


0

Take a look at the mail.add_x_header directive in PHP: http://php.net/manual/en/mail.configuration.php#ini.mail.add-x-header It will add an additional mail header with the name of the originating script.


1

A PHP file on the server could have a vulnerability written into the code. One such example would be code that takes user input and does not do any sort of validation checking of the input. There are bots typically used to find this type of code and validates that it can exploit it. The virus will then replicate itself to every PHP file that is can find. ...


0

The only thing that can reasonably be inferred from the fact that files were modified in a directory where no FTP access is allowed, is that they were not modified using FTP. Which means something else in the server has been compromised other than FTP. Which means you should be even more eager to nuke it ASAP.



Top 50 recent answers are included