Tag Info

Hot answers tagged

4

Well, unless you cut-and-pasted it wrong, that first line should also start with a comment. That is, change Firewall configuration written by system-config-firewall to # Firewall configuration written by system-config-firewall You might want to pay closer attention to that second line, too; there's nothing wrong with it, but you should probably read ...


2

I would use socat for that: socat TCP-LISTEN:6379,fork TCP:10.1.0.2:6379 You might want to run this using supervisor or a similar tool. On ubuntu: apt-get install socat supervisor cat > /etc/supervisor/conf.d/redis-socat.conf << EOF [program:redis-socat] command = socat TCP-LISTEN:6379,fork TCP:10.1.0.2:6379 autorestart = true user = nobody EOF ...


2

You are assuming the router is performing NAT. The router will drop the packet, or less likely send an ICMP reject code routers don't forward anything that is not "established"(outgoing/STUN) or port forwarded (firewall/uPnP). Just like if you were running Apache and IIS on the same box they can't both directly use the same port. IIS comes with a proxy ...


2

I assume your router is running NAT? Because why else would you have "port forwarding rules". If so, the packet will get dropped by the router.


1

hi, i have a host system with 2 interfaces, eth0 and eth1. eth0 will receive packets with ip of 127.3.x.x. i want to forward these packets to go out of eth1 to a server (10.0.1). eth1 has ip of 192.168.0.100. the server needs to see the packets as if they are coming from the host (192.168.0.100). i think i can remove -m flag, but when i do, i am getting ...


1

Your port-group ManagementPorts configuration should specify the internal port number (443), rather than the external port number (8642). The NAT translation rules are applied before the firewall rules, so by the time it gets to your firewall rule, it's requesting access on port 443. That's why adding 443 fixed things.


1

I agree that VPN is a more secure solution. However, what you're asking can still be done. If you go with the solution you're suggesting, I'd highly recommend that you also replace the HTTPS cert with a valid cert, that has been signed by a root CA. Otherwise you're at risk of a man-in-the-middle attack, because the self-signed cert that ships with the ...


1

I had exactly the same question and found the answer with help of this community. Here is the link: Port redirection with iptables to localhost / blocking the destination port I solved the problem by marking the packets incoming on 8080 and filtering them afterwards: iptables -t nat -A PREROUTING -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 8080 ...



Only top voted, non community-wiki answers of a minimum length are eligible