Tag Info

New answers tagged

-1

Quick put together. Try this: Note for Windows users, Skype is known to use port 80. Also, make sure Windows IIS Web Server is not running. Address is already in use Something else is already using the port in question. Run one of the following commands to check if a running process is holding the port needed by apache open. On Linux/Unix run $> ...


6

What you have in your question is not a sshd_config that is a ssh_config. You need to edit sshd_config instead and restart sshd afterwards. ssh_config is the client configuration and has no effect on daemon settings.


0

You did open your firewall correctly. In order to "open" the port, you need to actually have a service running that listens on port 8080.


0

Are you getting any errors when you start samba? Is the ArkOS server behind a firewall? Run nmap to be sure the port is open: nmap -p 1445 localhost


3

In most cases it is better to just use HTTP, as sooner or later there will be a firewall you need to cross. Most OSs allow the HTTP address space to be divided up between processes.


5

Caused by: java.net.SocketException: Permission denied You need to be root (superuser) to bind to ports under 1024. That's why 9443 works, but 443 doesn't.


15

Yes, IANA maintains the official service and port number registry. The process for getting a port number assigned to you is documented in RFC 6335. A review process is required for any port assignment, but it is much stricter for ports < 1024; such assignments require (among other things) that your protocol is documented in an RFC. (Note that this ...


1

If you are using cmder (or msysgit/mingw that has scp & ssh), I just wrote a simple python script for this. It can be found here: https://gist.github.com/ceilfors/fb6908dc8ac96e8fc983 Sample usage: python ssh-copy-id.py user@remote-machine. Password will be prompted upon running the script.


1

I don't know enough about Windows socket cycling to answer this, but I am guessing the server closes connections and sockets are sitting in TIME_WAIT state where they cannot be used again until they expire. The "right" way to solve this problem is to add more tuples - increase outgoing ports on the client (which you have done), add listening ports on the ...


1

Create another vhost: <VirtualHost 23.227.161.55:80> ServerName rystuff.net ProxyPass /jenkins http://localhost:8080/ ProxyPassReverse /jenkins http://localhost:8080/ </VirtualHost> You do not need ServerAlias if its the same as ServerName


1

What you are describing requires layer 7 awareness. Look at details around reverse proxy such as nginx, apache, haproxy. DNS doesn't give you any control over port. Iptables might work.


3

Your lsof output looks fairly conclusive that php-fpm is not listening on port 9001 (though you might like to use sudo netstat -plnt for a more concise listing that's faster to generate). Presumably then, the issue is with php-fpm. I'd suggest you forget about nginx for the moment, and use telnet localhost 9001 for debugging. I expect you'll see a failure ...


-1

Well, I was able to make this work via different solution. As Sander Steffann stated in the comments, it probably isn't possible to do this via iptables and/or ufw. Instead, I came accross an daemon xinetd, which helped me accomplish what I wanted - simply redirect 80 to 8080 on both IPv4 and IPv6 connections.


1

Your "iptables -A " may come after a reject rule. You need to check with iptables -L . note: iptables -I would insert the rule at beginning instead of appending it with -A


6

Sorry to say it, but If you've failed a PCI-DSS on this - you've got a whole horde of problems. Not least that a home router (NETGEAR DG834G) doesn't have the necessary level of logging required for the PCI regression test which you will have to go through. Further to this, the actual complaint in your message is that your router admin interface is ...


-2

jyoti Gurjar@: go to Control Panel-->Network and internet Connection-->Change Firewall Setting--> Exceptions--> Add prt--> then type ,port name=MySql and port no.=3306. -->ok :):):)


2

I sent an email yesterday night (before I posted this question) and I finally got a response from a Linux Administrator at Host Gator (I'll update if this works): Hello there! HostGator has built a custom firewall that's in place by default on all VPS and dedicated server plans. Luckliy, there is a file in the firewall configuration that is meant to ...


1

I found several references on the Internet that indicate that HostGator installs a custom firewall script on their VPS and dedicated servers. However I wasn't able to find any instructions on how it was installed or how to get rid of it. I would contact HostGator for further information, or consider switching to another provider.


7

In order to have the iptables rules stay in place after a reboot, you have to explicitly set that. In CentOS, after your rules are in place, you can run: /sbin/service iptables save More info here: https://library.linode.com/securing-your-server#sph_creating-a-firewall (See point #10)


2

Try netstat -tlnpu as root user and see if your application is listening on 127.0.0.1:8080, 0.0.0.0:8080 or something else. If it is bound to localhost (127.0.0.1) it surely won't work outside. Another option is that a firewall is blocking the traffic.


1

You forgot to open your firewall port 8080.


1

Actually you have enabled the submission port by uncommenting it It is port 587. You have not enabled port 465 as it is not uncommented ( below the submission settings) 465 as a service postfix doesn't know. You need to change that back to smtp as it was. That defaults to port 25. Sound like you won't use it but port 25 is used for other communications. So ...


0

I had to modify the above answer to include the -i option which allows you to specify which interface the rule should be applied to. When I ran the rule without the option, it was not showing up in iptables -L but after specifying the interface, it worked like a charm. From the iptables -h docs: [!] --in-interface -i input name[+] ...


2

PHP FPM Pool Names From your diff it appears you have duplicated PHP pool names in /etc/php-fpm.d. I am pretty certain only the configuration file that loads last will be in effect. As a result, with duplicate pool names only the last loaded name/port pair will spin up. Looking at your data, perhaps my-app-dev.conf and my-app-deploy.conf share the same ...


0

iptables -A INPUT -p tcp --dport 7676 -s 64.222.33.44 -j ACCEPT iptables -A INPUT -p tcp --dport 7676 -j DROP


1

If the service software allows binding to specific IP addresses, you can bind it to 127.0.0.1 address. This means it will listen to requests only arriving via the localhost interface.


3

You could use iptables for this. What you have go do is insert a DROP rule into the INPUT chain for packets with a destination address of your external IP 64.222.33.44 and a destination port of 7676.


1

The rule should be added to the INPUT chain after the -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT rule and before the -A INPUT -j REJECT --reject-with icmp-host-prohibited rule. You can do this by editing /etc/sysconfig/iptables directly or by inserting the rule using the -I argument. Personally I would save the state of the firewall and ...


1

Add the second line to all access from anywhere, assuming that the connection uses tcp and not udp. -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 1337 -j ACCEPT Or run the following command, again assuming tcp for the protocol. This will add the same line as the manual edit shown ...


3

It's just one command. Considering you're using TCP requests just do this: iptables -I INPUT -p tcp -m tcp --dport 1337 -j ACCEPT As pointed by @iain in the comments, using this on the command line will guarantee that the rule will be evaluated before the REJECT rules. If you're editing the file directly just put this before the REJECT lines: -A INPUT -p ...


1

MySQL 5.6 my.ini file is in the path where the data is stored, in my case C:\Documents and Settings\All Users\Datos de programa\MySQL\MySQL Server 5.6 instead of the path where mysql is install C:\Archivos de programa\MySQL\MySQL Server 5.6 , like older versions. We have to change C:\Documents and Settings\All Users\Datos de programa\MySQL\MySQL ...


2

Your process is waiting on something before it can exit. Maybe a system call. Tryingto access a file which has been unmounted is a common example of this, or an unavailable network share. Is there a parent or child process that also needs to be killed? I'm not a MacOS user, but on linux ps wwauxf | less is useful to browse through the processes ...


1

State E appears to mean that the process is exiting. But your process is basically a zombie that never exits. Everything online I found shows that there is little you can do other than reboot, e.g. How to kill an "exiting" process on OS X (state = E). If you do not want to reboot the OSX server due to other services impacted, you might consider (as ...



Top 50 recent answers are included