Tag Info

Hot answers tagged

5

OK, so firstly it looks like your incoming mail transaction is running into problems with SASL authentication. Oct 26 12:40:11 vps31465 postfix/smtpd[13551]: warning: SASL: Connect to private/dovecot-auth failed: No such file or directory That path looks to have come from here, in what I assume is postconf output (contrary to how you describe how you got ...


4

Some receiving mail servers will check whether the originating server is fully capable of receiving mails at your address. Others won't accept mails sent from dialup IP ranges. As you said your incoming mails will be handled by Google Apps, why not send your outgoing mails right through Google, too?


3

Looking at my /etc/fail2ban/jail.local there is this comment: Since 0.8.1 upstream fail2ban uses sendmail MTA for the mailing. Change mta configuration parameter to mail if you want to revert to conventional 'mail' Based on this and the error you posted, it seems you can only specify sendmail or mail. Do you receive emails from fail2ban when mta is set ...


3

You're right that it won't matter for others, but will certainly matter for you because when submitting over SMTP Postfix may refuse to accept your message for reasons beyond your control. Which means you'll have to use your own delivery queues and add other bloat code. In fact you will be doing Postfix's job. Some may say that mail() may also fail, but it ...


2

Your request is bit complicated because this matter. Postfix, by design, will execute something based on positive result from maps. For example in your transport_maps, it will send email to specific host if the recipient has positive result from maps lookup. But, you want to execute something - redirect to another mailbox - if there is negative result from ...


2

MailScanner supports multiple MTAs and in this case, it sounds like the configuration file (MailScanner.conf) is configured to use sendmail instead of postfix. As per the prior guide you referenced, it should have something like this: %org-name% = test CentOS Mail Server %org-long-name% = ORGFULLNAME %web-site% = ORG WEBSITE Run As User = postfix Run As ...


2

myorigin = mydomain.com - The domain name to append when the UNIX user sends out a mail. (For eg. If UNIX user john sends mail, then john@mydomain.com will be the sender address. If you want your sending domain to be mail.domain.com set your myorigin accordingly. myhostname = mail.mydomain.com - The unique FQDN of your mail server. When talking to other ...


2

Have a look at the PCRE map for Postfix. It allows you to define mail from rewrites for addresses based on a regular expression.


2

You can not use a SQL lookup as relayhost parameter. See the postconf manpage man 5 postconf: ... relayhost (default: empty) The next-hop destination of non-local mail ... To relay depeding on the recipient email address you have to define the transport_maps parameter in your postfix configuration. In your case this would look like this: ...


2

Postfix provides several “checks” that can be evaluated at different “stages” of the incoming SMTP connection. “checks” are something like “is the remote client SASL-Authenticated?”, “is the remote client providing an FQDN HELO Hostname?”, “is the remote client asking for SMTP pipelining?”, as well as “is the remote client blacklisted in some RBL?” or “is ...


2

Recommended is to use the Maildir directory format to store email rather than the the older mbox format. The Maildir format is well supported by Dovecot and has some advantages (no locking, allows for easy incremental back-ups and restoring of individual messages.) So you'll need to assign a directory. Convention is to store mail in a ~/Maildir directory ...


2

I would suggest that you to remove all the virtual_mailbox_* parameter and use only transport_maps and relay_domains. Set up a "dovecot:" transport in master.cf which delivers your mails via the dovecot LDA or the dovecot LMTP. E.g.: dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail ...


2

If you read the question/answer, why are you using (.*) as the expression? The answer marked correct to the question you link to clearly uses the regex expression: /.+@.+/ edit: if you, for whatever reason, do not want to actually read the answer in your link, I'll copy/paste it here for you. Finally found the answer. Listing here for posterity. ...


1

I changed the query variable in 'mysql-virtual-mailbox-maps.cf' from: query = SELECT 1 FROM virtual_users WHERE email='%s' to: query = SELECT email FROM virtual_users WHERE email='%s'. It didn't work before because it needs to match the 'FROM' header to the return value of the query (reject_sender_login_mismatch) explains this.


1

Because you already have permit_mynetworks in smtpd_relay_restrictions, then you can add the new restriction after it. smtpd_relay_restrictions = permit_mynetworks, check_recipient_access hash:/etc/postfix/block_localhost, permit_sasl_authenticated, defer_unauth_destination in /etc/postfix/block_localhost, you can put root@localhost REJECT postmap that ...


1

As stated in the error, the value of parameter smtpd_milters and non_smtpd_milters wasn't correct. The right one is smtpd_milters = unix:/var/run/opendkim/opendkim.sock non_smtpd_milters = unix:/var/run/opendkim/opendkim.sock As stated in official documentation The general syntax for listening sockets is as follows: unix:pathname Connect to ...


1

Your configuration looks correct and i have checked your Forward and Reverse entries. That look ok. The problem is that you don't know which SPAM-System and RBL the recipient use. So its possible that they use a special RBL-List and you are blocked on that list for example. There are a lot of possibilities but i think your configuration is ok. Perhaps ...


1

I've figured it out :), as expected turned out to be as simple as possible... My cert wasn't readable by openssl, after adding link named as cert hash to /etc/ssl/certs/ everything works like a charm.


1

For verifying email, you must set mode parameter in opendkim.conf as sv (s means signing, v means verifying). By default it will verifying all emails coming from outside InternalHosts. In your current config, you just signing the message coming from InternalHosts.


1

Another note on the answer above (which is 100% correct) - you can mostly get around this problem by setting a Reply-To address in your mail headers instead of relying on the From address.


1

First we define two smtpd process in master.cf, the one with rewrite enabled and the other with rewrite disabled. SMTPD with rewrite enabled was exist by default in master.cf. Now we will these lines 127.0.0.1:2552 inet n - n - 2000 smtpd -o receive_override_options=no_header_body_checks,no_address_mappings This will enable ...


1

You can use smtp_reply_filter feature to transform hard reject to soft reject when sending email. The idea was given by this thread. In main.cf, add this line smtp_reply_maps = pcre:/etc/postfix/smtp_5xx_to_4xx and in /etc/postfix/smtp_5xx_to_4xx, add the line if !/^5[0-9][0-9][ -]5\.1\.[0-9] / /^5(.*)$/ 4$1 endif



Only top voted, non community-wiki answers of a minimum length are eligible