Tag Info

New answers tagged

1

I have found the solution to my own question. Below are the lines 507-513 from program/steps/mail/sendmail.inc. // encoding subject header with mb_encode provides better results with asian characters if (function_exists('mb_encode_mimeheader')) { mb_internal_encoding($message_charset); $headers['Subject'] = mb_encode_mimeheader($headers['Subject'], ...


1

Basically if you want to do SASL authentication via MySQL you have 3 options Using pam-mysql and saslauthd. Your linked tutorial use this. Using sql auxprop plugin. In /etc/postfix/sasl/smtpd.conf file above, you have defined this method. Using dovecot instead cyrus SASL (option 1 and 2). Let's dovecot provide the auth socket for you. You states that you ...


1

You define this parameter in main.cf smtpd_sasl_path = /var/run/dovecot/auth-client This tells postfix where path the unix socket for SASL connection. Yet, in dovecot config you define the SASL socket was in /var/spool/postfix/private/auth service auth { unix_listener /var/spool/postfix/private/auth { group = postfix mode = 0660 user = ...


0

You could also try to add postfix user to sasl group.


1

I don't know to what extent you've redacted the output above, but in the important lines of the SQL query (Password mismatch, and the line that follows) it's comparing an MD5-hash to a very long string. MD5 hashes are 32 bytes long, so no string at all will ever MD5-hash to the sort of string you give, which looks to be 63 bytes long, and in addition is ...


0

Try changing myhostname to something else - for example mail.redmine.hsi.com


-1

If I'm understanding your question, I think your answer lies here: rewrite-recipient-of-all-except-one-recipient-outgoing-e-mail. It shows how to route based on recipient and has many references for postfix maps. This question asked of routing based on IP. The responder tells it's not possible. The first is the most likely solution to the problem, I think. ...


1

We have two facts here You are connect to bluehost via port 465 Postfix reported an error message: lost connection with boxNNN.bluehost.com[a.b.c.d] while receiving the initial server greeting One possible explanation is SMTP client in Postfix 2.11 or older doesn't support SSL. Explanation In SMTP, there are two encryptions scheme: STARTTLS and SMTPS. ...


0

Your concern was valid because the existence of SPF checker. If you forward an email comes from a domain with proper SPF record your IP doesn't listed in their sender SPF record the receiver use SPF record as a factor to identifying spam then yes, you may have error message SPF fail and the email end up in Spam Folder. SPF community acknowledge this ...


1

You must include the signing table via: refile:/etc/opendkim/SigningTable Refile means that regular expressions get evaluated. When it is included via file:/... regular expressions are not evaluated.


1

Sorry for misleading comment above. When you use sasldb, then you doesn't saslauthd to running. So you can safely remove it from startup script. When you use system user to password checking, then you must run saslauthd. The first step is creating a database for sasldb using saslpassword binary # saslpasswd2 -c username@example.com Password: Again (for ...


2

Snippet from comment It is a CentOS 5.11 server, there is no newer postfix version available in our repos (CentOS standard repos, epel, FAN, graphviz and remi). So you are stuck in unsupported version of postfix 2.3.3. Well, I understand your case, it's very sad tough :(. Postfix version 2.3.3 was released in August 2006. Although the CentOS team was ...


2

Finally got my setup to work with postfix multiple instances masegaloeh mentioned. I tried to use exim4, but apt-get install exim4 automatically uninstalled postfix, without even a prompt! Anyways, here is how I got it to work: #Adds some lines to main.cf enabling multiple instance postmulti -e init #Creates a new instance at the directory ...


3

I don't have data or metric to decide if performance matter in both case. I'll try to explain what background process involving those two cases. When postfix daemon was running, there is little difference between those two When using main.cf, postfix parses the configuration file, save it to memory and doesn't check the file again until postfix restarted ...


0

My understanding is that Google Apps is not for transactional mail, but I could be wrong. What may work better is a smart relay that makes use of an API, as this is typically lighter on resources than using a local MTA. Mandrill by Mailchimp is popular, but there is also Amazon SES, Rackspace Mailgun, and others. You can find WordPress plugins for these and ...


3

As you can see, there's no smtpd_sasl_path in our output of postconf -n Why? The answer is easy. Because there's no smtpd_sasl_path set. Have a look at your first snippet: There's a typo in it. You wrote smptd_sasl_path = private/auth -- but there's a difference between smtpd and smptd. Because Postfix doesn't have informations where to find the socket, ...


1

In the tutorial linked above, the author using CRYPT hash algorithm. This fact can be looked in SQL query: INSERT INTO `user` (`email`, `password`, `name`) VALUES ("admin@example.com", ENCRYPT("adminpassword"), "Administrator"); Saslauthd using pam-mysql to authenticate user, so we need to configure pam-mysql to use same hash algorithm. The configuration ...


1

This line Feb 25 14:25:22 web postfix/smtpd[31725]: 34C89740E40: client=unknown[213.6.194.39], sasl_method=PLAIN, sasl_username=contact@example.com tells us that someone sends email via your server after SMTP auth with username contact@example.com. In this stage, spammer has likely know your password of that user. Feb 25 14:25:26 web ...


0

This looks to me like you have a web page that is being used to send mail to user-input email addresses - thus you may or may not be an actual mail relay, but you are being used as an origin for spam.


2

Actually, there are two components that check your quota: Postfix, the checking process was invoked when you receiving email. Courier, the checking process was invoked when you moving around the email via POP3 and IMAP. Since you mention Thunderbird who report the quota warning, then likely you haven't disabled quota checking from Courier. So, how to ...


4

To always permit realying on mail.example.com by web.example.com, you can add web.example.com to your trusted network: mynetworks = 127.0.0.1/32 [your IPv4 and IPV6 addresses] [IP of web.example.com] Alternatively you can use smtpd_client_restrictions: smtpd_client_restrictions = permit_mynetworks, check_client_access hash:/etc/postfix/maps/client_access ...


1

For postfix version 2.6 and later, you can use postmulti shipped by postfix. Excerpt from man 1 postmulti: The postmulti(1) command allows a Postfix administrator to manage multiple Postfix instances on a single host. postmulti(1) implements two fundamental modes of operation. In iterator mode, it executes the same command for multiple Postfix ...


1

The problem(s) are resolved. As seen in the comments there was a problem saying that my logs did not work. This was resolved following the the instructions on a question here (it is the not approved answer with CentOS 7 in mind) After the logs worked again the solution was ony 5 seconds away. The logs were saying following error: Feb 22 18:15:27 ...


1

Looks like you are missing last slash when you specified maildir directory in /etc/postfix/vmail_mailbox. Excerpt from man 5 postconf virtual_mailbox_maps (default: empty) ... The virtual(8) delivery agent uses this table to look up the per-recipient mailbox or maildir pathname. If the lookup result ends in a slash ("/"), maildir-style ...


1

Since you imply you're not getting any error, I'm wondering if the mailboxes you have set in /etc/postfix/vmail_mailbox do not match the /var/vmail/%d/%n Dovecot virtual mailbox structure. For example, I would expect it to contain something like: leesinblik@jeroened.be jeroened.be/leesinblik/ In any case, look in the /var/vmail directory and see where ...


0

It seems your configuration is fine, I sent a test mail for you at test@jeroened.be, and this is the reply of your server: Feb 22 14:57:22 iabsis postfix/smtp[12704]: DDAE720052E: to=<test@jeroened.be>, relay=mail.jeroened.be[5.196.227.108]:25, delay=6.5, delays=0.33/0.02/6.1/0.03, dsn=5.1.1, status=bounced (host mail.jeroened.be[5.196.227.108] said: ...


2

This error message: Feb 21 15:52:46 server dovecot: auth-worker(3609): Error: pam(test,<myip>): pam_authenticate() failed: Authentication failure can be caused by several reasons such as: User didn't exist Incorrect password Based on above useradd command useradd --shell /bin/bash --create-home --password <password> <username> I ...


2

Firstly, so long as you have OpenDKIM specified in non_smptd_milters as well as smptd_milters in Postfix's main.cf, outgoing mail sent through PHP mail() should still be signed. The Received headers are not signed by default, and nothing much else should have been rewritten by cleanup. If you want an alternative method, you could DKIM sign using Amavis and ...


0

Setup a relay host to your isp smtp server, in: /etc/postfix/main.conf then reload: sudo service postfix reload


1

If destination mail server has empty free-space, then the email can't accept an email. Mail server have to store the email temporarily to queuing it before sending it to next destination. Proper mail server will throw 4xx when it's happened. It means, "I can't accept your mail right now. You may try again later" (RFC 2821 point 4.2.1). When getting 4xx-code ...


3

Form my understanding I could use PHP mail() function or even Swift Mailer's Swift_SendmailTransport class and deliver the messages directly to Postfix queue. That's true But if so, how can we ensure DKIM? Will changing the "FROM" header to the email accounts on the local server be enough? You doesn't specify your DKIM signer, so I assume that you ...


0

Your Outlook mail client, as shown in your image: is not set to use SASL authentication. Outlook's "Outgoing Server" dialogue may not be self-explanatory: "Log on to incoming mail server before sending mail" means do not SASL authenticate, but POP first. However, your Postfix settings require SASL: smtpd_client_restrictions = permit_sasl_authenticated ...


2

man postconf says "You are strongly encouraged to not change this setting." Nevertheless, you can, like this: smtp_tls_security_level = encrypt smtp_tls_mandatory_protocols = !SSLv2, !SSLv3 smtp_tls_mandatory_ciphers=high smtpd_tls_security_level = encrypt smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3 smtpd_tls_mandatory_ciphers=high ...


4

From Applied Crypto Hardening by bettercrypto.org: smtpd_tls_security_level = may smtp_tls_security_level = may smtp_tls_loglevel = 1 # if you have authentication enabled, only offer it after STARTTLS smtpd_tls_auth_only = yes tls_ssl_options = NO_COMPRESSION smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3 smtpd_tls_mandatory_ciphers=high ...


0

It is well documented. From http://www.postfix.org/TLS_README.html#server_cipher smtpd_tls_mandatory_ciphers = high smtpd_tls_mandatory_exclude_ciphers = aNULL, MD5


1

The tools were not lying! The solution have to look this way: # inbound smtpd_tls_security_level = may smtpd_tls_protocols=!SSLv2,!SSLv3 smtpd_tls_mandatory_protocols=!SSLv2,!SSLv3 # outbound smtp_tls_security_level = may smtp_tls_protocols=!SSLv2,!SSLv3 smtp_tls_mandatory_protocols=!SSLv2,!SSLv3 smtp[d]_tls_security_level == "may": ...


0

Follow the steps here to make it work. Setup a SPF record Setup DKIM Setup a DMARC record Setup a reverse DNS record HELO must be a host name not an IP Make sure that your IP is not on a blacklist Use a static IP address for your server Sign up for JMRP and SNDS


1

The first thing I would do before proceeding further would be to test port 25 end to end with a tool like netcat. The tool comes standard with most linux distros. For example on CentOS I would stop postfix to release port 25. Then I would start netcat like this: # nc -l 25 Then on the remote client I would start it like this: # nc {ip of remote ...


3

According to the nmap docs: filtered Nmap cannot determine whether the port is open because packet filtering prevents its probes from reaching the port. The filtering could be from a dedicated firewall device, router rules, or host-based firewall software. These ports frustrate attackers because they provide so little information. Sometimes they respond ...


0

Use spamhole: https://sourceforge.net/projects/spamhole/ From the website: spamhole is a fake sopen SMTP relay, intended to stop (some) spam by convincing spammers that it is delivering spam messages for them, when in fact it is not.


1

For a strange reason @masegaloeh 's answer doesn`t work with me instead when I use this, trying to solve another error, it fixed. So ain't going to say this is the right answer but I leave it anyway in case help anyone to solve similar problems. I Just add this line in my /etc/postfix/master.cf file because I have an smtpd error like this: "subsystem ...


1

The problem was the line -o smtpd_sender_login_maps=hash:/etc/postfix/virtual in master.cf. I forgot to look there, because this exact configuration was running fine for months on another my server.


1

For a mail server, there are free services that will check the various security measures for your domain. Check this site as an example: http://mxtoolbox.com/ Check your domain and implement the recommendations that the site suggests and your mail server should be secure. Since you have other services running on the server (assuming Ubuntu, and exposed to ...


-1

Check your nameserver in /etc/resolv.conf, try Google's 8.8.8.8: sudo vi /etc/resolv.conf Change the nameserver IP: nameserver 8.8.8.8 Then restart postfix: sudo /etc/init.d/postfix restart


0

This could be unrelated but I'm going to post it here because I had a hard time finding the answer to my question. I was able to get outbound email working from a vagrant virtual box by editing my /etc/resolv.conf to use Google's nameserver rather than the 10.0.x.x IP it was set to: sudo vi /etc/resolv.conf Change the nameserver IP: nameserver 8.8.8.8 ...


2

I found the solution. master.cf is sensitive to line indentation -o content_filter=spamassassin was missing a space before Missing indentation in the master.cf The /etc/postfix/master.cf file needs proper indentation. The first line of each service starts in the first column. Additional lines of the same service need to be indented by spaces. ...


3

Most MTAs will go to nearly any end to avoid dropping a message on the floor. Typically a bounce will be generated (either by the receiving MTA, or, for better-behaved MTAs, the receiving MTA will refuse with a 5xx fatal error code and the sending MTA will convert the outbound message into a bounce). If that bounce is itself undeliverable, the MTA holding ...


1

Look to this diagram, there are three independent entrances where the email could enter postfix, sendmail (via pickup), smtpd and qmqpd. The last entrance was rarely used here. When email send through smtpd, then the email source likely from outside (the exception when connection from 127.0.0.1). Outside email was considered untrusted obivously. So, postfix ...


1

One last point I should mention in case someone is confused as I was, about why the mail ultimately gets put into /var/mail/rcook/ when postfix changed "rcook" to "rcook@example.net". This happens because in /etc/dovecot/conf.d/10-mail.conf I have this: mail_location = maildir:/var/mail/%n:LAYOUT=fs which strips off the domain name. Once @masegaloeh ...


2

Let met tell you the secret of email delivery process in linux, featuring sendmail binary and postfix. When your run date | mail -s 'testing' rcook you tell sendmail to send email to rcook, a recipient address without domain parts to postfix. Because you have parameter append_at_myorigin = yes (default value), then postfix will add domain parts to ...



Top 50 recent answers are included