Tag Info

Hot answers tagged

3

You can do this with <Location /dev> RewriteEngine on RewriteRule ^/dev/(.*) /$1 ProxyPass / http://localhost:8080/ nocanon ProxyPassReverse / http://localhost:8080/ </Location> and so on. That will give you different proxies for the different URLs, and remove the leading /dev, /staging, or /prod from the URLs. But ...


2

Thats..... strange, You're creating an ssh tunnel to port 443 on the remote machine (devbox) but you've clearly got sshd listening on port 443 (Which is https by default), so when you point your browser at localhost:8080, you understandably get the sshd server Whats more, its pretty impossible for you to have a webserver listening on port 443, given thats ...


2

The difference between the two is the protocol used to communicate with the backend. fastcgi_cache is related to the FastCGI backend protocol. It caches output from FastCGI connected backends. proxy_cache is related to backends that use HTTP as the backend protocol, and it caches output from HTTP connected backends.


2

Yes, you can use the Meta backend for OpenLDAP to create a unified view of two directories. This article by user @larsks details the configuration.


2

You have and extra dot on one of the ranges: export no_proxy="localhost,127.0.0.0/8,172.16.0.0/12,192.168.0.0/16" EDIT: After searching, it seems no_proxy won't work with networks, only domains .sample.com or exact IP 192.168.1.2, so either you add your local domain, all the IP your network has, or you use flags like wget --no-proxy


1

The simplest way to do this is one port and host at a time. For example, to forward traffic from remote:8001 to intraserver:80, ssh -R 8001:intraserver:80 myuser@remote But if you want to forward all traffic from remote, and you have an ssh server running on your local host, ssh -R 2200:localhost:22 myuser@remote ssh -D 10800 -p 2200 localhost ...


1

The problem is, that on unix there is no such thing as a global proxy setting. On windows, there is a proxy setting in the internet explorer configuration, which is intended to use by every other programs as well, but nothing makes it for them obligatory on it as well. And your biggest problem, that you simply can't guarantee, there won't some software ...


1

Finally this page lead me to my solution: file://-based proxy scripts are deprecated in IE11. There are some temporary registry hacks given, but I was not able to get my scripts to work with regedits. Finally I set up a local IIS server Windows Start - "Control Panel." - click "Programs" link - "Turn Windows Features On or Off." Check the box ...


1

First: I don't think you needed a such hard thing as a ProxyHTMLURLMap for a simple reverse proxy. Second: try a localhost/my-gateway/ (with the ending slash!). Does it work? Third: Here is a surely working config fragment: <VirtualHost *:80> ServerName your.proxy.vhost.name ProxyRequests Off <Proxy *> Order deny,allow Allow ...


1

Just convince the site your are using a browser, e.g. with wget --user-agent="Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2049.0 Safari/537.36" (User agent string from here)


1

The Proxy http://localhost:8080 is meant only to apply permissions and other apache rules (restricting to some client IP, asking for authentication, etc), not for configuring the proxy itself. The equivalent proxy without mod_rewrite would look like this: ProxyPass / http://localhost:8080 Or if you need to apply any kind of restriction: <Proxy ...


1

You do this at the router, not the PCs. Don't allow the PCs in question to go outside the network; only allow the proxy to go outside the network. Use ACLs or NAT or whatever works for your router. You do need to configure the PCs to use the proxy of course, and either a GPO or WPAD is a good method of doing that.


1

Found the culprit. Internet Explorer can use custom proxy settings for each VPN connection, and those settings override the default, global proxy settings when a VPN connection is in use. Thus, as soon as you establish a VPN connection, the connection's proxy settings become active, and if you don't configure them, IE defaults to a "no proxy, direct ...


1

It was indeed a bug, as of now it is fixed, more information on Squid's bugtracker.


1

Next solution works pretty good and is exactly what I wanted: map $http_user_agent $outdated { default 0; "~MSIE [1-9]\." 1; "~Mozilla.*Firefox/[1-9]\." 1; "~Mozilla.*Firefox/[0-2][0-9]\." 1; "~Mozilla.*Firefox/3[0-1]\." 1; "~Opera.*Version/[0-9]\." ...


1

You could use Tor. It will use a random paths to your server each time and so will appear from different addresses.


1

Since you want to do the forward selectively, you need both mod_proxy and mod_rewrite, as mod_proxy by itself would only proxy by the URL context You could either proxy based on remote IP: RewriteCond %{REMOTE_ADDR} ^12.34.56.78$ RewriteRule ^(.*)$ http://cluster/$1 [P] or based on login (asuming basic authentication): RewriteCond %{REMOTE_USER} ...



Only top voted, non community-wiki answers of a minimum length are eligible