New answers tagged

0

It looks like you might be using server-first SSL bumping, which according to the docs cannot handle SNI on the server and will use the server's IP as the certificate (since the server will no longer have a single hostname). Starting with Squid 3.5 there are new mechanisms called peek and stare that allow squid to observe the SNI negotiation to figure out ...


0

The typical config is that your users/visitors browse to http://www.example.com.com/sonar and then they get the content reverse proxied from http://sonar.example.com:9000/. <VirtualHost *:80> ServerName www.example.com ServerAlias example.com ProxyPass /sonar http://sonar.example.com:9000/ ProxyPassReverse /sonar http://sonar.example....


1

it won't work with https:// extentions no matter in what way I try to set it Your <VirtualHost *:80> is only matching port 80 traffic, so it cannot work with "https:// extentions." Whatever problem there might be with your proxy setup, your first issue is with your virtual host setup. EDIT per OP comment to answer: what I want to do is redirect ...


-1

Is there a big difference between v4 and v6 proxy server? Basically, no. The principle should be exactly the same. What OS should I choose on the VPS? Linux or Windows? I prefer Linux and you can run Squid on it. Which program could help me to set this up? Maybe you can use VPN instead? Try OpenVPN. It supports IPv6 already, but I can suggest ...


0

According to the comments: Contrary to what I wrote in the comments, this directive try_files $uri @proxy_to_appserver is valid and fine. I've just checked and tested this. Removing the trailing / from the proxy_pass http://appserver/ directive solved this: nginx: [emerg] "proxy_pass" cannot have URI part in location given by regular expression, or ...


0

Where is the Web-Server running from ? If it is running on your physical machine - my best guess is that it is running on your 127.0.0.1 Ethernet. You could have given it a Alias in Apache Httpd config so it would appear like an FQDN. But for a better chance of an answer please supply OS Web Server Type (Apache IIS etc) At the moment it is all rather a ...


0

Test the destination Link (IP) using the traceroute/MTR commands. https://www.digitalocean.com/community/tutorials/how-to-use-traceroute-and-mtr-to-diagnose-network-issues it will give you the hop where non-working systems are stopping at. If it is firewall then you may need to look for the specific ports such as for a website http/https. And for your ...


0

I Have this Senario : VPS Server ->Running Shadowsocks Server Windows 10 ->Running Shadowsocks Client => connect to Shadowsocks Server (VPS) Ubuntu -> Running On VMware machine. where and what ip set? i confused. sorry


0

It may sound confusing, but the ssl-bump option is available with http_port and not https_port. So change the line accordingly and restart squid and see. For http_port directive options: http://www.squid-cache.org/Doc/config/http_port/ For the https_port directive, there is no such option as ssl-bump. See here: http://www.squid-cache.org/Doc/config/...


0

You can use SoftEther, which is open source and is extremely configurable. It might not have an out of the box option to cap traffic, but you can control it through its API.


1

I searched Google for "Nginx as email proxy server" and found this article on the Nginx website on how to use Nginx as an email proxy server. Just change the port in the configuration. Perhaps you should try reading the official documentation then ask a question if it doesn't work for you.


0

In Apache, as far selecting which IP address you want to use for the outgoing requests on the proxy you could use: https://httpd.apache.org/docs/current/mod/mod_proxy.html#proxysourceaddress A fairly dirty way of doing this would be to have a bash script that changes the value of "ProxySourceAddress" in your Apache conf file to a different IP address every ...


0

Like said fvu you can't use your http proxy to route ftp. And the easiest way is to use sftp. But you can do it using MobaXterm, an all in one remote connect software which provide many features for free, and more a correct price. Last way to proceed : create 1folder/server and setup rsync to use only the frontend as ftp.


0

Security is a process, not a destination. There is not a "make my thing secure" switch that you can flip. SSL/TLS is only one small part of the picture here. Yes, it's great to protect the connection between your clients and your server, but that doesn't do any good if there are vulnerabilities in your application. Speaking frankly, if there is a security ...


0

If you add the following line to your config file, it will stop IPv6 which slowed down my squid connections. tcp_outgoing_address 0.0.0.0 all


5

OK, now I think I understand what you want. This is a very special case and different from the normal port-forwarding approach which I posted earlier (see below). The following rules should do it. SNAT on incoming packets I assume the following: <x>: public IP of the server <y>: public IP of the client <a>: internal IP of the server (...


1

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport *$srcPortNumber* -j REDIRECT --to-port *$dstPortNumber* You will change -i attribut if yours NIC is not on eth0 Edit #1 You can for --dport and --to-port set ip adress whit port for exm: 192.168.0.1:80


1

At first, not sure why you need apache behind nginx. Now, if you don't do rewrites in apache which hide the php extension, just modify your location block like this: location ~ \.php$ { roxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-Proto $scheme; X-Forwarded-For $...


0

AS far as I know, SQUID is not a SOCKS server. WinGate has a SOCKS server, which supports client connections using TLS/SSL including client certs (which is non-standard) which authenticates to the proxy based on the UPN in the certificate (when using the Active Directory connector in WinGate). You can also with policy lock the destination down to wherever ...


0

Ok, I figured it out. I ended up with: server { listen 80; listen 443 ssl; server_name proxy.example.com; charset utf-8; location @error { return 404; } location / { # only allow GET requests if ($request_method != GET) { return 404; } # do not allow empty urls if ($...


0

Make sure the client is pointing to squid (port 3128) and not to apache (probably port 80)


0

Yes, that was pointing to 80 port, which is apache. 3128 port in browser solved the problem.


1

The best possible solution is to create a acl for each interface, make all the requests coming to that interface belong to that group and redirect that group to a specific outgoing interface. Example: The server X has the following IPs: 10.0.0.1 10.0.0.2 10.0.0.3 Therefore, the squid.conf file should be something like: acl 10_0_0_1 localip 10.0.0.1 ...



Top 50 recent answers are included