Tag Info

Hot answers tagged

3

From what I see you are using Ubuntu and therefore the Apt package manager. The error you are encountering is due to installing a package that it cannot find the public key for the package. This can be because: You have a package source that does not contain the public keys. You need to do apt-get update to update your sources before doing an install. Or ...


2

If your agents are still able to check in to the master correctly, and there is no crossover between the two masters, then it should be just a matter of setting [main] ca_server = puppet-right.example.com in /etc/puppet/puppet.conf with puppet. I've tested this on one of my agents, it seems to work fine. I might be missing something, but I don't think ...


2

It's obviously not so easy as it seems in the first place. In case of AWS, there are custom facts that tell you you are on aws, for example: # facter -p | grep ^ec2 |wc -l 33 Public IP is saved in 'ec2_public_ipv4' fact. So, it's easy to detect AWS. But on DigitalOcean - there is nothing that indicate for within the VM itself that it's running on ...


2

I suspect you may be looking at pending requests not certificates. Unapproved requests are typically in the $ssldir/ssl/ca/requests (on my system /var/lib/puppet/ssl/ca/requests) directory. Just go into the directory and delete them using rm, or whatever.


2

You need to add include apt at the top of your class, before the apt::source declaration: the error is saying it can't find apt::things because it doesn't know what the higher scope apt is. The include apt will use various defaults, if you want to change them you'll need to instead use a declaration such as: class { 'apt': always_apt_update => true, ...


2

The permissions and the timestamp on the directory and file don't match; that puppet resource isn't creating that file. Some other puppet resource, or something else on your system, is doing that.


2

Because the F5 is based on Red Hat, you technically can install the puppet agent, but in order to do this, you would have to install the puppet agent itself and ruby which would break the support you would receive from F5, and this is therefore not recommended and best practice would be not to do this. If you have just a one off node, then you should ...


1

"We're not programmers, we're sysadmins" My how times have changed, for the worse: a greybeard like me was expected to be a better programmer than professional programmers, or else would have never been able to pass for a system administrator. Now, we have "system administrators", who are basically Windows desktop users who have at some point converted ...


1

Just change the 100G in your code to 106G? Your manifest should reflect the actual state of the server, if you want to do this correctly. If you get this message, I'd recommend changing the puppet config/hiera values for this server to reflect the actual size. Or am I misinterpreting your question?


1

Your template explicitly loops over nameid and then over all keys in game_code, so of course each generated file is going to have all the data in it. Perhaps something like this would do: <UserName><%= @name %></UserName> <games> <% @game_code.sort.map do |hero, value| if (somecondition) value.sort.map do |game,code| ...


1

You could use the clean action e.g. puppet cert clean test2 t's in the documentation.


1

So it turned out to be using the dev -> prod testing - we had different modules and more importantly, a different lib from LVM between dev and prod. See: https://tickets.puppetlabs.com/browse/PUP-731 for the bug in puppet that causes this.


1

This has nothing to do with Puppet or dependencies. The problem is that it appears that your system is missing keys to verify package signatures. You should fix that. apt-get install debian-keyring apt-get install debian-archive-keyring apt-get update Could possibly fix that. If it doesn't, read https://wiki.debian.org/SecureApt


1

I found the problem... there was an extra space in the .yaml file which caused the error. Thanks for your help.


1

You wanted to manage /home/vagrant/.bashrc but you set: $user = "demo" which gets used later: file { "/home/${user}/.bashrc": ensure => present, owner => $user, so you'll just need to change the user variable to vagrant.


1

By making the exports unconditional, you will provoke a collision, because the manifest now declares the exported resource Class::Define[$fqdn] twice (with different attributes). You can avoid this by allowing to pass the FQDN as an attribute value, instead of expecting it to be the resource title. @@class::other_define { "hello-$fqdn": fqdn ...


1

You can try below manifest. The issue is that you have to add -f and --allow-unauthenticated options for apt-get to resolve the dependencies automatically and install them. Once these flags are added it is not necessary to add each and every dependent package to the package resource. class mysql { package { ["mysql-server-5.5"]: ensure => ...


1

Well you can, as it turns out, but it's not pretty. fail inline_template("<%= def path(scope) if scope.parent path(scope.parent) + '/' + scope.resource.ref else '' end end path(scope) %> failed: ACTUAL MESSAGE HERE") It works by using ...


1

Okay, I found the problem. I've mistakenly wrote the class in the hiera file instead of the modules directory of puppet. Once I moved the file to the modules/vim/manifests/ folder and edited the hiera file like so: classes: - vim It started working. Thanks for your help.


1

As Sven points out in his comment, this is actually a syntax error in your code - you have an extra } at the end of your first file resource. To expand on this, this isn't actually considered 'invalid' syntax as such - hence why Puppet still runs and doesn't complain. You're effectively ending the class with the second }, and anything after that is ignored ...


1

If you're using the latest version of vcsrepo (https://forge.puppetlabs.com/puppetlabs/vcsrepo) in Puppet 2.7, that might be the reason why it's not working. According to the forge page, it requires Puppet 3.x.


1

This page seems to imply you can override Facter facts by setting an environment variable: # show the operating system we are running (retrieved from facter) $ puppet -e 'notify { "We are running on $operatingsystem": }' notice: We are running on Fedora # override $operatingsystem for testing purposes $ FACTER_operatingsystem=Debian puppet -e 'notify { "We ...



Only top voted, non community-wiki answers of a minimum length are eligible