Tag Info

New answers tagged

0

This should do the trick: <% minNumOfNodes = (@akka_application_cluster_seed_nodes.split(',').length / 2)+1 %> min-nr-of-members = <% $minNumOfNodes %> Inside the <% %> it is just straight Ruby, so we take the raw string, split it on the comma, take the count, then do the required calculation on that.


0

For Puppet 3: Check out that this: nodetest1 { include firewalld } is written to /etc/puppet/manifests/site.pp or a file that is imported within this file with: import path/to/file.pp This also applies if you use environments but the default path is /etc/puppet/environment/<env>/manifests/site.pp as starting file. For Puppet 4: Nearly ...


0

First, make sure the module is in your modulepath. To figure out what's configured as your modulepath: $ sudo puppet config print modulepath /etc/puppet/modules:/usr/share/puppet/modules So, in my case, there should be a /etc/puppet/modules/firewalld directory. Secondly, to define the node according to the example, the definition should look something ...


0

The modules should be cloned to the modules directory of an environment, e.g., /etc/puppet/environments/production/modules/firewalld: The Base Modulepath The base modulepath is a list of global module directories for use with all environments. It can be configured with the basemodulepath setting, but its default value is probably suitable for you unless ...


0

By simply making a module on your puppet master does not mean it is applied to your hosts. You have in add the module to forman in the "puppet modules" page, then edit your host within forman and add the module. Y


1

I found the solution already. Instead of putting the code in "/etc/puppet/manifests/site.pp" I have to put it in "/etc/puppet/environments/production/manifests/nodes.pp" instead


1

If you are running puppet apply filename.pp in your master, you need to declare the puppet master as node or declare default node. as you can see in your output the problem is very clear, for declare the default node you need something as follow. /etc/puppet/manifests/nodes/default.pp node default { include sshcon, motdclass, virtualhost } you ...


1

The root cause is that the puppet version on puppet master server is 3.8.1 However i install puppet 4.1.0 on puppet agent. Puppet master version must be greater than or equal puppet agent version. The solution is that i uninstall puppet on puppet agent and reinstall puppet version 3.8.1 instead.


2

The original puppet code cannot be reconstructed as it was, because that might have contained conditionals, selectors, parameterised classes, defines, templates and all manner of puppet-language constructs that generates the catalog YAML you have recovered. You could probably, with some effort, use that YAML to recreate a raw set of puppet manifests that ...


1

As ricciocri sugested you can use --certname, but in your master you can set "allow_duplicate_certs = true" setting allow_duplicate_certs solve the problem, when you add a client with the same name of the previous one. If you are using vagrant for dev or testing, I think you can everything together for working automaticaly 1: certname #in your client side ...



Top 50 recent answers are included