Tag Info

Hot answers tagged

2

Try this piece of code proxy = urllib2.ProxyHandler({'http': '127.0.0.1:8080'}) opener = urllib2.build_opener(proxy) urllib2.install_opener(opener) urllib2.urlopen('http://www.google.com')


1

Another solution that fit my way of configuring WSGI was changing the WSGIScriptAlias line: WSGIDaemonProcess website user=user group=group python-path=/path/to/venv/website:/path/to/venv/lib/python2.7/site-packages WSGIScriptAlias /website /path/to/venv/website/wsgi.py process-group=website application-group=%{GLOBAL} <Location /website> ...


1

Sorry for a year late answer! I had the same problem and fixed it, I don't know if you changed the name of a directory after creating the virtual environment, I did though. If so then here's what I did. 1.) deactivate your v-env. After the fix you need to restart the v-env, so might as well deactivate now. right? 2.) Now, since we created the v-env in a ...


1

The problem encountered here was caused by python or the vcsa-deploy utility attempting to use the proxy defined in the shell environment: https_proxy=http://proxy.example.com:3128/ I ran vcsa-deploy with strace and saw that it was attempting to use that proxy. I used the unset https_proxy command to temporarily disable that proxy, repeated the ...



Only top voted, non community-wiki answers of a minimum length are eligible