Tag Info

New answers tagged

1

I would recommend to act on both *.rpmnew and *.rpmsave files after updates. The creation of these files generally indicates one of the following three things: you were not careful (or there was no other way to do it) and modified a configuration file that is under the package management. Usually, if a package provides a directory for configuration ...


4

My question is, does CentOS 7 have some sort of feature that makes dropping packets impossible? No, but it has two features that make dropping packets far less likely: a kernel version that includes TPACKET_V3 for PF_PACKET sockets; a libpcap version that uses TPACKET_V3 for PF_PACKET sockets. Libpcap uses PF_PACKET sockets to capture on Linux 2.2 ...


0

You could write a little script to do it for you (this is ugly but works): #!/bin/bash for f in *; do flag="x" attr=$(getfattr $f) if [ "$attr" = "" ] then flag=" " fi find -name $f -printf "$flag %a _ %c _ %t _ %P\n" done


0

On inspection of the full iptables -n --list output, IN_public_deny is (eventually) called from the INPUT chain, which has nothing to do with packets sent from the system to the thus undenied host; those packets are instead routed through the OUTPUT chain (or possibly FORWARD if the firewall is a router or bridge between the source and destination). ...


0

So write a shell script to collect your data into variables. After you have the data in variables, you can reformat and print them exactly how you want.


0

I think you're installing your bootloader to the wrong place. This sounds like a SCSI enumeration issue, so the important details are: What media you're installing from: USB and USB CDROM will shift the device names around (e.g. /dev/sda, /dev/sdb). Either way, your server is a G1, so it has a Smart Array P400i or E200i RAID controller. Under RHEL 6.x, ...


0

The issue has been solved and this question can be closed. However, i was not able to do this via ssh. I had to turn off the instance on the virtual box and reboot it. Doing this via ssh remains open for discussion. How to solve the issue by rebooting the rhel5 instance: 1.Boot the system into single user mode (do this by pressing esc on the boot screen. ...


0

The useradd should create the home directory when correct option is passed and you don't (or shouldn't) have to create them manually. I suggest you execute the following (in the order listed) to remove and recreate your user properly. userdel -f -r user1 useradd -m user1 NOTE: you don't have to pass the -d option since the default will be /home/user1 in ...


0

The only issue I can see with your setup is in your passwd file. Try changing user1:x:513:517::/home/user1:bin/bash to user1:x:513:517::/home/user1:/bin/bash.


0

Redhat uses Systemd for starting/stopping jobs. If you are in rescue mode, it uses the rescue or emergency targets. You need to config sshd (and its dependencies) to run also on these runlevels (= targets, in the systemd terminology). Here you can find more about systemd finetuning. Some Redhat docs may be also usable.


9

You can't ssh into recovery mode as ssh won't be running. You need a way to get on to console. If this is a virtual machine and you own the host there should be some way to connect to the host and get on console. If this is a service like AWS then you are out of luck and you need to recover it someway else like building a new instance and detaching the root ...


0

Running yum clean all && yum update did not help me. I tried: yum remove dracut yum install dracut yum clean all yum install dracut But it was always saying that there is no package dracut available. So the only way was to install it manually: wget ftp://fr2.rpmfind.net/linux/centos/6.7/os/x86_64/Packages/dracut-kernel-004-388.el6.noarch.rpm wget ...


6

It's very rare for changes to the default configuration to have security or stability implications. However, "very rare" is not "never", and it's a good system hygiene practice to review all .rpmnew files and double-check that they don't contain important changes, and then delete them. As a double-check, you should also arrange to receive security notices ...


1

Read the man page again: -t number --tries=number Set number of tries to number. Specify 0 or inf for infinite retrying. The default is to retry 20 times, with the exception of fatal errors like "connection refused" or "not found" (404), which are not retried. Use -t to define the number of tries (attempts), not retries. ...


2

Can you post dmesg output? Generally speaking, the best way to figure this out is to look in the chassis management module. It should have an option to enumerate devices within the blade. (I would comment, but low rep) EDIT: I no longer have a valid IBM support entitlement, so I can't link you directly, but it looks like you have the eHEA model. There ...


1

If you are using RHEL/CentOS 7, your system will be using systemd, and therefore journalctl. As mentioned above, you can use the journalctl _COMM=sshd. However, you should also be able to view this with the following command: # journalctl -u sshd You can verify your version of redhat by the following command as well: # cat /etc/*release This will show ...


1

You can easily do this in two ways: a) create an SSH key without passphrase, and deploy the public key to B b) create an SSH key with passphrase, load it once into ssh-agent on boot and make the connection to B use this agent. This is more secure than the first option. Links: a) http://hortonworks.com/kb/generating-ssh-keys-for-passwordless-login/ b) ...


0

You are looking for a single-sign-on (SSO) setup. I have not personally done an ssh SSO configuration, but I found a few links that look decent: Red Hat docs, an RHEL blog post, and one from another Linux distribution (this last one is the most step-by-step of the three). Hope one of those helps!


3

@dawud's comments are incorrect. DAC permissions are checked first. If they deny access, then the process receives permission denied. If DAC allows access, then the selinux MAC policy is checked. If DAC allows access but MAC denies access, then access is denied. DAC can never override MAC. Diagram Your Wordpress plugin should be labeled with ...


0

Never mind. Just finished a big refactor of the script; drastically reduced memory usage and am no longer getting the error. I should note I was able to work around the error for a while with this php call: ini_set('memory_limit','256M');


0

The shell prompt you received is not a normal system prompt; it's intended for you to fix the problems that prevented a normal boot. So let us look at the problems. First, there was an important clue: Primary GPT is invalid, using alternate GPT. This strongly suggests to me that something has overwritten the start of the virtual disk. One of the tools ...


3

When you are testing this you are sending your queries to 172.16.100.66. Your named.config specifies the following addresses: listen-on port 53 { 127.0.0.1; 172.16.100.67; 100.111.100.121; }; Ie, I would expect that named is not listening on the address that you are sending the queries to.


1

Your configuration as shown shouldn't cause there to be 185. It could be that for some reason you actually have that many requests simultaneously (such as slow HTTP DoS attacks). Check out what mod_status shows you to investigate further (see http://httpd.apache.org/docs/2.2/mod/mod_status.html for how to enable it).


0

I faced similar problem with SOL on Supermicro server (SYS-1028R-WTRT). I used a Centos 7 OS. I think this sequence of actions help me decide this problem: I shutdown all systemd getty services (systemctl stop serial-getty@ttyS0 , ...ttyS1) Manually run /sbin/agetty -L ttyS1 115200 vt100 (this set of parameters get me a login string on SoL connection) ...


2

Your system has a copy of curl from the third party city-fan repository installed. Unfortunately someone didn't install it correctly and its libcurl dependency does not match the version of curl, because libcurl is still the one shipped by Red Hat. How you resolve this depends on whether you really intended to use the city-fan copy of curl, or whether it ...


-1

Had this problem after filtering my dump with https://github.com/jasperlee108/svndumpfilterIN Fixed with removing md5 checksums: sed -i '/Text-copy-source-md5/d' your.dmp However, there can possible be some consequences...


5

Seems like a problem with your mirror or your yum-cache, as dracut-kernel 004-388.el6 should be available, at least it is for me: ============================================================================================================= Package Arch Version Repository Size ...


0

You might also try lsof ("list open files"). There are methods for specifying what you want to see e.g. only things with TCP connections, only things in a specific process or a specific directory, etc. It only gives you what is happening at that moment in time, but if something is chewing that up by itself, it should be able to point you in the right ...


0

The shmall parameter refers to traditional UNIX IPC shared memory. You can see the memory allocations of that using the command ipcs. The tmpfs temporary filesystem is a totally different subsystem used as a ram based, swap backed filesystem. tmpfs is used as the basis to perform posix shared memory in fact, which is a different type of shared memory system ...


1

Your local copy of the repository metadata is out of sync with what the repositories contain. Clear your metadata and try again. yum clean metadata or yum clean all


0

Depending on version of RHEL (which for whatever reason you decided not to include), you have to make sure ntpd (RHE6) or chronyd.service (RHEL7) IS running and set to start after reboot, also make sure it's configured properly. for more information: RHEL6: ntp.conf(5), ntpq(8), ntpdc(8) RHEL7: chrony(1), chronyc(1), chrony.conf(5), hwclock(8), ntpd(8) ...


0

Have you verified your NTP settings are pointing to your NTP server and communicating to the server? Or if you do not have an internal NTP server, verify that they are all pointing to the same external NTP server and that they are properly communicating to that server? You mention that the servers "lose sync". What does this mean exactly? Are they straying ...


0

Yes, managing a DHCP server is completely optional for Cobbler. Just set manage_dhcp: 0 in your /etc/cobbler/settings file.



Top 50 recent answers are included