Tag Info

Hot answers tagged

4

Your rsync have probably messed up your rights with /root/ or /root/.ssh/ folders. Your /root folder owner is not root anymore and your chmod should be 700. The following commands should fix the problem chmod 700 /root chown root:root /root chown -R root:root /root/.ssh


3

Set the service to manual start. In the same script that you run to copy the files, start the service. This script can be run by the task scheduler as any user.


2

No, it will not be better with sshfs. It can't be, as with locally mounted remote file systems, the local rsync process has to read the file to see what needs to be copied. For this, the whole file has to be transported via the network.


1

sshfs won't help with this; what you need to do is add the -W option to tell rsync to just transfer whole files, without trying to figure out where the specific differences are. You might also need to remove --inplace (not sure about that). rsync is really designed for remote operations where there's an rsync instance (or daemon) on each computer, each with ...


1

Try rsync rsync -u <src> <dest> it will copy filest but if file exists it will skip files that are newer on the destination


1

The public key root login over SSH is likely your best bet. You could furthermore restrict this access to a single host: AllowUsers root@192.0.2.123 Or even use the Match directive to get a unique configuration for a given something (address, user, etc): Match Address 192.0.2.123 PasswordAuthentication no RSAAuthentication yes ...


1

It works for me: $ rsync --hard-links --recursive --link-dest=/local user@host:/remote/ /local I use rsync version 3.1.0. From man: --hard-links Tells rsync to look for hard-linked files in the transfer, without this option, hard-linked files in the transfer are treated as though they were separate files. --link-dest=DIR Unchanged ...


1

Just ran into this problem. And if you want rsync to treat symlinked directories as directories, you want the K option rsync -K /files/ user@server:/files/


1

I use duplicity instead of rdiff-backup but from my understanding your problem is here: My idea was to transfer data initially on physical media to remote server. After that transfer I synchronized the data by rync to make sure they are identical. Now I want to do intial rdiff-backup. Solution that works The simplest solution is to rdiff-backup to ...


1

The data.mdb file is actually a thin provisioned 86GB (by default) file. Rsync and sometimes cp commands will 'explode' the file to it's full size when copying to a backup directory. This obviously doesn't help if you want to create an offsite backup or if you are limited in resources. This behavior seems new in 8.0.1 The proper way to prevent this is to ...


1

No, rsync does not check the access time (atime) of a file. Instead, it use the modified and changed times (ctime/mtime) to check if a file changed. What you should pay attention, however, is that rsync is preserving mtime (-t option) in the fist place. If not, any further attempt will re-sync the same files. rsync -a includes '-rlptgoD' options, so if you ...



Only top voted, non community-wiki answers of a minimum length are eligible