Tag Info

New answers tagged

0

A hacky solution to this is to hardcode the path of the required gem in ruby's load path. file { '/etc/profile.d/rubylib.sh': content => 'export RUBYLIB=\'/var/lib/gems/1.9.1/gems/zabbixapi-2.4.0/lib\'' } This is bad for a number of reasons: Hardcodes version numbers Need to run puppet multiple times Need to log out and back in between puppet ...



Top 50 recent answers are included