Tag Info

New answers tagged

2

In an effort to get a fresh perspective on this problem, I started to configure a similar relayhost setup on another server and it was during that process that I finally traced what the source of the problem. Turns out in my sasl_passwd file I was missing a crucial character. sasl_passwd file before the fix: DomainB.name ...


3

For enable SASL when receiving email via smtpd, you need to put this parameter smtpd_sasl_auth_enable = yes For enable SASL when sending email via smtp, you need to put this parameter smtp_sasl_auth_enable = yes In your postconf output above, you only put smtp_sasl_auth_enable not smtpd_sasl_auth_enable. That's why postfix complain with error ...


2

AUTH is not part of basic SMTP, but of ESMTP. So in order to use AUTH, you need to start the SMTP session with EHLO instead of HELO.


2

You need to know the differences of smtpd and smtp in postfix. In short, smtpd was SMTP server that receive the email and smtp was SMTP client that send the email. Based on the article linked above, you need to adding three parameters into main.cf smtp_sasl_auth_enable=yes smtp_sasl_password_maps=hash:/etc/postfix/sasl_passwd smtp_sasl_security_options ...


0

I was wrong: The parameter smtpd_sasl_password_mapsdonĀ“t exist. I think you mistyped smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd - it has to be `smtpd_sasl_password_maps = hash:/etc/postfix/sasl_passwd



Top 50 recent answers are included