Tag Info

New answers tagged

0

Configuring postfix as a "Satellite system" made it work, per this article.


0

(My answer is similar to @Greenonline's but I'm posting it separately since code formatting in comments can get crowded). It should work but you need to be very specific on the formatting. 1) Edit /etc/mail/sendmail.mc 2) Add the following: LOCAL_CONFIG O CipherList=HIGH O ServerSSLOptions=+SSL_OP_NO_SSLv2 +SSL_OP_NO_SSLv3 ...


1

What is the error that you get when you enter your command..? However, you could try modifying the LOCAL_CONFIG section of the sendmail.mc file, instead of specifying the option on the command line. CipherList=HIGH ServerSSLOptions= +SSL_OP_NO_SSLv3 +SSL_OP_CIPHER_SERVER_PREFERENCE ClientSSLOptions= +SSL_OP_NO_SSLv3 Answer is modified from the source: ...


0

You should use a SMTP library like SwiftMailer in PHP to send mails via SMTP to the mail server instead of mail() function. This way you can use arbitrary From addresses in e-mails.


1

Permission Group: ms-Exch-SMTP-Accept-Any-Recipient Via PowerShell: (includes anti-spam bypass) Get-ReceiveConnector <RelayName> | Add-ADPermission –User “NAME” –ExtendedRights ms-Exch-SMTP- Accept-Any-Recipient,ms-exch-bypass-anti-spam


1

As far as I can see you just want to send mails. In this case you must not set an MX record for the server, as your mail server is not responsible for any domain. If I understand your problem, you really just want an MTA that relays your mails. Setting up a full fledged mail server for this purpose is overkill; so first here are a few alternatives: ...


0

For me it was a solution to comment out the following line in /etc/postfix/main.cf: non_smtpd_milters


3

As you write, it had to work. user1316146 is also right: gethostbyaddr is doing reverse ip lookups, which aren't needed for mail sending. The problem isn't here, on my opinion. I think, you have simply a noisy network or a not really reliable local dns. You had to configure your sendmail to try to get its target address more agressively, and many times. ...


7

No, it's not required to have, but you break some things by not having it (like logrotate). It's easier to just use iptables and block the ports.


1

Welcome to Serverfault! :-) Have you explicitly configured SendMail to use TLS? If not, out of the box, SendMail will still try to perform opportunistic TLS operations with a zero-byte client certificate. I assume this is what you're seeing? For more information on this (oddity?) check out @MadHatter's excellent response here: ...


3

gethostbyaddr is performing reverse DNS, so you need to have PTR records set up for the IP addresses in question. You also needs to have that address range delegated to you for public address. If you're using 8.8.8.8 as your DNS for the box, you're not going to be able to have PTR records for the 10.0.0.0/8 network. This lookup usually only occurs for ...


-2

To fix this issue, you need to: 1) Login to your Gmail account using the web browser. 2) Click on this link to enable applications to access your account: https://accounts.google.com/b/0/DisplayUnlockCaptcha 3) Click on Continue button to complete the step. 4) Now try again to send the email from your PHP script. It should work.


0

I figured out the answer on my own before I even got a single comment, or anything. The problem was this line here: dnl include(`/usr/share/sendmail-cf/m4/cf.m4')dnl I needed to uncomment it: include(`/usr/share/sendmail-cf/m4/cf.m4')dnl That was it...


-1

If you have PHP 5.3 and above, open your php.ini and find the following line mail.log = Write the full path to the file you want to make a log and give it chmod 664 access. so that you can read and write to it but no execution since its just a log file


3

I also changed the MX Records for the email service. I am able to send mails but not receive any mails. When I check on a MX lookup service I see my new records when I prefix www (www.abc.com) to the domain but just the domain name (abc.com) it throws up blank results. If you want to receive email for domain.com, the MX records need to be under ...



Top 50 recent answers are included