Tag Info

Hot answers tagged

21

As others have mentioned, disabling sftp isn't anywhere near sufficient - a user with unrestricted ssh access can view any file that their account has permissions to view, can modify anything they have permission to modify, and can easily download anything they can read to their own machine. The only way to stop them from doing this is to actually restrict ...


17

Comment out sftp support in sshd_config (and of course restart sshd): #Subsystem sftp /usr/lib/openssh/sftp-server


11

No. Microsoft offers an FTP over SSL (FTPS) solution but does not currently provide a solution for securing FTP traffic using FTP over SSH (SFTP)


10

Do not attempt to do this with .profile because it provides no security whatsoever and restricts exactly nothing! It doesn't matter what you put in .profile, since you can bypass it by simply giving a command to run on the ssh command line, like this: ssh user@host command. You can still get normal shell access by doing ssh -t user@host bash. Disabling the ...


8

The Microsoft IIS server does not support SFTP (or SSH) at all. On any version of Windows. It supports secure FTP (FTPS or FTP over TLS/SSL) though. It's different (incompatible) protocol than SFTP. But most "FTP" clients support both SFTP and FTPS. When setting up FTPS server, make sure you disable plain (unecrypted) FTP! See (my) guide Installing Secure ...


2

I assume that by "sftp client" you refer to an OpenSSH SFTP client. The "problem" is that when you press Ctrl+C, it stops the upload and cleanly closes the remote file, just as if the upload completely finished (note that it is a correct behavior and many other SFTP clients behave the same). So the server has absolutely no way to tell that the upload was ...


1

After looking over your iptables -L. I think you have a firewall issue on the server side. the ACCEPT tcp -- anywhere anywhere tcp dpt:ssh ctstate ESTABLISHED The ESTABLISHED usually means for connections that are active or already established. Add this line in your iptables sudo iptables -A INPUT -p tcp --dport ssh -j ...


1

If you are trying to login using SSH with the root account, by default on Ubuntu it'll just say no like you are experiencing. If you have to allow root access (highly dangerous), change 'AllowRootLogin' to yes. A much better approach would be to create a new user: $adduser serveradmin $passwd serveradmin (enter the password for the new account) Then you ...


1

Groups! addgroup yourgroup chgrp yourgroup /some/dir Add the users you want to share this directory to the group. usermod -g yourgroup user1 usermod -g yourgroup user2 Give group proper permissions to /some/dir. 775 is just an example. chmod 775 /some/dir Assign /some/dir as the home directory for your users. usermod -d /some/dir user1 usermod -d ...



Only top voted, non community-wiki answers of a minimum length are eligible