New answers tagged

0

The following is simple and awesome: python -m SimpleHTTPServer 8888 This starts a new http file server for current directory. Supposed there is a file named foo in current directory, you can download it like this: wget http://your.ip.here:8888/foo


0

The g+s bit on directories will impose the group-of-the-parent-directory (BSD style) instead of the default group-of-the-process (SysV style). So, something like chmod g+s /var/www (and also on any subdirectories) should cause the www-data group to be preserved on the creation of new files thereunder. Another option may be to use the so-called POSIX acls ...


0

ProFTPD's DefaultRoot directive can take an optional group expression, which says whether to apply the DefaultRoot to that user (based on their group membership), or not. For example, you might use: DefaultRoot /home/ftp/external external DefaultRoot /home/ftp The first DefaultRoot says to chroot users to /home/ftp/external if they are members of group ...


0

Try to use RSA keys instead of passwords Generate RSA keys on the server Copy to client use the rsa key instead of a password


0

Configuring ssh to enable only sftp for some selected users is a good idea and it works properly, provided that you you install either scponly or rssh. rssh works fine, unless you need to configure jail, in this case try to follow instruction provided by CHROOT manuals is crazy, leading to "copy" large parts of system executables and library just below ...


1

You can set-up SSH keys to every user, so they have to use private key to get access to SFTP server. Let clients generate private and public key by themselves and let them send public key to you, so you can add it to ~/.ssh/authorized_keys file. You can generate private and public key ofcourse by yourself but that means you need to send private key to ...


2

You have got typo in the sshd_config: Subsystem sftp intenal-sftp should be Subsystem sftp internal-sftp


4

It most probably means that the /usr/lib/openssh/sftp-server does not exist. Make sure the Subsystem directive points to an existing path: Subsystem sftp /usr/lib/openssh/sftp-server Or actually, nowadays you typically use the internal-sftp instead: Subsystem sftp internal-sftp See OpenSSH: Difference between internal-sftp and sftp-server.


0

this should handle it for you Match Group somegroup,!admin PasswordAuthentication yes ChrootDirectory %h X11Forwarding no AllowTcpForwarding no ForceCommand internal-sftp


0

Ok, the point I missed has something to do with the shell. I tried to login with /bin/false as described in many manuals. But that didn't work. As @Jakuje pointed out, changing that to /bin/sh for testing purposes allowed me to login via sftp. Hurray! And the interesting fact I also didn't know: internal-sftp already prevents ssh login. However, who ...


-1

As I see, you deployed your VM is Azure Service Manager (ASM) mode also know as classical mode. That means you are using Cloud Service and Azure Load Balancer. The cloud service is accessed using a VIP (Load Balancer), while the individual VMs are normally accessed using VIP:. By assigning an Instance Level IP to a specific VM, that VM can be accessed ...


6

Yes it probably does use mkdir(2) and open(2) (or something very similar). You could check by running strace(1) on your ftp daemon and exercising it e.g. strace -p <pid of ftp daemon>


0

Do you have the Subsystem for sftp enabled in your /etc/ssh/sshd_config file? The line might look like this: Subsystem sftp /usr/libexec/sftp-server (or your location of executable) On another server (Debian/Ubuntu Jessie): Subsystem sftp /usr/lib/openssh/sftp-server


1

No, it is not safe to configure your firewall as you indicated. Using a firewall configured using the rule in the image you linked would be a security risk because that rule effectively opens up ALL ports and all protocols. The reason your port 21 rule was not working was because FTP actually requires 2 channels to function, a command channel and a data ...


1

I think you don't need vsftpd server at all. OpenSSH server allows you to upload files using sftp. You configured vsftpd as ssl enabled ftp server (ftps). read more Also you can improve your server security using next simple steps: move ssh server to another port ex.Port 422; set PasswordAuthentication no use ssh keys only; setup firewall (for example ...



Top 50 recent answers are included