Tag Info

Hot answers tagged

4

Any decent internet provider will remove that block on a business account. Especially if you are paying for a static IP address, which would be best for running a mail server. Most probably will not remove it on residential accounts. The blocks are to prevent spam and email viruses spreading. Since the vast majority wont be running their own mail server ...


4

Unless I misunderstand your design, your relay server will be the one making a direct connection to remote mail servers. Therefore whichever public ip your relay uses should be the one seen (and checked and possibly reported) by the remote server(s).


4

You should be configuring phpmailer to connect to localhost, not to the hostname of the machine (which will then use its external IP address to connect). Localhost is allowed to relay mail through postfix by mynetworks, but when you connect with the hostname it's via the public IP address, which is not allowed to relay.


3

I don't know for certain, if Pigeonhole implements client SMTP AUTH, but I found no setting for it. On the other hand, you can use a sendmail script instead of SMTP to circumvent that limitation. See: # Binary to use for sending mails. #sendmail_path = /usr/sbin/sendmail # If non-empty, send mails via this SMTP host[:port] instead of sendmail. ...


3

As others pointed out your SMTP relay has probably changed something. Looks like they chagned their advertised authentication mechanisms. I don't know if swaks tells you which authentication mechanism it used in it's output, but you could try specifying an auth-type and see if you get through. The parameter for digest-md5 would be: swaks -s smtp.strato.de ...


3

To do what you said, you had to set the default transport to the port 587. It can be done with a default_transport = smtp:587 But it won't work, because most SMTP servers of the world simply don't have an open port 587. What you could do: you had to get an SMTP relay who were accepted your mails (on a port differing from 25), and allowed them to go out of ...


2

You should monitor the relay's IP - if this is the MTA doing the actual delivery, then delivery will fail if it gets into RBL/PBL


2

Ok - I worked out a solution to this - so I'm posting here in case other people want the solution. It turns out you dont need Postfix at all. I use SMTP4DEV, but there are many other similar programs that will 'capture' all SMTP emails for instant viewing and easy debugging. Install your SMTP capture program on your real computer. Have it listen to your ...


2

Honestly, the right thing to do is to pick the ISP where you put your main mail server a little more carefully. But assuming that's out of the question, I wouldn't do this at layer 3 (iptables), I'd do it at layer 4 (application, being SMTP), taking advantage of SMTP's inherent store-and-forward nature. The procedure looks somewhat like this: Set up a ...


2

SMTP provides no guarantee of delivery and no guarantee of timely delivery. the only thing you can do is rule out your systems as the cause of the delay. Here's what I would suggest: Find a sample email sent from your client and compare the time it got to your firewall against the time it got to your proxy and then against the time it got to your Exchange ...


2

What kind of error do you get? Relay not allowed? Generally, as far as I know, Exchange 2010 doesn't allow relaying mails (i.e. accept recipients that the server is not authoritative for). That's probably, why you can send mails to internal recipients. In fact, you should be careful not to block legitimate mail from outside your organization to enter the ...


2

Use transport_maps and relayhost feature from postfix. Edit main.cf, and add this two lines relayhost = smtp.b.example.com transport_maps = hash:/etc/postfix/transportmaps The above file (/etc/postfix/transportmaps) should contain something like: a@example.com smtp.a.example.com b@example.com smtp.a.example.com Don't forget to postmap that file.


2

This problem was bugging me for a while. I was trying to connect from server1.domain.com to server2.domain.com. Here's how I fixed this - #/etc/postfix/main.cf mydomain = server1.domain.com myhostname = $mydomain virtual_alias_maps = hash:/etc/postfix/virtual alias_database = hash:/etc/postfix/virtual myorigin = /etc/mailname mydestination = ...


2

Question What Linux tool can immediately (without queueing) relay e-mails to recipient SMTP server and provide valid bounce messages? Or, if there is better solution of this problem, what tools should I look at? The postfix itself has MULTIPLE INSTANCE feature. It will lets you define separate instance of postfix that have its own queue and ...


2

Maybe. This is called backscatter, and some services do take it into account in computing IP reputation, and some blacklists operate exclusively based on backscatter.


2

Your colleague is right. As Michael Hampton said, that behaviour generates backscatter mail, which is seen usually as spam. Frequently, spammers forge the "mail from" address, and also many times they bruteforce addresses to send to. You will likely get lots of spam of this kind: a forged remitent and a bruteforced non-existent mailbox as destination at ...


2

Use a valid sending address from your domain. localhost.localdomain is NOT a valid Internet domain. Consider using a noreply address, for which you track bounced email. If you want users to be able to reply use a Reply-to: header with the address to which replies should be sent.


2

There are multiple solutions. All are described in the documentation: http://www.postfix.org/ADDRESS_REWRITING_README.html#delivering


2

Postfix multi instance is a postfix feature that you are looking for. You need two instance. First instance was null client instance. It will act as system to handle email from PHP apps. Configuration of this instance looks like the describe in this documentation except you must add this parameter smtp_bind_address = my.first.ip.address Second instance ...


1

In the section Simple content filter example, you can use pipe (e.g. stdin) to receive the mail body. In advanced ones, your script must capable to act as both SMTP server and SMTP client. As SMTP server, postfix will use SMTP to give email to script. So your script must handle SMTP transaction on your own. Spawn process doesn't do it to you, instead it ...


1

In postfix 2.10, new parameter smtpd_relay_restrictions was introduced. This restriction will evaluated BEFORE smtpd_recipient_restrictions. Snippet from official documentation smtpd_relay_restrictions (default: permit_mynetworks, permit_sasl_authenticated, defer_unauth_destination) Access restrictions for mail relay control that the Postfix SMTP ...


1

relayhost is only used when you are sending email that is routed to a 'remote' host. Since you have your postfix installation with the testingserver.com as myhostname, and you are trying to send the test email to a @testingserver.com email, postfix will rule this email local and will deliver it to the local user. Your configuration should work, just test ...


1

sendgrid uses password based authentication (config details for that below). It won't care about your IP, or the hostnames you use (myhostname, myorigin, etc). The hostname your server presents to sendgrid in the HELO (or EHLO) greeting is likely to appear in mail headers. Some recipients' spam software may check it, so use something that does exist in ...


1

First, most third party SMTP gateway providers support using their service as a authenticated, encrypted relay host: sendgrid documentation Dyn documentation AWS SES documentation mailjet documentation mailgun documentation etc. etc. etc. The key is, you shouldn't have to do access control using IP addresses or hostname. You use encryption (TLS) and ...


1

I have a similar set up relaying via mailgun. Firstly, you can get the public IP of an instance using: http://169.254.169.254/latest/meta-data/public-ipv4 From within the instance, in my case I use orchestration (ie. Chef + OpsWorks) to automatically create a DNS record in Route53 for the instance on boot. You could probably also use: ...


1

It looks like you are connecting to the wrong SMTP port or you have a bad smtpd_recipient_restrictions. Most SMTP setups have open ports 25 for other servers delivering mail to local accounts (and 465 for the TLS variant) and an additional port 587 (called submission) for local users sending mail to foreign hosts. You can activate these in the master.cf and ...


1

You'll need to go into Exchange System Manager and setup your relay that way. After you're in ESM expand the organization, then the servers, then expand the server name, and finally expand Protocols. Select Relay. The rest is basically making sure that only the IP of the server/program your company uses is allowed to relay is set right; meaning only allow ...


1

If you're using a relayserver, i guess you use the smarthost configuration of exim. If so, then you just need to identify the routeur that takes care of routing mail to smarthost, and define a transport for this router that uses the smtp driver but on port 587: remote_submission: driver =smtp protocol = smtp port = 587 You can also edit the default ...


1

Assuming both parts where you obfuscated the real domain name are actually the same name (example.com and mail.example.com) the likely situation is that you are using internal nameservers (which is 192.168.1.201) that have an MX record defined for whatever example.com really is and it's simply using that record. That's how SMTP normally works when ...


1

Yes, that's what the transport table is for, depending on what you use (SQL, dbm, flat text files, etc) the setup is fairly simple. On the slave you'd create an entry like this client.domain smtp:[ip.of.the.master] That will mean that when the slave server receives mail for that domain, it will use smtp to relay it to your master server, who will then ...



Only top voted, non community-wiki answers of a minimum length are eligible