Tag Info

Hot answers tagged

6

I'll start with two practical answers The first and most obvious answer is that in a case where there's a temporary DNS error, a temporary bounce will allow the sender's mailserver to try again until the DNS error is fixed. In this case, a permanent bounce will block actual ham mail from reaching you. The second answer is that a great deal of spam is sent ...


4

The MailDir tree should be owned by the user that is getting the message delivered. You can fix the home directories with this little script. cd /home for dir in *; do [ -d $dir ] && chown -R $dir $dir done This will reset each users home directory tree to be owned by that user. In the rare case that the home directory name does not match ...


4

The parameter can only be set once, so you will not be able to dynamically change it, however you can override it in Postfix's master.cf file as explained in this SF answer. The only way (that I know of) is for you to run several Postfix instances as you suggested, however for the sake of a SMTP banner, I personally think this is overkill.


4

I've been running my own email server for 17 years, including hosting a large mailing list, and although it takes time I find it's perfectly possible, even today. Most of what should be done, you're already doing; but one factor you don't address is what kind of IP address you're using. Many mail providers outright blacklist (or use as a strong marker for ...


4

postfix/smtpd - This is typically the SMTP daemon process for handling incoming mail and routing to the appropriate internal location. postfix/smtp - This is typically the SMTP daemon process for delivering mail out to the world. If you're seeing alot of postfix/smtp log entries, these would be all of the SMTP connections sending spam out to other nodes. ...


3

You can do this with Enable-ExchangeCertificate in the EMS by specifying None for that certificate. https://technet.microsoft.com/en-us/library/dd351257(v=exchg.141).aspx


3

If outgoing port 25 is blocked you cannot send email because you won't be able to connect to the remote MX. What I would do is setup in a different hosting provider a machine that is allowed to send email and set it up to relay from your VPS listening in a different port (e.g.: 1025), then you could configure your sendmail to forward all the emails to that ...


2

The dot is used to terminate the message of an email in the SMTP protocol: An empty line (CR, LF), followed by single dot and again a newline with CR and LF. But this is clearly not the case here. To find out if these SMTP-clients are just botnets or legitimate senders, you can have a look at the PTR of their IPs, they are both logged. If the PTR is a ...


1

If you have exposed you mail server to the Internet, expect most of the connections to be from spambots, and other illegitimate senders. I would consider just matching rejects for any Errors in fail2ban. legitimate senders should rarely generate and error, and will retry later if they do get banned. I do some nasty things to suspected spammers, and it ...


1

Don't give up hope completely. Running your own mail server is sometimes a pain but it sounds like you're doing everything right. Generally I would say if they aren't blocking you outright (i.e. you get bounces back) then it's a content issue. Try adjusting the content somewhat. Microsoft aren't the best at anti-spam but they try hard for their users - ...


1

You can specify the path to php.ini passing option --php-ini FILENAME to the php executable. Try again giving the path to the php.ini used by the webserver.


1

Setting up a postfix server that accepts this domain might help with what you are looking for. Any low cost VPS server should be sufficient.


1

Why worry about forwarding e-mail from spammers? Reject or defer any remote messages on connections that aren't authenticated. If you defer, any misguided legitimate server will eventually deliver according to your MX. If it is a spambot, they will usually not retry in either case. You can reject or deny as early as the "MAIL FROM" command. By that ...


1

I found the problem: The cause was not the SMTP-Server feature itself but the IIS-ODBCLogging feature that was required by the SMTP-Server. The installation of this IIS related feature failed due to a permission problem: It seemed that the installer had problems to update the IIS configuration which is stored on a network share (for sharing it between ...


1

This is going to be an incomplete answer but I hope it gets you on track. The transport you specified in your transport table has to point to something Postfix knows about (and a transport has nothing to do with your aliases). That is, "mailman" needs to be defined in master.cf. Most postfix installations come with an example mailman service in master.cf ...


1

You need to add opendkim as a milter to postfix. Make sure these two lines are in postfix's main.cf: milter_protocol = 2 milter_default_action = accept Then add opendkim to your milters: smtpd_milters = inet:localhost:8891 non_smtpd_milters = inet:localhost:8891 I would also add localhost to the TrustedHosts file for opendkim since it's possible that ...


1

You can certainly configure Google Apps to use an internal SMTP relay -- but, as you've discovered running an e-mail server is filled with caveats. Generally, I recommend offloading the SMTP service to your external provider. At the minimum, you want to setup: Valid hostname Reverse DNS (PTR record in the ARPA zone) DKIM (Domain Keys Identified Mail) DNS ...


1

ASA 5506X not only by default masks SMTP banner, but also scrambles ehlo replies, like shown below, where XXXX are ASA inventions. They must have a fancy idea about security those who implemented this "feature". Anyway. I had no clue that the default filtering was on for ESMTP, as the graphical interfaces shows no rule and lowest security. ehlo ...


1

(Shamelessly copied from http://stackoverflow.com/a/29939735/32453) You can configure Ubuntu to prefer IPv4 over IPv6. This way you will be able to send emails and access IPv6-only sites. Edit /etc/gai.conf and uncomment the following line: precedence ::ffff:0:0/96 100



Only top voted, non community-wiki answers of a minimum length are eligible