Tag Info

New answers tagged

2

Most setups include the domain in the username. (At least most of mine.) Try: echo -ne '\0username@domain.com\0password!'|base64


2

You are mixing up smtpd_sasl and smtp_sasl, the first is for users authenticating on your server to submit emails for delivery, the latter is used when postfix does not deliver directly but also through a relay and postfix itself authenticates. Unfortunately, when connecting to my server with the username and password, I keep getting authentication ...


2

Use error:nouser 550 ... or error:5.1.1:550 ... as virtusertable value as suggested in virtusertable section of cf/README. info@example.com error:nouser 550 No such user here info@example.net error:5.1.1:550 No such user here RFC5321 describes (subtle) difference between the two error codes. 550 Requested action not taken: mailbox unavailable (e.g., ...


1

You've got Yourself a SSL certificate for your domain, I think you have exported certificate without private key. A ".cert" (or ".cer" or ".crt") file usually contains a single certificate, alone and without any wrapping (no private key, no password protection, just the certificate). Ex- Some CAs store the certificate's private key in a Private Key (.pvk) ...


1

Either you or the CA had to create a private/public key pair, before the CA signed the public key. You need the private key in order to decrypt the TLS traffic. If you created the key pair, then you have the private key file. If the CA created it, then they have it and you need to get it from them.


3

The 550 and 553 error codes should all be treated the same by the sending server as will any of the 500 series codes. These all indicate a permanent error condition. The 550 indicates the requested action (add recipient) was not completed. The 553 error indicates that the mailbox name is invalid. In either case the recipient was not accepted.


1

The shodanshok's comment is right: If you can't telnet the SMTP server, the connection is blocked at the gateway or server level. So I opened a ticket for Digital Ocean's support and got the following response: To curb a recent increase in abuse and SPAM, we have an initial SMTP block on new accounts created in certain contexts. To remove ...


0

What is blocking your connections is SELINUX, probably. To diagnose, follow these steps: issue setenforce 0 and re-try connections to the SMTP server if it works, re-enable SELINUX by issuing setenforce 1 and enable the specific permission you need through setsebool -P httpd_can_network_connect on


3

There certainly is a difference in how mail servers behave in that case. Ideally the receiving mail server will reject the RCPT command, in which case the mail content will never be delivered to the target server in the first place. In a much less ideal scenario (which is unfortunately often seen in practice anyway), the mail server will accept the RCPT ...


1

This error Sender address rejected: not owned by user xxx; came from this restriction on submission port (master.cf file) submission inet n - n - - smtpd ... -o smtpd_sender_restrictions=reject_sender_login_mismatch ... As explained in man 5 postconf, reject_sender_login_mismatch Reject the request when ...


2

SMTPS means SMTP over TLS, like with HTTPS. So first a TLS connection is established (without fallback), and then STMP is started. Just as nobody expects HTTPS on the HTTP-Port 80, you should not expect that anybody who connects to your STMP-service sends TLS requests. Thus, all connections to your server on port 25 will likely fail, if you enforce TLS! ...


0

Convert OP comment to CW Now I could solve. I tell them if anyone happens the same error. In /etc/cyrus.conf replace this line lmtp cmd="lmtpd" listen="backend:lmtp" prefork=1 maxchild=20 babysit=true maxforkrate=2 proto=tcp4 maxfds=256 -U 5 -T 10 with lmtp cmd="lmtpproxyd" listen="lmtp" prefork=1 maxchild=20 maxforkrate=2 proto=tcp4 maxfds=256 -U 5 ...


4

I'm not an expert in either dovecot or postfix, but it looks like you have postfix configured to use Maildir style mailboxes, but you're telling dovecot to use mbox style mailboxes. Take a look at the postfix docs for the home_mailbox config option, or the dovecot docs for the mail_location config option to figure out which one you need to change (and ...


0

So I've just fixed this error by looking at my GoDaddy hosted domains (the ones that are not using CloudFlare) and adding some CNAME's and changing my MX records from what I posted in the question to: MX 300 0 smtp.asia.secureserver.net. MX 300 10 mailstore1.asia.secureserver.net. Basically I've just added ".asia" before "secureserver.net".


3

Possible solution When sending an email, the parameter used to control outgoing IP address was smtp_bind_address. So you should explicitly set parameter smtp_bind_address to one IP address. Explanation Your configuration above, you already modified inet_interfaces parameter. It only set which IP Address that postfix will receive mails on. However, ...


2

The issue ended up being that a DNS server in the network actually had entries for when it was originally installed that were directing MX look ups to the old postini addresses. We never noticed because mail from that server was making it through. I was looking right past that at the error and ignoring WHO was responding. Deleting those MX records and ...


0

You should set up a receive connector operating on a non-standard port (maybe 2525) and restrict it to only accept IP addresses of servers that you know are allowed to send out. Create the connector with nothing ticked in Authentication and Anonymous users ticked for permissions groups. After that you'll need to run the following command in PS as Exchange ...


2

I encountered "fatal: unknown service: smtp/tcp" error because the SMTP daemon ran chrooted (which si default behavior on Debian for example) and the chroot environment wasn't properly set up. Check out official documentation. To properly set up chroot environment you should use script for your platform provided in directory examples/chroot-setup in the ...


1

Is your domain (which from SMTP transcript seems to be example.com in proxy:mysql:/etc/sentora/configs/postfix/mysql-relay_domains_maps.cf? Because your mydestination, which could lead to the mail being accepted, only includes localhost.hostname.domain.com and localhost. Edit: i was not trying to tell you to add the domain in the mydestination list. Since ...


1

I assume the domain name in the MAIL FROMand RCPT TO commands is the same and registered in Google Mail. The problem might be that Google Mail doesn't accept mail that comes from outside and has a known domain as a sender. "Hey! You are not me! I" Things to check out: Is your internal mail server permitted in your SPF record. Validate your SPF. Is your ...


0

You don't specify your mail software but there are a number of options for this case. They can be combined. (I would recommend the first for all hosts not providing MX services. It should resolve your issue.) Configure the mail server to listen on the local host interface(s) (127.0.0.0, ::1) only. Configure the mail server to use a common server as a ...


1

What McAfee told you is definitely the recommended approach here. Spammers intentionally try direct connections for the exact reason you pointed out - they're trying to bypass perimeter defenses. The specifics depend on your environment, preferences, and details from McAfee. Here are some links to get you started: ...


0

Most email services have a built-in blind carbon copy (BCC:) function. Using this function will cause the server to make a duplicate of the email and send it to the address that is specified; the regular message continues to be delivered to the user. I haven't touched sendmail in years, but I know for certain that postfix has this feature. It took some ...


0

I edit my firewall and allow port 25 and smtp started working right after I do a restart for the smtp relay server.


1

Your NAT scenario "Assume there is no way for the 30 mail servers to know what IP address they are getting on the outside" is broken in the context of reliable SMTP delivery. It's quite simple. A reverse DNS record can only reliable map back to one host-name. I.e. 2.1.168.192.in-addr.arpa. will only map to smtp1.example.com. The same holds for the ...


-1

Im not too sure about Roundcube as I still use Squirrelmail, but I know having the proxy: in front of mysql: can cause issues with the virtual look up called in php. This may not be THE answer but its something to try. Roundcube does require direct mysql access to add both the sender and the recipient addresses to the SQL database. these are verified by the ...


0

As said above in comments, postfix isn't configured as an open relay. Again as said above, there was a vulnerability in one of my nginx websites. The problem was "solved" by shutting down unused websites. The only one which I believe could have been attacked is an empty and unconfigured dokuwiki. Now I still see connexion attempts like Mar 8 02:17:57 ...


1

I found the problem. As you can see in the log: Mar 6 11:00:51 ubuntu postfix/smtp[19925]: 07BF424E7A: to=<matangivoni@yahoo.com>, relay=mta6.am0.yahoodns.net[66.196.118.33]:25, delay=1.1, delays=0.02/0.01/0.86/0.18, dsn=5.7.1, status=bounced (host mta6.am0.yahoodns.net[66.196.118.33] said: 553 5.7.1 [BL21] Connections will not be accepted from ...


1

Your mail from the gitlab instance has been accepted by your postfix Mar 6 10:58:32 ubuntu postfix/qmgr[12506]: 5BEE724E74: from=<gitlab@ubuntu>, size=630, nrcpt=1 (queue active) But delivery to the destination does not work here: Mar 6 10:59:02 ubuntu postfix/smtp[19746]: 5BEE724E74: to=<admin@example.com>, relay=none, delay=30, ...


2

If you can't make the business case you might want to reconsider moving the SMTP services completely in-house: Decide on a primary e-mail domain, run that in-house and leave all other domains on an external mailhost where you map those secondary e-mail addresses to "real" mailboxes on your primary domain. The exact method depends a bit on the mailserver ...


1

It seems you are not enabling SSL on the port 465 nor using different settings for your smtp submission server. This means you might have the same settings on port 465 than on port 25. Thunderbird is then trying to establish SMTPS connection but answered in plain text. Submission is a whole different setup from plain SMTP and certainly needs an ...



Top 50 recent answers are included