Tag Info

Hot answers tagged

10

Check the command that starts snmpd (possibly somewhere /etc/rc.d/ - in Ubuntu it's /etc/defaults/snmpd) for the logging options: SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid -g root 0.0.0.0' Or find it in the ps aux | grep snmpd output. The man page gives the logging options: -Ls FACILITY Log messages via syslog, using ...


8

You can have a look at this page. It shows you the top-level MIB tree. When referring to OID like: 1.3.6.1.4.1.8072, you are referring to : iso.org.dod.internet.private.enterprise.your_company So, this is the convention used. Otherwise, you may have conflict with existing MIBs. Note that your_company is not just some number you can make up yourself -- It ...


8

As twalberg suggests, this is probably a 32-bit overflow problem. SNMP Interface Counters in are 32-bit (unsigned) by default. If your SNMP daemon and server OS support 64-bit counters they can be found in the ifXtable MIB (.1.3.6.1.2.1.31.1.1)


5

In order to set the minimum priority to LOG_WARNING, (which is what I usually use) simply change the argopt: -Lsd to -LSwd Which stands for: S: syslog, priority comes next w: (or 4) log only warnings and more relevant messages d: use the LOG_DAEMON facility As stated in the man (but actually missing a clear example): For -LF and -LS the ...


4

according to the snmp documentation; `extend [MIBOID] NAME PROG ARGS works in a similar manner to the exec directive, but with a number of improvements. The MIB tables (nsExtendConfigTable etc) are indexed by the NAME token, so are unaffected by the order in which entries are read from the configuration files. There are two result tables - one ...


4

Usually when you get silence like that, especially from a snmpwalk or snmpget, it means that the device isn't getting your query, isn't using the snmp version you think it is, isn't configured to accept queries from your IP address, or isn't accepting your community. Confirm that snmp is on, that the version and community is correct, that any query-based ...


4

rocommunity public default -V systemonly Your read-only community string is public. default represents what traffic will be accepted, which is to say all traffic will be accepted. Change default to be a hostname or a network address and slash annotated subnet to restrict it further (e.g. 10.4.0.0/16). The read-only context will be restricted to the -V ...


3

Forget about installing from source code; packages are already available. yum install net-snmp net-snmp-utils


3

Could you try this command (OID is from Cacti log): snmpwalk -Cc -On -v 1 -c public 127.0.0.1 1.3.6.1.4.1.2021.11.52.0 If you don't get a result like .1.3.6.1.4.1.2021.11.52.0 = Counter32: 250038, then edit /etc/snmp/snmpd.conf adding or decommenting: rocommunity public localhost And restart snmpd using one of: /etc/init.d/snmpd restart service ...


3

I have solved this issue, and for reference if anyone else is facing this problem it's to do with the /etc/hosts.allow file. Add this line snmpd: xxx.xxx.xxx.xxx Where xxx.xxx.xxx.xxx is the ip address of the client querying the snmpd service.


3

This restarts snmpd: svcadm restart net-snmp By looking at svcs -a | grep snmp I realized the service is named net-snmp and not snmp, snmpd, or snmpdx. Opensolaris and snmp are both new to me.


3

The controller state requires that both the Controller Firmware and the kernel module (driver) be up to date. Once I updated both of those the controller state changed to "Ready."


3

I completely remove the "-Lsd" directive from the /etc/sysconfig/snmpd.options file in CentOS/Redhat installations, leaving a file that reads: # snmpd command line options OPTIONS="-Lf /dev/null -p /var/run/snmpd.pid -a"


2

view systemonly included .1.3.6.1.2.1.1 view systemonly included .1.3.6.1.2.1.25.1 rocommunity public default -V systemonly Since you are connecting with the public commit you are limited to only the mibs define by systemonly. You may want to remove the -V systemonly bit.


2

The design of the Extend MIB is that you would query the nsExtendConfigTable looking for the index that corresponds to the correct name, specified in the extend directive. Once you have that index, you can then query the tables nsExtendOutput1Table and nsExtendOutput2Table. So, to answer your question, the OIDs will change, but are programmatically ...


2

Net-snmp can be configured to make internal SNMP query and send traps from DISMAN-EVENT-MIB when disk usage exceeds defined threshold. In order to send traps for the disk usage, add the following lines to snmpd.conf and restart the agent: # trap target and community trap2sink localhost public # authorization for self monitoring createUser ...


2

Look at the exec section of the net-snmp man page. As far as getting an snmp server to poll that, it greatly depends on what you're using.


2

Are there any other com2sec or rw/rouser lines in your configuration? Is iptables enabled on either the source or destination host that would prevent UDP traffic?


2

You've said that the script is located in /tmp; is your /tmp partition mounted noexec by any chance? That can be an occasional source of confusion.


2

For Ubuntu 12.04 (which was causing the same messages for me) the full steps to get SNMP working appear to be as follows : Install snmpd : apt-get install snmpd Ensure the multiverse repository is enabled : apt-get install python-software-properties add-apt-repository 'deb http://archive.ubuntu.com/ubuntu precise multiverse' apt-get update Install the ...


2

Check out the man page for snmpd.conf - agentaddress [<transport-specifier>:]<transport-address>[,...] defines a list of listening addresses, on which to receive incoming SNMP requests. See the section LISTENING ADDRESSES in the snmpd(8) manual page for more information about the format of listening address ...


2

On Debian with 5.4.3 snmpd dosn't seem to load all it's modules by default, by adding: -I interface,ifTable,ifXTable,cpu,cpu_linux,hw_mem,extend,versioninfo,snmp_mib,ip,at,system_mib to the command line for snmpd (note the 'extend' in there), i can: snmpwalk -Ou -v 1 -c public localhost nsExtendOutput2Table which returns the default 'extend' examples: ...


2

At a minimum, you need to define trapsink, trap2sink or informsink in /etc/snmp/snmpd.conf to specify the host to send SNMP traps to. You can also specify the community string and an alternate port number (if not using 162). You can also set a trapcommunity for a default community string to be used when sending traps. For sending v3 traps, use trapsess. ...


1

Turns out the issue was DNS look ups timing out so I just pushed the -n flag to the options lines in /etc/defaults/snmpd. This was on Debian 6.0. # snmpd options (use syslog, close stdin/out/err). SNMPDOPTS='-Lsd -Lf /var/log/snmpd.log -n -u snmp -g snmp -I -smux -p /var/run/snmpd.pid' # snmptrapd options (use syslog). TRAPDOPTS='-Lsd ...


1

You'll want the cron job to look more like this: /usr/sbin/service bsnmpd status >/dev/null ; if [ $? != 0 ] ; then /usr/sbin/service bsnmpd start ; fi Anyway, let's figure out why bsnmpd is core dumping. See if you can find the bsnmpd.core file, then run /usr/bin/gdb /usr/sbin/bsnmpd bsnmpd.core then run bt and paste the output.


1

Snmpbulkwalk initiates internal server repetitions to walk through mib tree. Server does not respond untill it retrives "max-repetitions" number of variables or end of mib tree is reached. Retrieving some variables may demand valuable time. Important note: snmpwalk walks trough a requested subtree exactly but snmpbulkwalk may retreive additional variables ...


1

In RHEL there're two configuration options, according to "man snmp_config", added in BZ#917816 enhancement. # include site specific config includeFile site.conf # include a all *.conf files in a directory includeDir /etc/snmp/config.d


1

snmpget -v 2c -c PUBLIC 10.38.2.24 1.3.6.1.2.1.2.2.1.10 snmpget -v 2c -c PUBLIC 10.38.2.24 1.3.6.1.2.1.2.2.1.16 -c communityname, default to PUBLIC -v version, probably 2c SNMPget: Net-SNMP


1

rocommunity public But please rethink this. Letting anybody in the world get your SNMP data is generally a bad idea.


1

You need to use -o option in addition. For example: monitor -o 1.3.6.1.x -o 1.3.6.2.y -I -u root -s -t -r 18 "Warn: High ipp Usage" -e ifMtu.1 1.3.6.1.2.1.2.2.1.4.1 != where: 1.3.6.1.x and 1.3.6.2.y are two additional varbinds added to SNMP PDU payload and defined by these OIDs. You may also refer to: man page of snmpd.conf do



Only top voted, non community-wiki answers of a minimum length are eligible