New answers tagged

-2

do a tracert -d [serverIP] on the destination IP to see where the packet is dropped. Could be a firewall blocking the way on your parameter or on the remote side !!


3

The text after the key is just a comment. It is the comment that is added when the key is generated. You can change it to be whatever you want or even remove it. It is there because ssh-copy-id does exactly what it says and just copies the public key to the remote machine. This is documented Protocol 2 public key consist of: options, keytype, ...


1

The poster who referred to SElinux hit the nail on the head for my problem, I don't want to use selinux but had forgotten to disable it, and server came up with selinux enabled on boot. ssh -v Debug helped. The key is accepted: debug1: Found key in /var/lib/amanda/.ssh/known_hosts:19 debug1: ssh_rsa_verify: signature correct And then I get the error ...


0

I managed to get it done by Stopping the instance detaching the drive created a new instance with new keypair stopped it detached drive attached original drive started instance in the web console previous employees keypair gone, replaced with new keypair name. downside is that the new keypair will not allow me to get the windows admin password. moral of ...


1

The other answers here are great, assuming that the destination server already has the .pem file's public key. In my case, I created a .pem file to access an existing server, which was not configured for my newly generate key. So here is how I managed to set up my server for access using my newly created .pem key: Create the public key from the .pem file: ...


1

ControlPersist in combination with ProxyCommand is not effective and you miss ControlPath option. But it is not a problem here. First of all, if you are using non-standard config file and you want it to be used even by the proxy command, you need to specify it even there. The -q option makes the connection quiet so you have no idea what is going on under ...


0

Verify that key formatting didn't get munged. If the ssh client cannot read in the key properly, I've seen instances where it thinks it's an encrypted key and will ask for a passphrase.


2

In order to disable authentication using password, you have to disable the following settings in the configuration file of your sshd server (generally /etc/ssh/sshd_config): ChallengeResponseAuthentication no PasswordAuthentication no UsePAM no Then reload the configuration: $ sudo service ssh reload


0

I haven't tried it as I don't use Windows instances, but this AWS documentation suggests deleting the user in IAM revokes their access. I'd be surprised if you had to do the work you described just because one user in your organisation happened to create a server then leave the company. This is very easy to try. I'm incorrect please do comment so I can ...



Top 50 recent answers are included